aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-06-11 16:22:01 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-06-11 16:22:01 +0000
commit65a154db1484ea5fe26a0d2e6ee26f7fc772eeac (patch)
tree65600a337f581d6295f43cf46ffc06b8aab59dca
parent0f7982a4fde339171ac73804d8b30ec82b04fff4 (diff)
downloadports-65a154db1484ea5fe26a0d2e6ee26f7fc772eeac.tar.gz
ports-65a154db1484ea5fe26a0d2e6ee26f7fc772eeac.zip
MFH: r415944 r416225 r416711
Update to upstream version 2.2.3 Differential Revision: https://reviews.freebsd.org/D6373 Fix build with libc++ 3.8.0 VLC brings its own header for atomic operations which defines a whole bunch of atomic macros, conflicting with the ones in the C++ standard <atomic> header. This changeset works around those. PR: 209722 Submitted by: dim Update to upstream release 2.2.4, fix remote attack CVE-2016-5108 Detailed changelog (BSD relevant excerpts): Decoder: * Fix crash in G.711 wav files * Fix mp3 crash in libmad * Fix out-of-bound write in adpcm QT IMA codec (CVE-2016-5108) Qt: * Fix resizing issues Translations: * Update of Bulgarian, Catalan, German, French, Italian, Marathi, Norwegian Bokmål, Norwegian Nynorsk, Portuguese, Slovak, Spanish (Mexico), Swedish, Simplified Chinese, and Traditional Chinese translations Security: CVE-2016-5108 Approved by: ports-secteam (junovitch)
Notes
Notes: svn path=/branches/2016Q2/; revision=416726
-rw-r--r--multimedia/vlc/Makefile4
-rw-r--r--multimedia/vlc/distinfo5
-rw-r--r--multimedia/vlc/files/patch-configure21
-rw-r--r--multimedia/vlc/files/patch-include_vlc__atomic.h17
-rw-r--r--multimedia/vlc/files/patch-include_vlc__playlist.h19
-rw-r--r--multimedia/vlc/files/patch-include_vlc__sout.h22
-rw-r--r--multimedia/vlc/files/patch-modules_gui_qt4_dialogs_messages.hpp11
-rw-r--r--multimedia/vlc/files/patch-share-lua-intf-cli.lua11
-rw-r--r--multimedia/vlc/files/patch-vendor-00-ce9145229
-rw-r--r--multimedia/vlc/pkg-descr2
-rw-r--r--multimedia/vlc/pkg-plist2
11 files changed, 92 insertions, 51 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 8d5c6105c3dd..908e070d9989 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= vlc
-DISTVERSION= 2.2.1
-PORTREVISION= 8
+DISTVERSION= 2.2.4
PORTEPOCH= 4
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
@@ -53,6 +52,7 @@ CONFIGURE_ARGS+=--enable-debug
.endif
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS_i386= -fomit-frame-pointer
+LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= A52 AALIB ASS AVAHI CACA DBUS DCA DIRAC DOCS DVDREAD \
DVDNAV FAAD FLAC FLUID FRIBIDI GME GNOMEVFS2 GNUTLS \
diff --git a/multimedia/vlc/distinfo b/multimedia/vlc/distinfo
index e5b2f1487ed1..07b00df8df17 100644
--- a/multimedia/vlc/distinfo
+++ b/multimedia/vlc/distinfo
@@ -1,2 +1,3 @@
-SHA256 (vlc-2.2.1.tar.xz) = 543d9d7e378ec0fa1ee2e7f7f5acf8c456c7d0ecc32037171523197ef3cf1fcb
-SIZE (vlc-2.2.1.tar.xz) = 20940288
+TIMESTAMP = 1465555959
+SHA256 (vlc-2.2.4.tar.xz) = 1632e91d2a0087e0ef4c3fb4c95c3c2890f7715a9d1d43ffd46329f428cf53be
+SIZE (vlc-2.2.4.tar.xz) = 22199316
diff --git a/multimedia/vlc/files/patch-configure b/multimedia/vlc/files/patch-configure
index fd0befa99924..331811b65505 100644
--- a/multimedia/vlc/files/patch-configure
+++ b/multimedia/vlc/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig
+--- configure.orig 2016-04-05 00:45:51 UTC
+++ configure
-@@ -8461,9 +8461,6 @@ case "${host_os}" in
+@@ -8471,9 +8471,6 @@ case "${host_os}" in
;;
freebsd*)
SYS=freebsd
@@ -10,7 +10,7 @@
;;
openbsd*)
SYS=openbsd
-@@ -26098,7 +26095,7 @@ main ()
+@@ -25539,7 +25536,7 @@ main ()
return 0;
}
_ACEOF
@@ -19,7 +19,7 @@
ac_cv_c_o4=yes
-@@ -26142,7 +26139,7 @@ main ()
+@@ -25583,7 +25580,7 @@ main ()
return 0;
}
_ACEOF
@@ -28,7 +28,7 @@
ac_cv_c_o3=yes
-@@ -27336,7 +27333,7 @@ _ACEOF
+@@ -26777,7 +26774,7 @@ _ACEOF
if ac_fn_c_try_compile "$LINENO"; then :
ac_cv_altivec_inline="yes"
else
@@ -37,7 +37,7 @@
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -27349,7 +27346,7 @@ asm volatile("vperm 0,1,2,3");
+@@ -26790,7 +26787,7 @@ asm volatile("vperm 0,1,2,3");
}
_ACEOF
if ac_fn_c_try_compile "$LINENO"; then :
@@ -46,3 +46,12 @@
else
ac_cv_altivec_inline=no
fi
+@@ -49199,7 +49196,7 @@ fi
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+
+- as_fn_error $? "\"You cannot build VLC with Qt-5.5.0. You need to backport I78ef29975181ee22429c9bd4b11d96d9e68b7a9c\"" "$LINENO" 5
++ $as_echo "Qt-5.5.x found. Ensure Qt I78ef29975181ee22429c9bd4b11d96d9e68b7a9c is backported." >&5
+
+ fi
+
diff --git a/multimedia/vlc/files/patch-include_vlc__atomic.h b/multimedia/vlc/files/patch-include_vlc__atomic.h
new file mode 100644
index 000000000000..064bf0f4c58f
--- /dev/null
+++ b/multimedia/vlc/files/patch-include_vlc__atomic.h
@@ -0,0 +1,17 @@
+--- include/vlc_atomic.h.orig 2014-08-14 07:20:03 UTC
++++ include/vlc_atomic.h
+@@ -32,6 +32,14 @@
+ /*** Native C11 atomics ***/
+ # include <stdatomic.h>
+
++# elif defined (__cplusplus) && defined(_LIBCPP_VERSION) && _LIBCPP_VERSION >= 3800
++
++# include <atomic>
++
++using std::atomic_uint_least32_t;
++using std::atomic_uintptr_t;
++using std::atomic_int;
++
+ # else
+
+ # define ATOMIC_FLAG_INIT false
diff --git a/multimedia/vlc/files/patch-include_vlc__playlist.h b/multimedia/vlc/files/patch-include_vlc__playlist.h
new file mode 100644
index 000000000000..c846d1a7ade5
--- /dev/null
+++ b/multimedia/vlc/files/patch-include_vlc__playlist.h
@@ -0,0 +1,19 @@
+--- include/vlc_playlist.h.orig 2014-11-16 18:57:58 UTC
++++ include/vlc_playlist.h
+@@ -24,13 +24,13 @@
+ #ifndef VLC_PLAYLIST_H_
+ #define VLC_PLAYLIST_H_
+
++#include <vlc_input.h>
++#include <vlc_events.h>
++
+ # ifdef __cplusplus
+ extern "C" {
+ # endif
+
+-#include <vlc_input.h>
+-#include <vlc_events.h>
+-
+ TYPEDEF_ARRAY(playlist_item_t*, playlist_item_array_t)
+
+ struct intf_thread_t;
diff --git a/multimedia/vlc/files/patch-include_vlc__sout.h b/multimedia/vlc/files/patch-include_vlc__sout.h
new file mode 100644
index 000000000000..fb99aad4f588
--- /dev/null
+++ b/multimedia/vlc/files/patch-include_vlc__sout.h
@@ -0,0 +1,22 @@
+--- include/vlc_sout.h.orig 2014-11-16 18:57:58 UTC
++++ include/vlc_sout.h
+@@ -28,6 +28,9 @@
+ #ifndef VLC_SOUT_H_
+ #define VLC_SOUT_H_
+
++#include <sys/types.h>
++#include <vlc_es.h>
++
+ /**
+ * \file
+ * This file defines structures and functions for stream output in vlc
+@@ -37,9 +40,6 @@
+ extern "C" {
+ #endif
+
+-#include <sys/types.h>
+-#include <vlc_es.h>
+-
+ /** Stream output instance (FIXME: should be private to src/ to avoid
+ * invalid unsynchronized access) */
+ struct sout_instance_t
diff --git a/multimedia/vlc/files/patch-modules_gui_qt4_dialogs_messages.hpp b/multimedia/vlc/files/patch-modules_gui_qt4_dialogs_messages.hpp
new file mode 100644
index 000000000000..bb70dc1bf936
--- /dev/null
+++ b/multimedia/vlc/files/patch-modules_gui_qt4_dialogs_messages.hpp
@@ -0,0 +1,11 @@
+--- modules/gui/qt4/dialogs/messages.hpp.orig 2014-08-14 07:20:04 UTC
++++ modules/gui/qt4/dialogs/messages.hpp
+@@ -55,7 +55,7 @@ private:
+ void sinkMessage( const MsgEvent * );
+ bool matchFilter( const QString& );
+
+- atomic_uint verbosity;
++ atomic_int verbosity;
+ static void MsgCallback( void *, int, const vlc_log_t *, const char *,
+ va_list );
+
diff --git a/multimedia/vlc/files/patch-share-lua-intf-cli.lua b/multimedia/vlc/files/patch-share-lua-intf-cli.lua
deleted file mode 100644
index 143471138051..000000000000
--- a/multimedia/vlc/files/patch-share-lua-intf-cli.lua
+++ /dev/null
@@ -1,11 +0,0 @@
---- share/lua/intf/cli.lua.orig 2015-07-11 02:39:34.126886159 +0000
-+++ share/lua/intf/cli.lua 2015-07-11 02:54:46.665888389 +0000
-@@ -343,7 +343,7 @@
- end
- if val.args then str = str .. " " .. val.args end
- if #str%2 == 1 then str = str .. " " end
-- str = str .. string.rep(" .",(width-(#str+#val.help)-1)/2)
-+ str = str .. string.rep(" .",math.floor((width-(#str+#val.help)-1)/2))
- str = str .. string.rep(" ",width-#str-#val.help) .. val.help
- end
- client:append(str)
diff --git a/multimedia/vlc/files/patch-vendor-00-ce91452 b/multimedia/vlc/files/patch-vendor-00-ce91452
deleted file mode 100644
index fa5a6a92a319..000000000000
--- a/multimedia/vlc/files/patch-vendor-00-ce91452
+++ /dev/null
@@ -1,29 +0,0 @@
-From ce91452460a75d7424b165c4dc8db98114c3cbd9 Mon Sep 17 00:00:00 2001
-From: Francois Cartegnie <fcartegnie@free.fr>
-Date: Mon, 3 Aug 2015 15:17:32 +0200
-Subject: [PATCH] demux: mp4: correctly match release function
-
-Signed-off-by: Jean-Baptiste Kempf <jb@videolan.org>
----
- modules/demux/mp4/libmp4.c | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git modules/demux/mp4/libmp4.c modules/demux/mp4/libmp4.c
-index 331262b..f220e51 100644
---- modules/demux/mp4/libmp4.c
-+++ modules/demux/mp4/libmp4.c
-@@ -3643,6 +3643,11 @@ void MP4_BoxFree( stream_t *s, MP4_Box_t *p_box )
- {
- for( i_index = 0; ; i_index++ )
- {
-+ if ( MP4_Box_Function[i_index].i_parent &&
-+ p_box->p_father &&
-+ p_box->p_father->i_type != MP4_Box_Function[i_index].i_parent )
-+ continue;
-+
- if( ( MP4_Box_Function[i_index].i_type == p_box->i_type )||
- ( MP4_Box_Function[i_index].i_type == 0 ) )
- {
---
-1.7.10.4
-
diff --git a/multimedia/vlc/pkg-descr b/multimedia/vlc/pkg-descr
index c34f35b7070d..4ed82567bd40 100644
--- a/multimedia/vlc/pkg-descr
+++ b/multimedia/vlc/pkg-descr
@@ -2,7 +2,7 @@ VLC media player is a highly portable multimedia player for various
audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, and
more) as well as DVD's, VCD's, and various streaming protocols. It
can also be used as a server to stream in unicast or multicast in
-IPv4 or IPv6 on a high-bandwidth network. VLC also has the ability
+IPv4 or IPv6 on a high-bandwidth network. VLC also has the ability
to transcode media on-the-fly for streaming or saving to disk.
WWW: http://www.videolan.org/
diff --git a/multimedia/vlc/pkg-plist b/multimedia/vlc/pkg-plist
index b15c8062476e..f22fd7c5cb58 100644
--- a/multimedia/vlc/pkg-plist
+++ b/multimedia/vlc/pkg-plist
@@ -170,10 +170,12 @@ share/apps/solid/actions/vlc-openvcd.desktop
%%NLS%%share/locale/km/LC_MESSAGES/vlc.mo
%%NLS%%share/locale/kn/LC_MESSAGES/vlc.mo
%%NLS%%share/locale/ko/LC_MESSAGES/vlc.mo
+%%NLS%%share/locale/ks_IN/LC_MESSAGES/vlc.mo
%%NLS%%share/locale/ky/LC_MESSAGES/vlc.mo
%%NLS%%share/locale/lg/LC_MESSAGES/vlc.mo
%%NLS%%share/locale/lt/LC_MESSAGES/vlc.mo
%%NLS%%share/locale/lv/LC_MESSAGES/vlc.mo
+%%NLS%%share/locale/mai/LC_MESSAGES/vlc.mo
%%NLS%%share/locale/mk/LC_MESSAGES/vlc.mo
%%NLS%%share/locale/ml/LC_MESSAGES/vlc.mo
%%NLS%%share/locale/mn/LC_MESSAGES/vlc.mo