aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-02-23 14:29:55 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-02-23 14:29:55 +0000
commit6827378ef6184c61ea3f4aacbd13da80bb784591 (patch)
treeb6166ee387bd12df29304956b540387ab9ec0e01
parent48e1e74a5801577082c9fb4c7d329d49fa4aa1e8 (diff)
downloadports-6827378ef6184c61ea3f4aacbd13da80bb784591.tar.gz
ports-6827378ef6184c61ea3f4aacbd13da80bb784591.zip
Notes
-rw-r--r--security/sguil-client/Makefile4
-rw-r--r--security/sguil-client/files/patch-sguil.conf2
-rw-r--r--security/sguil-sensor/Makefile6
-rw-r--r--security/sguil-server/Makefile4
4 files changed, 8 insertions, 8 deletions
diff --git a/security/sguil-client/Makefile b/security/sguil-client/Makefile
index 65e696703b7e..83245c7cca96 100644
--- a/security/sguil-client/Makefile
+++ b/security/sguil-client/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= SF/sguil/sguil/sguil-${PORTVERSION}
MAINTAINER= pauls@utdallas.edu
COMMENT= Sguil is a network security monitoring program
-LIB_DEPENDS= tls:${PORTSDIR}/devel/tcltls
-RUN_DEPENDS= dtplite:${PORTSDIR}/devel/tcllib \
+RUN_DEPENDS= tcltls>=0:${PORTSDIR}/devel/tcltls \
+ dtplite:${PORTSDIR}/devel/tcllib \
${LOCALBASE}/lib/tclx8.4/tclx.tcl:${PORTSDIR}/lang/tclX \
${LOCALBASE}/lib/iwidgets/iwidgets.tcl:${PORTSDIR}/x11-toolkits/iwidgets \
gpg2:${PORTSDIR}/security/gnupg
diff --git a/security/sguil-client/files/patch-sguil.conf b/security/sguil-client/files/patch-sguil.conf
index 8671aef51efa..3190d26ee0a2 100644
--- a/security/sguil-client/files/patch-sguil.conf
+++ b/security/sguil-client/files/patch-sguil.conf
@@ -5,7 +5,7 @@
# PATH to tls lib if needed (tcl can usually find this by default)
-#set TLS_PATH /usr/lib/tls1.4/libtls1.4.so
-+#set TLS_PATH /usr/local/lib/libtls.so
++#set TLS_PATH /usr/local/lib/tls1.6/libtls1.6.so
# win32 example
#set TLS_PATH "c:/tcl/lib/tls1.4/tls14.dll"
diff --git a/security/sguil-sensor/Makefile b/security/sguil-sensor/Makefile
index c27f68b679be..7bebc3d97b96 100644
--- a/security/sguil-sensor/Makefile
+++ b/security/sguil-sensor/Makefile
@@ -9,8 +9,8 @@ MASTER_SITES= SF/sguil/sguil/sguil-${PORTVERSION}
MAINTAINER= pauls@utdallas.edu
COMMENT= Sguil is a network security monitoring program
-LIB_DEPENDS= tls:${PORTSDIR}/devel/tcltls
-RUN_DEPENDS= barnyard2:${PORTSDIR}/security/barnyard2-sguil \
+RUN_DEPENDS= tcltls>=0:${PORTSDIR}/devel/tcltls \
+ barnyard2:${PORTSDIR}/security/barnyard2-sguil \
${LOCALBASE}/lib/tclx8.4/tclx.tcl:${PORTSDIR}/lang/tclX
OPTIONS_DEFINE= PADS SANCP
@@ -65,7 +65,7 @@ PLIST_SUB+= USEPADS="@comment "
post-patch:
.for f in ${AGENTS}
- @${REINPLACE_CMD} 's|/bin/sh|${STAGEDIR}${PREFIX}/bin/${TCLSH}|' \
+ @${REINPLACE_CMD} 's|/bin/sh|${PREFIX}/bin/${TCLSH}|' \
${WRKSRC}/sensor/${f}
.endfor
diff --git a/security/sguil-server/Makefile b/security/sguil-server/Makefile
index 05a0db3b2bdd..e142c2148de0 100644
--- a/security/sguil-server/Makefile
+++ b/security/sguil-server/Makefile
@@ -9,11 +9,11 @@ MASTER_SITES= SF/sguil/sguil/sguil-${PORTVERSION}
MAINTAINER= pauls@utdallas.edu
COMMENT= Sguil is a network security monitoring program
-RUN_DEPENDS= p0f:${PORTSDIR}/net-mgmt/p0f \
+RUN_DEPENDS= tcltls>=0:${PORTSDIR}/devel/tcltls \
+ p0f:${PORTSDIR}/net-mgmt/p0f \
tcpflow:${PORTSDIR}/net/tcpflow \
dtplite:${PORTSDIR}/devel/tcllib \
${LOCALBASE}/lib/tclx8.4/tclx.tcl:${PORTSDIR}/lang/tclX
-LIB_DEPENDS= tls:${PORTSDIR}/devel/tcltls
OPTIONS_DEFINE= MYSQL
MYSQL_DESC= Depend on databases/mysqltcl