aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2016-06-20 11:11:09 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2016-06-20 11:11:09 +0000
commit7517f204abf3e7b85236d11666da68504314f4ee (patch)
tree03ce9f9371603c8b7f030881f18ba3a90be79408
parent69bcc4ee7653ea77ebc53eb358d209b9892474ad (diff)
downloadports-7517f204abf3e7b85236d11666da68504314f4ee.tar.gz
ports-7517f204abf3e7b85236d11666da68504314f4ee.zip
MFH: r413860 r417040
- Update to 1.7.0 - Remove unneeded patches (applied upstream) - Fix inline assembler error on 9.x - Fix pkg-plist Changelog: https://lists.gnupg.org/pipermail/gnupg-announce/2016q2/000386.html PR: 208907 Approved by: junovitch (mentor) Exp-run: antoine Differential Revision: D5989 - Update to 1.7.1 - Remove unneeded patch (applied upstream) - Convert to new test framework https://lists.gnupg.org/pipermail/gnupg-announce/2016q2/000389.html PR: 210328 Reviewed by: amdmi3, junovitch (mentors) Approved by: amdmi3, junovitch (mentors) Exp-run: antoine Differential Revision: D6865 Approved by: ports-secteam (junovitch)
Notes
Notes: svn path=/branches/2016Q2/; revision=417151
-rw-r--r--security/libgcrypt/Makefile7
-rw-r--r--security/libgcrypt/distinfo5
-rw-r--r--security/libgcrypt/files/patch-cipher_salsa20.c62
-rw-r--r--security/libgcrypt/files/patch-mpi_longlong.h24
-rw-r--r--security/libgcrypt/files/patch-src_gcrypt.h.in20
-rw-r--r--security/libgcrypt/pkg-plist2
6 files changed, 18 insertions, 102 deletions
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index bcce006d0a1e..2466665ae5aa 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= libgcrypt
-PORTVERSION= 1.6.5
-PORTREVISION= 1
+PORTVERSION= 1.7.1
CATEGORIES= security
MASTER_SITES= GNUPG
@@ -23,6 +22,7 @@ CONFIGURE_ARGS= --disable-drng-support --enable-static=yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_TARGET=${ARCH:S/amd64/x86_64/}-portbld-${OPSYS:tl}${OSREL}
USE_LDCONFIG= yes
+TEST_TARGET= check
DOCS= AUTHORS ChangeLog ChangeLog-2011 INSTALL NEWS README \
README.GIT THANKS TODO doc/HACKING doc/README.apichanges
@@ -48,7 +48,4 @@ post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
-regression-test: build
- cd ${WRKSRC} && ${MAKE_CMD} check
-
.include <bsd.port.mk>
diff --git a/security/libgcrypt/distinfo b/security/libgcrypt/distinfo
index baa0024c863d..4ba799a6fee3 100644
--- a/security/libgcrypt/distinfo
+++ b/security/libgcrypt/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libgcrypt-1.6.5.tar.bz2) = f49ebc5842d455ae7019def33eb5a014a0f07a2a8353dc3aa50a76fd1dafa924
-SIZE (libgcrypt-1.6.5.tar.bz2) = 2549601
+TIMESTAMP = 1466077169
+SHA256 (libgcrypt-1.7.1.tar.bz2) = 450d9cfcbf1611c64dbe3bd04b627b83379ef89f11406d94c8bba305e36d7a95
+SIZE (libgcrypt-1.7.1.tar.bz2) = 2843435
diff --git a/security/libgcrypt/files/patch-cipher_salsa20.c b/security/libgcrypt/files/patch-cipher_salsa20.c
deleted file mode 100644
index 97cbfa8bd605..000000000000
--- a/security/libgcrypt/files/patch-cipher_salsa20.c
+++ /dev/null
@@ -1,62 +0,0 @@
---- cipher/salsa20.c.orig 2016-03-23 16:34:00 UTC
-+++ cipher/salsa20.c
-@@ -485,7 +485,8 @@ salsa20r12_encrypt_stream (void *context
- static const char*
- selftest (void)
- {
-- SALSA20_context_t ctx;
-+ byte ctxbuf[sizeof(SALSA20_context_t) + 15];
-+ SALSA20_context_t *ctx;
- byte scratch[8+1];
- byte buf[256+64+4];
- int i;
-@@ -502,32 +503,35 @@ selftest (void)
- static const byte ciphertext_1[] =
- { 0xE3, 0xBE, 0x8F, 0xDD, 0x8B, 0xEC, 0xA2, 0xE3};
-
-- salsa20_setkey (&ctx, key_1, sizeof key_1);
-- salsa20_setiv (&ctx, nonce_1, sizeof nonce_1);
-+ /* 16-byte alignment required for amd64 implementation. */
-+ ctx = (SALSA20_context_t *)((uintptr_t)(ctxbuf + 15) & ~(uintptr_t)15);
-+
-+ salsa20_setkey (ctx, key_1, sizeof key_1);
-+ salsa20_setiv (ctx, nonce_1, sizeof nonce_1);
- scratch[8] = 0;
-- salsa20_encrypt_stream (&ctx, scratch, plaintext_1, sizeof plaintext_1);
-+ salsa20_encrypt_stream (ctx, scratch, plaintext_1, sizeof plaintext_1);
- if (memcmp (scratch, ciphertext_1, sizeof ciphertext_1))
- return "Salsa20 encryption test 1 failed.";
- if (scratch[8])
- return "Salsa20 wrote too much.";
-- salsa20_setkey( &ctx, key_1, sizeof(key_1));
-- salsa20_setiv (&ctx, nonce_1, sizeof nonce_1);
-- salsa20_encrypt_stream (&ctx, scratch, scratch, sizeof plaintext_1);
-+ salsa20_setkey( ctx, key_1, sizeof(key_1));
-+ salsa20_setiv (ctx, nonce_1, sizeof nonce_1);
-+ salsa20_encrypt_stream (ctx, scratch, scratch, sizeof plaintext_1);
- if (memcmp (scratch, plaintext_1, sizeof plaintext_1))
- return "Salsa20 decryption test 1 failed.";
-
- for (i = 0; i < sizeof buf; i++)
- buf[i] = i;
-- salsa20_setkey (&ctx, key_1, sizeof key_1);
-- salsa20_setiv (&ctx, nonce_1, sizeof nonce_1);
-+ salsa20_setkey (ctx, key_1, sizeof key_1);
-+ salsa20_setiv (ctx, nonce_1, sizeof nonce_1);
- /*encrypt*/
-- salsa20_encrypt_stream (&ctx, buf, buf, sizeof buf);
-+ salsa20_encrypt_stream (ctx, buf, buf, sizeof buf);
- /*decrypt*/
-- salsa20_setkey (&ctx, key_1, sizeof key_1);
-- salsa20_setiv (&ctx, nonce_1, sizeof nonce_1);
-- salsa20_encrypt_stream (&ctx, buf, buf, 1);
-- salsa20_encrypt_stream (&ctx, buf+1, buf+1, (sizeof buf)-1-1);
-- salsa20_encrypt_stream (&ctx, buf+(sizeof buf)-1, buf+(sizeof buf)-1, 1);
-+ salsa20_setkey (ctx, key_1, sizeof key_1);
-+ salsa20_setiv (ctx, nonce_1, sizeof nonce_1);
-+ salsa20_encrypt_stream (ctx, buf, buf, 1);
-+ salsa20_encrypt_stream (ctx, buf+1, buf+1, (sizeof buf)-1-1);
-+ salsa20_encrypt_stream (ctx, buf+(sizeof buf)-1, buf+(sizeof buf)-1, 1);
- for (i = 0; i < sizeof buf; i++)
- if (buf[i] != (byte)i)
- return "Salsa20 encryption test 2 failed.";
diff --git a/security/libgcrypt/files/patch-mpi_longlong.h b/security/libgcrypt/files/patch-mpi_longlong.h
index 8ad882b895d0..249e29f0cb03 100644
--- a/security/libgcrypt/files/patch-mpi_longlong.h
+++ b/security/libgcrypt/files/patch-mpi_longlong.h
@@ -1,27 +1,27 @@
---- mpi/longlong.h.orig 2016-03-23 17:33:08 UTC
+--- mpi/longlong.h.orig 2016-06-16 11:43:39 UTC
+++ mpi/longlong.h
-@@ -170,6 +170,7 @@ MA 02111-1307, USA. */
+@@ -174,6 +174,7 @@ MA 02111-1307, USA. */
(pl) = __m0 * __m1; \
} while (0)
- #define UMUL_TIME 46
-+#if 0
- #ifndef LONGLONG_STANDALONE
- #define udiv_qrnnd(q, r, n1, n0, d) \
+ # define UMUL_TIME 46
++# if 0
+ # ifndef LONGLONG_STANDALONE
+ # define udiv_qrnnd(q, r, n1, n0, d) \
do { UDItype __r; \
-@@ -179,6 +180,7 @@ MA 02111-1307, USA. */
+@@ -183,6 +184,7 @@ MA 02111-1307, USA. */
extern UDItype __udiv_qrnnd ();
- #define UDIV_TIME 220
- #endif /* LONGLONG_STANDALONE */
+ # define UDIV_TIME 220
+ # endif /* !LONGLONG_STANDALONE */
+#endif /* 0 */
#endif /* __alpha */
/***************************************
-@@ -1287,7 +1289,7 @@ typedef unsigned int UTItype __attribute
+@@ -1293,7 +1295,7 @@ typedef unsigned int UTItype __attribute
"rJ" ((USItype)(al)), \
"rI" ((USItype)(bl)) \
__CLOBBER_CC)
--#if defined (__sparc_v8__) || defined(__sparcv8)
-+#if defined (__sparc_v8__) || defined(__sparcv8) || defined (__sparc__)
+-# if defined (__sparc_v8__) || defined(__sparcv8)
++# if defined (__sparc_v8__) || defined(__sparcv8) || defined(__sparc__)
/* Don't match immediate range because, 1) it is not often useful,
2) the 'I' flag thinks of the range as a 13 bit signed interval,
while we want to match a 13 bit interval, sign extended to 32 bits,
diff --git a/security/libgcrypt/files/patch-src_gcrypt.h.in b/security/libgcrypt/files/patch-src_gcrypt.h.in
deleted file mode 100644
index 65b4c5a886fd..000000000000
--- a/security/libgcrypt/files/patch-src_gcrypt.h.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/gcrypt.h.in.orig 2015-09-07 12:05:57 UTC
-+++ src/gcrypt.h.in
-@@ -506,7 +506,7 @@ enum gcry_mpi_flag
- GCRYMPI_FLAG_USER1 = 0x0100,/* User flag 1. */
- GCRYMPI_FLAG_USER2 = 0x0200,/* User flag 2. */
- GCRYMPI_FLAG_USER3 = 0x0400,/* User flag 3. */
-- GCRYMPI_FLAG_USER4 = 0x0800,/* User flag 4. */
-+ GCRYMPI_FLAG_USER4 = 0x0800 /* User flag 4. */
- };
-
-
-@@ -1343,7 +1343,7 @@ enum gcry_mac_algos
- /* Flags used with the open function. */
- enum gcry_mac_flags
- {
-- GCRY_MAC_FLAG_SECURE = 1, /* Allocate all buffers in "secure" memory. */
-+ GCRY_MAC_FLAG_SECURE = 1 /* Allocate all buffers in "secure" memory. */
- };
-
- /* Create a MAC handle for algorithm ALGO. FLAGS may be given as an bitwise OR
diff --git a/security/libgcrypt/pkg-plist b/security/libgcrypt/pkg-plist
index 17f63016dccc..b6a2c15b76f8 100644
--- a/security/libgcrypt/pkg-plist
+++ b/security/libgcrypt/pkg-plist
@@ -6,6 +6,6 @@ include/gcrypt.h
lib/libgcrypt.a
lib/libgcrypt.so
lib/libgcrypt.so.20
-lib/libgcrypt.so.20.0.5
+lib/libgcrypt.so.20.1.1
man/man1/hmac256.1.gz
share/aclocal/libgcrypt.m4