aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2016-02-25 09:25:27 +0000
committerMax Khon <fjoe@FreeBSD.org>2016-02-25 09:25:27 +0000
commit7ea2b1a4221886f09739fbd147a81aaf6e20580e (patch)
treee5fe2af3706ec558bba7d1e5c41836ac76c0e415
parentaa8891c0437af855933675c3f6e82f9aa2f45f83 (diff)
- Install pgadmin3.desktop desktop entry and icons
(16x16 and 32x32 that are present in src tarball) - Bump PORTREVISION to reflect package changes. PR: 207399 Submitted by: Dmitri Goutnik
Notes
Notes: svn path=/head/; revision=409500
-rw-r--r--databases/pgadmin3/Makefile21
1 files changed, 19 insertions, 2 deletions
diff --git a/databases/pgadmin3/Makefile b/databases/pgadmin3/Makefile
index 87c076a11f48..9730c4688f86 100644
--- a/databases/pgadmin3/Makefile
+++ b/databases/pgadmin3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pgadmin3
PORTVERSION= 1.22.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= PGSQL/pgadmin3/release/v${PORTVERSION}/src
DIST_SUBDIR= postgresql
@@ -21,8 +21,12 @@ CONFIGURE_ARGS= --with-wx-version=${USE_WX} --enable-databasedesigner
USE_GNOME= libxml2 libxslt
USE_WX= 2.8
WX_COMPS= wx contrib
+ICON_SIZES= 16 32
-PLIST_FILES= bin/pgadmin3
+PLIST_FILES= bin/pgadmin3 share/applications/pgadmin3.desktop
+.for SZ in ${ICON_SIZES}
+PLIST_FILES+= share/icons/hicolor/${SZ}x${SZ}/apps/pgAdmin3.png
+.endfor
PORTDATA= *
post-patch:
@@ -30,5 +34,18 @@ post-patch:
@${REINPLACE_CMD} -e 's,wxrc,wxrc-gtk2u-2.8,' ${WRKSRC}/pgadmin/ui/embed-xrc
@${REINPLACE_CMD} -e 's,/usr/bin/xterm,${LOCALBASE}/bin/xterm,' ${WRKSRC}/plugins.d/plugins.ini
@${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' ${WRKSRC}/pgadmin/ver_svn.sh
+ @${REINPLACE_CMD} -e 's,Exec=/usr/bin/pgadmin3,Exec=${LOCALBASE}/bin/pgadmin3,'\
+ -e 's,Icon=/usr/share/pgadmin3/pgAdmin3.png,Icon=pgAdmin3,'\
+ -e '/^MimeType=/d'\
+ -e '/^DocPath=/d'\
+ ${WRKSRC}/pkg/pgadmin3.desktop
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/pkg/pgadmin3.desktop ${STAGEDIR}${PREFIX}/share/applications
+.for SZ in ${ICON_SIZES}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}x${SZ}/apps
+ ${INSTALL_DATA} ${WRKSRC}/pgadmin/include/images/pgAdmin3-${SZ}.png ${STAGEDIR}${PREFIX}/share/icons/hicolor/${SZ}x${SZ}/apps/pgAdmin3.png
+.endfor
.include <bsd.port.mk>