aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-06-21 16:01:47 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-06-21 16:01:47 +0000
commit967a28aef293cce26fe99b33d596d1354c670ac5 (patch)
tree52f45240447c6e50f8d6e51a833ba08362935dbf
parent7c58cf09e39d3275e7715cfbffb82eb0d7d7321e (diff)
downloadports-967a28aef293cce26fe99b33d596d1354c670ac5.tar.gz
ports-967a28aef293cce26fe99b33d596d1354c670ac5.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/fpc-opengl/Makefile21
2 files changed, 22 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4aab2d007e9b..69fdc5cdf268 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -131,6 +131,7 @@
SUBDIR += fpc-libgd
SUBDIR += fpc-libpng
SUBDIR += fpc-ncurses
+ SUBDIR += fpc-opengl
SUBDIR += fracplanet
SUBDIR += fractorama
SUBDIR += fraqtive
diff --git a/graphics/fpc-opengl/Makefile b/graphics/fpc-opengl/Makefile
new file mode 100644
index 000000000000..5bd4f598c0a9
--- /dev/null
+++ b/graphics/fpc-opengl/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: fpc-opengl
+# Date created: 2006-06-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= graphics lang
+PKGNAMESUFFIX= -opengl
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free Pascal interface to the OpenGL library
+
+RUN_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
+USE_GL= yes
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+
+.include "${MASTERDIR}/Makefile"