aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-10-01 15:07:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-10-01 15:07:31 +0000
commitc91d0249ddb36b9fe4d92a83d35306a1b7dce90b (patch)
treefecf3f68ea9a9b5ae728e158fb1edf1e6465fa63
parent7fb97380c1116e7ce0df4b4c265f26078f8f67f4 (diff)
Notes
-rw-r--r--lang/spidermonkey185/Makefile6
-rw-r--r--mail/thunderbird/Makefile8
-rw-r--r--www/firefox-esr/Makefile6
-rw-r--r--www/firefox/Makefile6
-rw-r--r--www/libxul/Makefile6
-rw-r--r--www/seamonkey/Makefile8
6 files changed, 20 insertions, 20 deletions
diff --git a/lang/spidermonkey185/Makefile b/lang/spidermonkey185/Makefile
index 71f6d13fa5cd..1d9d9f259226 100644
--- a/lang/spidermonkey185/Makefile
+++ b/lang/spidermonkey185/Makefile
@@ -12,13 +12,13 @@ DISTNAME= js185-1.0.0
MAINTAINER= koobs@FreeBSD.org
COMMENT= Standalone JavaScript (1.8.5) interpreter from Mozilla
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ autoconf-2.13:${PORTSDIR}/devel/autoconf213
LIB_DEPENDS= libnspr4.so:${PORTSDIR}/devel/nspr
CONFLICTS= njs-[0-9]*
USES= gmake pathfix perl5 pkgconfig
-USE_AUTOTOOLS= autoconf213:env
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_PERL5= build
@@ -108,7 +108,7 @@ PLIST_SUB+= SPARC="@comment "
.endif
pre-configure:
- (cd ${WRKSRC} && ${AUTOCONF})
+ (cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf-2.13)
regression-test: build
@${ECHO_MSG} -n "===> Running jstests.py: "
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 81a7f00e3186..9b0b217abed6 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -25,6 +25,7 @@ BUILD_DEPENDS= nspr>=4.10.6:${PORTSDIR}/devel/nspr \
sqlite3>=3.8.4.2:${PORTSDIR}/databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat \
+ autoconf-2.13:${PORTSDIR}/devel/autoconf213 \
zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip
@@ -34,7 +35,6 @@ EM_VERSION= 1.7.2
L_VERSION= 3.3.1.2
SSP_UNSAFE= yes
-USE_AUTOTOOLS= autoconf213:env
OBJDIR_BUILD= # in-tree build broken after bug 789837
USE_GECKO= gecko
USE_MOZILLA= # empty
@@ -156,9 +156,9 @@ post-patch:
.endif
pre-configure:
- (cd ${WRKSRC} && ${AUTOCONF})
- (cd ${MOZSRC} && ${AUTOCONF})
- (cd ${MOZSRC}/js/src/ && ${AUTOCONF})
+ (cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf-2.13)
+ (cd ${MOZSRC} && ${LOCALBASE}/bin/autoconf-2.13)
+ (cd ${MOZSRC}/js/src/ && ${LOCALBASE}/bin/autoconf-2.13)
.if ${PORT_OPTIONS:MENIGMAIL}
post-configure:
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 9afb0cef6cfd..5d000e10439e 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -25,12 +25,12 @@ BUILD_DEPENDS= nspr>=4.10.6:${PORTSDIR}/devel/nspr \
sqlite3>=3.8.4.2:${PORTSDIR}/databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat \
+ autoconf-2.13:${PORTSDIR}/devel/autoconf213 \
zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
-USE_AUTOTOOLS= autoconf213:env
OBJDIR_BUILD= # in-tree build broken after bug 789837
USE_GECKO= gecko
CPE_PRODUCT= ${PORTNAME}_esr
@@ -97,8 +97,8 @@ post-patch:
${WRKSRC}/browser/app/nsBrowserApp.cpp
pre-configure:
- (cd ${WRKSRC} && ${AUTOCONF})
- (cd ${WRKSRC}/js/src/ && ${AUTOCONF})
+ (cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf-2.13)
+ (cd ${WRKSRC}/js/src/ && ${LOCALBASE}/bin/autoconf-2.13)
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/pixmaps
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 96bfee96fbe9..eb329d4a19f7 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -25,12 +25,12 @@ BUILD_DEPENDS= nspr>=4.10.6:${PORTSDIR}/devel/nspr \
sqlite3>=3.8.4.2:${PORTSDIR}/databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat \
+ autoconf-2.13:${PORTSDIR}/devel/autoconf213 \
zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
-USE_AUTOTOOLS= autoconf213:env
OBJDIR_BUILD= # in-tree build broken after bug 789837
USE_GECKO= gecko
CONFLICTS= firefox-esr-31.* firefox-esr-24.* firefox-esr-17.*
@@ -96,8 +96,8 @@ post-patch:
${WRKSRC}/browser/app/nsBrowserApp.cpp
pre-configure:
- (cd ${WRKSRC} && ${AUTOCONF})
- (cd ${WRKSRC}/js/src/ && ${AUTOCONF})
+ (cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf-2.13)
+ (cd ${WRKSRC}/js/src/ && ${LOCALBASE}/bin/autoconf-2.13)
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/share/pixmaps
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index eceede4ff25d..3554824e7424 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -23,6 +23,7 @@ BUILD_DEPENDS= nspr>=4.10.2:${PORTSDIR}/devel/nspr \
libvorbis>=1.3.4:${PORTSDIR}/audio/libvorbis \
opus>=1.1:${PORTSDIR}/audio/opus \
v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat \
+ autoconf-2.13:${PORTSDIR}/devel/autoconf213 \
zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip
LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
@@ -30,7 +31,6 @@ LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
WRKSRC= ${WRKDIR}/mozilla-esr24
CONFLICTS= libxul-1.9.*
-USE_AUTOTOOLS= autoconf213:env
WANT_GNOME= yes
USE_QT4= # empty
QT_NONSTANDARD= yes
@@ -74,8 +74,8 @@ post-patch:
${WRKSRC}/xulrunner/stub/nsXULStub.cpp
pre-configure:
- (cd ${WRKSRC} && ${AUTOCONF})
- (cd ${WRKSRC}/js/src/ && ${AUTOCONF})
+ (cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf-2.13)
+ (cd ${WRKSRC}/js/src/ && ${LOCALBASE}/bin/autoconf-2.13)
post-build:
@${REINPLACE_CMD} -e "s|\(Libs:.*\)\($$\)|\1 -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}\2| ; \
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index d84cde145178..cf8b8f135f0b 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -25,6 +25,7 @@ BUILD_DEPENDS= nspr>=4.10.6:${PORTSDIR}/devel/nspr \
sqlite3>=3.8.4.2:${PORTSDIR}/databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat \
+ autoconf-2.13:${PORTSDIR}/devel/autoconf213 \
zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip
@@ -34,7 +35,6 @@ EM_VERSION= 1.7.2
L_VERSION= 3.4
SSP_UNSAFE= yes
-USE_AUTOTOOLS= autoconf213:env
OBJDIR_BUILD= # in-tree build broken after bug 789837
USE_GECKO= gecko
WANT_GNOME= yes
@@ -179,9 +179,9 @@ post-patch:
.endif
pre-configure:
- (cd ${WRKSRC} && ${AUTOCONF})
- (cd ${MOZSRC} && ${AUTOCONF})
- (cd ${MOZSRC}/js/src/ && ${AUTOCONF})
+ (cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf-2.13)
+ (cd ${MOZSRC} && ${LOCALBASE}/bin/autoconf-2.13)
+ (cd ${MOZSRC}/js/src/ && ${LOCALBASE}/bin/autoconf-2.13)
.if ${PORT_OPTIONS:MMAILNEWS} && ${PORT_OPTIONS:MENIGMAIL}
post-configure: