aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-02 02:30:23 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-12-02 02:30:23 +0000
commit1a1e8b436e985f1f3807086c03be5657b35d78a6 (patch)
tree332a1724880ab12a83ba75a2761da48f868497da
parentc067c89f61c6038bbe4eac5b6355d6b3726d9e30 (diff)
downloadports-1a1e8b436e985f1f3807086c03be5657b35d78a6.tar.gz
ports-1a1e8b436e985f1f3807086c03be5657b35d78a6.zip
Notes
-rw-r--r--games/super_mario_bros_python/Makefile11
-rw-r--r--games/super_mario_bros_python/pkg-plist5
2 files changed, 6 insertions, 10 deletions
diff --git a/games/super_mario_bros_python/Makefile b/games/super_mario_bros_python/Makefile
index 3e21aec5e7af..ffe190c37190 100644
--- a/games/super_mario_bros_python/Makefile
+++ b/games/super_mario_bros_python/Makefile
@@ -16,15 +16,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Clone of the original Super Mario Bros
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/license.txt
RUN_DEPENDS= ${PYGAME}
WRKSRC= ${WRKDIR}/Super-Mario-Bros-Python-v${DISTVERSION}release
USES= shebangfix python:2 zip
-SHEBANG_FILES= gamelib/*.py
-python_OLD_CMD?= /usr/bin/env python
-python_CMD?= ${PYTHON_CMD}
+SHEBANG_FILES= gamelib/*.py start.py
+python_OLD_CMD= /usr/bin/env python
+python_CMD?= ${PYTHON_CMD}
PORTDOCS= changelog.txt readme.txt
OPTIONS_DEFINE= DOCS
@@ -36,7 +37,7 @@ DESKTOP_ENTRIES="Super Mario Bros. Python" "" ${PORTNAME} \
post-patch:
@${REINPLACE_CMD} -i '' -e '1d' \
- -e 's|#! /usr/bin/env python|#!${PYTHON_CMD}|' \
+ -e 's|#! /usr/bin/env python|#!${python_CMD}|' \
${WRKSRC}/start.py
@${FIND} ${WRKSRC} -name "*.py~" -delete -or -name "*.sav~" -delete
@@ -45,7 +46,7 @@ do-build:
@${PYTHON_CMD} -O -m compileall ${WRKSRC}
do-install:
- @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
+ @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${python_CMD}|' \
${WRKDIR}/${PORTNAME}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
diff --git a/games/super_mario_bros_python/pkg-plist b/games/super_mario_bros_python/pkg-plist
index 2db8b40ca9f2..33063442ac61 100644
--- a/games/super_mario_bros_python/pkg-plist
+++ b/games/super_mario_bros_python/pkg-plist
@@ -154,8 +154,3 @@ share/pixmaps/super_mario_bros_python.png
%%DATADIR%%/start.py
%%DATADIR%%/start.pyc
%%DATADIR%%/start.pyo
-@dirrm %%DATADIR%%/gamelib
-@dirrm %%DATADIR%%/data/saves
-@dirrm %%DATADIR%%/data/fonts
-@dirrm %%DATADIR%%/data
-@dirrm %%DATADIR%%