aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2014-12-02 09:37:42 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2014-12-02 09:37:42 +0000
commit3357d4793fe25f1d343925d94e8017c8553d1d22 (patch)
tree461d699f7a3513b26bc6a4564c5a127dcd917f5e
parent0b390aaabe9ff544a11b00539e88b7022c5d30f0 (diff)
downloadports-3357d4793fe25f1d343925d94e8017c8553d1d22.tar.gz
ports-3357d4793fe25f1d343925d94e8017c8553d1d22.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/websocketpp/Makefile20
-rw-r--r--devel/websocketpp/distinfo2
-rw-r--r--devel/websocketpp/pkg-descr8
-rw-r--r--devel/websocketpp/pkg-plist89
5 files changed, 120 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2fd882de336a..b02aea6b3562 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4807,6 +4807,7 @@
SUBDIR += vtcl
SUBDIR += vxlog
SUBDIR += wand-libconfig
+ SUBDIR += websocketpp
SUBDIR += websvn
SUBDIR += wininfo
SUBDIR += winpdb
diff --git a/devel/websocketpp/Makefile b/devel/websocketpp/Makefile
new file mode 100644
index 000000000000..82b90f758a9f
--- /dev/null
+++ b/devel/websocketpp/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= websocketpp
+PORTVERSION= 0.4.0
+CATEGORIES= devel
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Header only implementation of the WebSocket protocol
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GITHUB= yes
+GH_ACCOUNT= zaphoyd
+GH_PROJECT= websocketpp
+GH_TAGNAME= 0.4.0
+GH_COMMIT= 802e34b
+USES= cmake
+
+.include <bsd.port.mk>
diff --git a/devel/websocketpp/distinfo b/devel/websocketpp/distinfo
new file mode 100644
index 000000000000..14803e530c32
--- /dev/null
+++ b/devel/websocketpp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (websocketpp-0.4.0.tar.gz) = 0e21d29b7b21009f6fe6930a2fb4898e71e41b0c5b77ef6a578ffa5f6d2f4e5b
+SIZE (websocketpp-0.4.0.tar.gz) = 628705
diff --git a/devel/websocketpp/pkg-descr b/devel/websocketpp/pkg-descr
new file mode 100644
index 000000000000..b875a86be1f1
--- /dev/null
+++ b/devel/websocketpp/pkg-descr
@@ -0,0 +1,8 @@
+WebSocket++ is an open source (BSD license) header only C++ library that
+implements RFC6455 The WebSocket Protocol.
+
+It allows integrating WebSocket client and server functionality into
+C++ programs. It uses interchangable network transport modules including
+one based on C++ iostreams and one based on Boost Asio.
+
+WWW: http://www.zaphoyd.com/websocketpp/
diff --git a/devel/websocketpp/pkg-plist b/devel/websocketpp/pkg-plist
new file mode 100644
index 000000000000..7adfda04c084
--- /dev/null
+++ b/devel/websocketpp/pkg-plist
@@ -0,0 +1,89 @@
+include/websocketpp/base64/base64.hpp
+include/websocketpp/client.hpp
+include/websocketpp/close.hpp
+include/websocketpp/common/chrono.hpp
+include/websocketpp/common/connection_hdl.hpp
+include/websocketpp/common/cpp11.hpp
+include/websocketpp/common/functional.hpp
+include/websocketpp/common/md5.hpp
+include/websocketpp/common/memory.hpp
+include/websocketpp/common/network.hpp
+include/websocketpp/common/platforms.hpp
+include/websocketpp/common/random.hpp
+include/websocketpp/common/regex.hpp
+include/websocketpp/common/stdint.hpp
+include/websocketpp/common/system_error.hpp
+include/websocketpp/common/thread.hpp
+include/websocketpp/common/time.hpp
+include/websocketpp/concurrency/basic.hpp
+include/websocketpp/concurrency/none.hpp
+include/websocketpp/config/asio.hpp
+include/websocketpp/config/asio_client.hpp
+include/websocketpp/config/asio_no_tls.hpp
+include/websocketpp/config/asio_no_tls_client.hpp
+include/websocketpp/config/boost_config.hpp
+include/websocketpp/config/core.hpp
+include/websocketpp/config/core_client.hpp
+include/websocketpp/config/debug.hpp
+include/websocketpp/config/debug_asio.hpp
+include/websocketpp/config/debug_asio_no_tls.hpp
+include/websocketpp/config/minimal_client.hpp
+include/websocketpp/config/minimal_server.hpp
+include/websocketpp/connection.hpp
+include/websocketpp/connection_base.hpp
+include/websocketpp/endpoint.hpp
+include/websocketpp/endpoint_base.hpp
+include/websocketpp/error.hpp
+include/websocketpp/error_container.hpp
+include/websocketpp/extensions/extension.hpp
+include/websocketpp/extensions/permessage_deflate/disabled.hpp
+include/websocketpp/extensions/permessage_deflate/enabled.hpp
+include/websocketpp/frame.hpp
+include/websocketpp/http/constants.hpp
+include/websocketpp/http/impl/parser.hpp
+include/websocketpp/http/impl/request.hpp
+include/websocketpp/http/impl/response.hpp
+include/websocketpp/http/parser.hpp
+include/websocketpp/http/request.hpp
+include/websocketpp/http/response.hpp
+include/websocketpp/impl/connection_impl.hpp
+include/websocketpp/impl/endpoint_impl.hpp
+include/websocketpp/impl/utilities_impl.hpp
+include/websocketpp/logger/basic.hpp
+include/websocketpp/logger/levels.hpp
+include/websocketpp/logger/stub.hpp
+include/websocketpp/message_buffer/alloc.hpp
+include/websocketpp/message_buffer/message.hpp
+include/websocketpp/message_buffer/pool.hpp
+include/websocketpp/processors/base.hpp
+include/websocketpp/processors/hybi00.hpp
+include/websocketpp/processors/hybi07.hpp
+include/websocketpp/processors/hybi08.hpp
+include/websocketpp/processors/hybi13.hpp
+include/websocketpp/processors/processor.hpp
+include/websocketpp/random/none.hpp
+include/websocketpp/random/random_device.hpp
+include/websocketpp/roles/client_endpoint.hpp
+include/websocketpp/roles/server_endpoint.hpp
+include/websocketpp/server.hpp
+include/websocketpp/sha1/sha1.hpp
+include/websocketpp/transport/asio/base.hpp
+include/websocketpp/transport/asio/connection.hpp
+include/websocketpp/transport/asio/endpoint.hpp
+include/websocketpp/transport/asio/security/base.hpp
+include/websocketpp/transport/asio/security/none.hpp
+include/websocketpp/transport/asio/security/tls.hpp
+include/websocketpp/transport/base/connection.hpp
+include/websocketpp/transport/base/endpoint.hpp
+include/websocketpp/transport/iostream/base.hpp
+include/websocketpp/transport/iostream/connection.hpp
+include/websocketpp/transport/iostream/endpoint.hpp
+include/websocketpp/transport/stub/base.hpp
+include/websocketpp/transport/stub/connection.hpp
+include/websocketpp/transport/stub/endpoint.hpp
+include/websocketpp/uri.hpp
+include/websocketpp/utf8_validator.hpp
+include/websocketpp/utilities.hpp
+include/websocketpp/version.hpp
+lib/cmake/websocketpp/websocketpp-config.cmake
+lib/cmake/websocketpp/websocketpp-configVersion.cmake