aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-12-27 20:45:45 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-12-27 20:45:45 +0000
commit3edf4f547c96de772f2a139b36220069969abc6a (patch)
tree2540aab2568c3f8f978b062eec636e1c09f3db86
parent2b9dd982d572537769a982a71f487b2af16fa48b (diff)
downloadports-3edf4f547c96de772f2a139b36220069969abc6a.tar.gz
ports-3edf4f547c96de772f2a139b36220069969abc6a.zip
Notes
-rw-r--r--x11/Makefile1
-rw-r--r--x11/wmfstatus/Makefile21
-rw-r--r--x11/wmfstatus/distinfo1
-rw-r--r--x11/wmfstatus/files/patch-Makefile33
-rw-r--r--x11/wmfstatus/pkg-comment1
-rw-r--r--x11/wmfstatus/pkg-descr15
-rw-r--r--x11/wmfstatus/pkg-plist1
7 files changed, 73 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index f66d6127cbdc..9771eb11b154 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -81,6 +81,7 @@
SUBDIR += wdm
SUBDIR += wmbutton
SUBDIR += wmcliphist
+ SUBDIR += wmfstatus
SUBDIR += wmmatrix
SUBDIR += wmmenu
SUBDIR += wrapper
diff --git a/x11/wmfstatus/Makefile b/x11/wmfstatus/Makefile
new file mode 100644
index 000000000000..a08070e59ba6
--- /dev/null
+++ b/x11/wmfstatus/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: wmfstatus
+# Date created: 26 December 2001
+# Whom: Bruce M Simpson <bms@spc.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmfstatus
+PORTVERSION= 0.4
+CATEGORIES= x11
+MASTER_SITES= http://www.finik.net/files/
+
+MAINTAINER= bms@spc.org
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+NO_MAN=
+
+.include <bsd.port.mk>
diff --git a/x11/wmfstatus/distinfo b/x11/wmfstatus/distinfo
new file mode 100644
index 000000000000..bc453ca235e4
--- /dev/null
+++ b/x11/wmfstatus/distinfo
@@ -0,0 +1 @@
+MD5 (wmfstatus-0.4.tar.gz) = 91c4d03268c935663bc55dc7eb61597c
diff --git a/x11/wmfstatus/files/patch-Makefile b/x11/wmfstatus/files/patch-Makefile
new file mode 100644
index 000000000000..1c6d893a129e
--- /dev/null
+++ b/x11/wmfstatus/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile.orig Mon Nov 22 17:38:07 1999
++++ Makefile Thu Dec 27 18:35:43 2001
+@@ -1,6 +1,6 @@
+-LIBDIR = -L/usr/X11R6/lib
++LIBDIR = -L${X11BASE}/lib
+ LIBS = -lXpm -lXext -lX11
+-FLAGS = -O2
++FLAGS = ${CFLAGS}
+ OBJS = wmfstatus.o \
+ ../wmgeneral/wmgeneral.o \
+ ../wmgeneral/misc.o \
+@@ -8,10 +8,10 @@
+
+
+ .c.o:
+- cc -I/usr/X11R6/share/include $(FLAGS) -c -Wall $< -o $*.o
++ ${CC} -I${X11BASE}/include $(FLAGS) -c -Wall $< -o $*.o
+
+ wmfstatus: $(OBJS)
+- cc $(FLAGS) -o wmfstatus $^ -lXext $(LIBDIR) $(LIBS)
++ ${CC} $(FLAGS) -o wmfstatus $? -lXext $(LIBDIR) $(LIBS)
+
+ all:: wmfstatus
+
+@@ -23,7 +23,4 @@
+ rm -f *~
+
+ install:: wmfstatus
+- cp -f wmfstatus /usr/local/bin/
+- chmod 755 /usr/local/bin/wmfstatus
+- chown root:root /usr/local/bin/wmfstatus
+- @echo "WMFSTATUS Installation finished..."
++ ${BSD_INSTALL_PROGRAM} ./wmfstatus ${PREFIX}/bin/
diff --git a/x11/wmfstatus/pkg-comment b/x11/wmfstatus/pkg-comment
new file mode 100644
index 000000000000..6d5b9593cc0a
--- /dev/null
+++ b/x11/wmfstatus/pkg-comment
@@ -0,0 +1 @@
+General purpose LCD display for the WindowMaker dock
diff --git a/x11/wmfstatus/pkg-descr b/x11/wmfstatus/pkg-descr
new file mode 100644
index 000000000000..fcf67a8e2494
--- /dev/null
+++ b/x11/wmfstatus/pkg-descr
@@ -0,0 +1,15 @@
+From the author's website:
+
+It is a very useful general purpose 8x5 LCD screen. It can show any
+information you provide manually or generate by some script/program.
+Can monitor anything, starting with number of new messages in inbox
+and ending with number of unread articles on Slashdot. I myself use
+two instances of wmfstatus to see number of unread mails in the big
+number of folders I have.
+
+Author: finik@sporu.net
+
+WWW: http://www.finik.net/software.html
+
+Bruce
+bms@spc.org
diff --git a/x11/wmfstatus/pkg-plist b/x11/wmfstatus/pkg-plist
new file mode 100644
index 000000000000..b0a29c611f9b
--- /dev/null
+++ b/x11/wmfstatus/pkg-plist
@@ -0,0 +1 @@
+bin/wmfstatus