aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-09-08 15:12:21 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-09-08 15:12:21 +0000
commit82c4b96e97c930035ce2e0ec338267ad588ade57 (patch)
treec84c07dc80178a6f93f65d7051e92a5e9edc2d91
parent0b55083de2e7f5ca27d3227ac39a079a1e0022b7 (diff)
downloadports-82c4b96e97c930035ce2e0ec338267ad588ade57.tar.gz
ports-82c4b96e97c930035ce2e0ec338267ad588ade57.zip
Notes
-rw-r--r--mail/fetchmail/Makefile1
-rw-r--r--mail/fetchmail/files/patch-socket.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 262f84c91f4f..b9c497a97431 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -11,6 +11,7 @@
PORTNAME= fetchmail
PORTVERSION= 6.3.11
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
http://homepages.uni-paderborn.de/mandree/fetchmail/:ma \
diff --git a/mail/fetchmail/files/patch-socket.c b/mail/fetchmail/files/patch-socket.c
new file mode 100644
index 000000000000..1220421515a1
--- /dev/null
+++ b/mail/fetchmail/files/patch-socket.c
@@ -0,0 +1,15 @@
+--- socket.c.org 2009-08-08 16:01:49.000000000 +0200
++++ socket.c 2009-08-08 16:03:17.000000000 +0200
+@@ -628,9 +628,10 @@
+ report(stdout, GT_("Unknown Issuer CommonName\n"));
+ }
+ if ((i = X509_NAME_get_text_by_NID(subj, NID_commonName, buf, sizeof(buf))) != -1) {
+- if (outlevel >= O_VERBOSE)
++ if (outlevel >= O_VERBOSE) {
+ report(stdout, GT_("Server CommonName: %s\n"), (tt = sdump(buf, i)));
+- xfree(tt);
++ xfree(tt);
++ }
+ if ((size_t)i >= sizeof(buf) - 1) {
+ /* Possible truncation. In this case, this is a DNS name, so this
+ * is really bad. We do not tolerate this even in the non-strict case. */