aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-20 15:23:04 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-20 15:23:04 +0000
commit8a23e1166f8206bc7da200b085b6c811adcfa56c (patch)
tree118cf05f7264f52f0fdbf32dd99289f14fecc1d2
parentc83c9d3a2f0314e4bbf1febe4a6c4723b70637e1 (diff)
downloadports-8a23e1166f8206bc7da200b085b6c811adcfa56c.tar.gz
ports-8a23e1166f8206bc7da200b085b6c811adcfa56c.zip
Notes
-rw-r--r--print/Makefile1
-rw-r--r--print/pdfcube/Makefile31
-rw-r--r--print/pdfcube/distinfo3
-rw-r--r--print/pdfcube/pkg-descr9
4 files changed, 44 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index df012e0afa89..1ea88ab409eb 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -187,6 +187,7 @@
SUBDIR += passivetex
SUBDIR += pcal
SUBDIR += pclprint
+ SUBDIR += pdfcube
SUBDIR += pdfjam
SUBDIR += pdflib
SUBDIR += pdflib-perl
diff --git a/print/pdfcube/Makefile b/print/pdfcube/Makefile
new file mode 100644
index 000000000000..6163c59f3be4
--- /dev/null
+++ b/print/pdfcube/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: pdfcube
+# Date created: Apr. 20, 2007
+# Whom: Li-Wen Hsu <lwhsu@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdfcube
+PORTVERSION= 0.0.2
+CATEGORIES= print
+MASTER_SITES= # http://code.100allora.it/pdfcube/attachment/wiki/WikiStart/${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= An OpenGL presentation viewer on a spinning cube
+
+LIB_DEPENDS= glut:${PORTSDIR}/graphics/libglut \
+ gtkglext:${PORTSDIR}/x11-toolkits/gtkglext \
+ poppler-glib:${PORTSDIR}/graphics/poppler-gtk
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/pdfcube
+
+.include <bsd.port.pre.mk>
+
+do-fetch:
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+ ${FETCH_CMD} -o "${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}" "http://code.100allora.it/pdfcube/attachment/wiki/WikiStart/${DISTNAME}${EXTRACT_SUFX}?format=raw"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/print/pdfcube/distinfo b/print/pdfcube/distinfo
new file mode 100644
index 000000000000..5c5cca8a1b22
--- /dev/null
+++ b/print/pdfcube/distinfo
@@ -0,0 +1,3 @@
+MD5 (pdfcube-0.0.2.tar.gz) = 391fc1f65bbe1fcf5905d87d70749ba1
+SHA256 (pdfcube-0.0.2.tar.gz) = 1a1f951ec56abb15e59a4ef1f29c7d5dd4f95f4b59aa59f0a76e304e3f3140b0
+SIZE (pdfcube-0.0.2.tar.gz) = 318649
diff --git a/print/pdfcube/pkg-descr b/print/pdfcube/pkg-descr
new file mode 100644
index 000000000000..1b268f53ae51
--- /dev/null
+++ b/print/pdfcube/pkg-descr
@@ -0,0 +1,9 @@
+PDF Cube uses the OpenGL API to add 3D spinning cube page transitions to PDF
+documents.
+
+PDF Cube is an OpenGL API-based 3D PDF viewer that adds a compiz/Keynote-like
+spinning cube trasition effect to your PDF presentations (including
+LaTeX-Beamer and Prosper). You can also zoom on 5 predefined areas of any
+presentation page with a smooth zooming effect.
+
+WWW: http://code.100allora.it/pdfcube