aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-11-07 12:33:09 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-11-07 12:33:09 +0000
commit8c7ed9150e6ee5047b310291cbe22092464b73b0 (patch)
tree7d2a27fd7ebb2fe11d51895f0cb1e9b55da5815a
parent679a6dda9a0c3e92620e4d12e9645827ecfd56c0 (diff)
downloadports-8c7ed9150e6ee5047b310291cbe22092464b73b0.tar.gz
ports-8c7ed9150e6ee5047b310291cbe22092464b73b0.zip
Notes
-rw-r--r--www/p5-Gantry/Makefile113
-rw-r--r--www/p5-Gantry/files/patch-Build.PL19
-rw-r--r--www/p5-Gantry/pkg-plist193
-rw-r--r--www/p5-Geo-Caching/Makefile3
-rw-r--r--www/p5-Geo-Caching/pkg-plist7
-rw-r--r--www/p5-Gungho/Makefile62
-rw-r--r--www/p5-Gungho/pkg-plist60
7 files changed, 193 insertions, 264 deletions
diff --git a/www/p5-Gantry/Makefile b/www/p5-Gantry/Makefile
index 2373f43d5780..245986ada36b 100644
--- a/www/p5-Gantry/Makefile
+++ b/www/p5-Gantry/Makefile
@@ -10,25 +10,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Web application framework for mod_perl, cgi, etc
-BUILD_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
- p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
- p5-Data-UUID>=0:${PORTSDIR}/devel/p5-Data-UUID \
- p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc \
- p5-CGI-Simple>=0:${PORTSDIR}/www/p5-CGI-Simple \
- p5-Data-FormValidator>=0:${PORTSDIR}/textproc/p5-Data-FormValidator \
- p5-File-Copy-Recursive>=0:${PORTSDIR}/devel/p5-File-Copy-Recursive \
- p5-Hash-Merge>=0:${PORTSDIR}/textproc/p5-Hash-Merge \
- p5-HTML-Prototype>=0:${PORTSDIR}/www/p5-HTML-Prototype \
- p5-HTTP-Server-Simple>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple \
- p5-URI>=0:${PORTSDIR}/net/p5-URI \
- p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC \
- p5-Sub-Install>0:${PORTSDIR}/devel/p5-Sub-Install \
- p5-Mail-RFC822-Address>0:${PORTSDIR}/mail/p5-Mail-RFC822-Address \
- p5-Config-General>0:${PORTSDIR}/devel/p5-Config-General \
- p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
- p5-Template-Toolkit>=2.0:${PORTSDIR}/www/p5-Template-Toolkit \
- p5-Template-Plugin-HTML-SuperForm>0:${PORTSDIR}/textproc/p5-Template-Plugin-HTML-SuperForm
-RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
p5-Data-UUID>=0:${PORTSDIR}/devel/p5-Data-UUID \
p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc \
p5-CGI-Simple>=0:${PORTSDIR}/www/p5-CGI-Simple \
@@ -45,106 +27,21 @@ RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
p5-Template-Toolkit>=2.0:${PORTSDIR}/www/p5-Template-Toolkit \
p5-Template-Plugin-HTML-SuperForm>0:${PORTSDIR}/textproc/p5-Template-Plugin-HTML-SuperForm
-
-IS_INTERACTIVE= Asks about installation paths
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
USES= perl5
USE_PERL5= modbuild
+CONFIGURE_ARGS= </dev/null
WWWDIR= ${PREFIX}/www/${PORTNAME:L}
-MAN3= Gantry.3 \
- Gantry::Build.3 \
- Gantry::Conf.3 \
- Gantry::Conf::FAQ.3 \
- Gantry::Conf::Provider.3 \
- Gantry::Conf::Provider::FlatFile::Config::General.3 \
- Gantry::Conf::Provider::FlatFile::Config::Tiny.3 \
- Gantry::Conf::Provider::HTTP.3 \
- Gantry::Conf::Provider::HTTP::Config::General.3 \
- Gantry::Conf::Provider::ParamBuilder.3 \
- Gantry::Conf::Provider::PerlSetVar.3 \
- Gantry::Conf::Provider::SQL::PostgreSQL.3 \
- Gantry::Conf::Tutorial.3 Gantry::Control.3 \
- Gantry::Control::C::Access.3 \
- Gantry::Control::C::AuthenBase.3 \
- Gantry::Control::C::AuthenCDBI.3 \
- Gantry::Control::C::AuthenRegular.3 \
- Gantry::Control::C::Authz::PageBasedBase.3 \
- Gantry::Control::C::Authz::PageBasedCDBI.3 \
- Gantry::Control::C::Authz::PageBasedRegular.3 \
- Gantry::Control::C::AuthzBase.3 \
- Gantry::Control::C::AuthzCDBI.3 \
- Gantry::Control::C::AuthzRegular.3 \
- Gantry::Control::C::Groups.3 Gantry::Control::C::Pages.3 \
- Gantry::Control::C::Users.3 \
- Gantry::Control::Model::GEN::auth_group_members.3 \
- Gantry::Control::Model::GEN::auth_groups.3 \
- Gantry::Control::Model::GEN::auth_pages.3 \
- Gantry::Control::Model::GEN::auth_users.3 \
- Gantry::Control::Model::auth_group_members.3 \
- Gantry::Control::Model::auth_group_members_cdbi.3 \
- Gantry::Control::Model::auth_groups.3 \
- Gantry::Control::Model::auth_groups_cdbi.3 \
- Gantry::Control::Model::auth_pages.3 \
- Gantry::Control::Model::auth_pages_cdbi.3 \
- Gantry::Control::Model::auth_users.3 \
- Gantry::Control::Model::auth_users_cdbi.3 \
- Gantry::Docs.3 Gantry::Docs::Tutorial.3 \
- Gantry::Docs::About.3 Gantry::Docs::DBConn.3 \
- Gantry::Docs::Cookbook.3 \
- Gantry::Docs::FAQ.3 Gantry::Docs::QuickStart.3 \
- Gantry::Docs::Why.3 Gantry::Engine::CGI.3 \
- Gantry::Engine::MP13.3 Gantry::Engine::MP20.3 \
- Gantry::Exception.3 \
- Gantry::Init.3 Gantry::Plugins::AutoCRUD.3 \
- Gantry::Plugins::AjaxCRUD.3 \
- Gantry::Plugins::AjaxFORM.3 \
- Gantry::Plugins::AuthCookie.3 \
- Gantry::Plugins::AutoCRUDHelper::CDBI.3 \
- Gantry::Plugins::AutoCRUDHelper::DBIxClass.3 \
- Gantry::Plugins::CRUD.3 Gantry::Plugins::Calendar.3 \
- Gantry::Plugins::Cache.3 \
- Gantry::Plugins::Cache::FastMmap.3 \
- Gantry::Plugins::Cache::Memcached.3 \
- Gantry::Plugins::Cache::Storable.3 \
- Gantry::Plugins::DBIxClassConn.3 Gantry::Plugins::Static.3 \
- Gantry::Plugins::PageCache.3 \
- Gantry::Plugins::Shibboleth.3 \
- Gantry::Plugins::SOAP::Doc.3 \
- Gantry::Plugins::SOAP::RPC.3 \
- Gantry::Plugins::Validate.3 Gantry::Server.3 Gantry::Stash.3 \
- Gantry::Stash::Controller.3 Gantry::Stash::View.3 \
- Gantry::Stash::View::Form.3 Gantry::State::Simple.3 \
- Gantry::State::Default.3 Gantry::Template::Default.3 \
- Gantry::State::Exceptions.3 \
- Gantry::Template::Framing.3 Gantry::Template::TT.3 \
- Gantry::Utils::AuthCDBI.3 Gantry::Utils::CDBI.3 \
- Gantry::Utils::CRON.3 \
- Gantry::Utils::CRUDHelp.3 Gantry::Utils::Crypt.3 \
- Gantry::Utils::Captcha.3\
- Gantry::Utils::DB.3 \
- Gantry::Utils::DBConnHelper.3 \
- Gantry::Utils::DBConnHelper::MP13.3 \
- Gantry::Utils::DBConnHelper::MP20.3 \
- Gantry::Utils::DBConnHelper::Script.3 \
- Gantry::Utils::DBIxClass.3 Gantry::Utils::FormErrors.3 Gantry::Utils::HTML.3 \
- Gantry::Utils::FormMunger.3 \
- Gantry::Utils::Model.3 Gantry::Utils::Model::Auth.3 \
- Gantry::Utils::Model::Regular.3 Gantry::Utils::ModelHelper.3 \
- Gantry::Utils::PODViewer.3 Gantry::Utils::PerlbalFixup.3 \
- Gantry::Utils::SQL.3 Gantry::Utils::Validate.3 \
- Gantry::Utils::TablePerms.3 \
- Gantry::Utils::Threeway.3 \
- Template::Plugin::GantryAuthCookie.3
-
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e 's,/home/httpd/html/gantry,${WWWDIR},g' \
-e 's,\$ENV{'GANTRY_TEMPLATE_PATH'},${WWWDIR},g' \
${WRKSRC}/Build.PL
pre-su-install:
- @${MKDIR} ${WWWDIR}
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
.include <bsd.port.mk>
diff --git a/www/p5-Gantry/files/patch-Build.PL b/www/p5-Gantry/files/patch-Build.PL
index f247d54b9424..04ca30f4cf8b 100644
--- a/www/p5-Gantry/files/patch-Build.PL
+++ b/www/p5-Gantry/files/patch-Build.PL
@@ -1,6 +1,6 @@
---- ./Build.PL.orig 2009-07-14 17:08:45.608765850 -0400
-+++ ./Build.PL 2009-07-14 17:40:19.239457739 -0400
-@@ -106,27 +106,6 @@
+--- Build.PL.orig 2010-01-14 01:33:31.000000000 +0800
++++ Build.PL 2013-11-07 20:14:30.000000000 +0800
+@@ -107,27 +107,6 @@ if (! $template_path) {
$build->notes( install_web_directory => $template_path );
@@ -28,7 +28,16 @@
$build->create_build_script;
sub _custom_code {
-@@ -157,7 +136,6 @@
+@@ -151,14 +130,13 @@ sub _custom_code {
+
+ my $install_base = $self->install_destination('lib')
+ || $p->{install_sets}{site}{lib};
+-
+- my $initf = "$install_base/$p->{dist_name}/Init.pm";
++ my $destdir = $self->destdir;
++ my $initf = "$destdir$install_base/$p->{dist_name}/Init.pm";
+
+ $self->SUPER::ACTION_install();
my $tmpl_dir = $self->notes( 'install_web_directory' );
@@ -36,7 +45,7 @@
# write Init.pm file with install options
-@@ -235,10 +213,6 @@
+@@ -236,10 +214,6 @@ EO_INIT
else {
print "\n$num Gantry templates copied to $tmpl_dir\n";
}
diff --git a/www/p5-Gantry/pkg-plist b/www/p5-Gantry/pkg-plist
index 2cf6d94a0729..11c406f661c7 100644
--- a/www/p5-Gantry/pkg-plist
+++ b/www/p5-Gantry/pkg-plist
@@ -1,78 +1,111 @@
-%%WWWDIR%%/bookerrata.html
-%%WWWDIR%%/control_wrapper.tt
-%%WWWDIR%%/data.tt
-%%WWWDIR%%/default.tt
-%%WWWDIR%%/delete.tt
-%%WWWDIR%%/editor_init.ttc
-%%WWWDIR%%/form.tt
-%%WWWDIR%%/form_ajax.tt
-%%WWWDIR%%/gantry_site.html
-%%WWWDIR%%/gantrybookcode.tar.gz
-%%WWWDIR%%/login.tt
-%%WWWDIR%%/main.tt
-%%WWWDIR%%/paging.ttc
-%%WWWDIR%%/pod.tt
-%%WWWDIR%%/pod_wrapper.tt
-%%WWWDIR%%/results.tt
-%%WWWDIR%%/sample_wrapper.tt
-%%WWWDIR%%/search.tt
-%%WWWDIR%%/threeway.tt
-%%WWWDIR%%/wrapper.tt
-%%WWWDIR%%/wsdl.tt
-%%WWWDIR%%/wsdldoc.tt
-%%WWWDIR%%/yapcna2007.pdf
-%%WWWDIR%%/css/default.css
-%%WWWDIR%%/css/gantry_datepicker.css
-%%WWWDIR%%/css/gantry_forms.css
-%%WWWDIR%%/css/gantry_layout.css
-%%WWWDIR%%/css/gantry_site.css
-%%WWWDIR%%/css/my.css
-%%WWWDIR%%/css/pod_style.css
-%%WWWDIR%%/images/bar.a-center-gray.png
-%%WWWDIR%%/images/bar.a-left-gray.png
-%%WWWDIR%%/images/bar.a-right-gray.png
-%%WWWDIR%%/images/bar2-center-gray.png
-%%WWWDIR%%/images/bar2-left-gray.png
-%%WWWDIR%%/images/bar2-right-gray.png
-%%WWWDIR%%/images/blc-gray-block.gif
-%%WWWDIR%%/images/bookcover.gif
-%%WWWDIR%%/images/brc-gray-block.gif
-%%WWWDIR%%/images/building240.jpg
-%%WWWDIR%%/images/form.png
-%%WWWDIR%%/images/gantry_gears.jpg
-%%WWWDIR%%/images/gantry_logo.png
-%%WWWDIR%%/images/mainlist.png
-%%WWWDIR%%/images/pdf.gif
-%%WWWDIR%%/images/tlc-gray-block.gif
-%%WWWDIR%%/images/trc-gray-block.gif
-%%WWWDIR%%/images/tenttut/appbody.png
-%%WWWDIR%%/images/tenttut/appconfig.png
-%%WWWDIR%%/images/tenttut/appstat.png
-%%WWWDIR%%/images/tenttut/backends.png
-%%WWWDIR%%/images/tenttut/controledit.png
-%%WWWDIR%%/images/tenttut/dataedit.png
-%%WWWDIR%%/images/tenttut/fieldedit.png
-%%WWWDIR%%/images/tenttut/fieldedit2.png
-%%WWWDIR%%/images/tenttut/formedit.png
-%%WWWDIR%%/images/tenttut/joiner.png
-%%WWWDIR%%/images/tenttut/main_listingout.png
-%%WWWDIR%%/images/tenttut/mainlistedit.png
-%%WWWDIR%%/images/tenttut/optionsedit.png
-%%WWWDIR%%/images/tenttut/quickedit.png
-%%WWWDIR%%/images/tenttut/stubmethedit.png
-%%WWWDIR%%/images/tenttut/tableedit.png
-%%WWWDIR%%/images/tenttut/tentopening.png
-%%WWWDIR%%/js/datePicker.js
-%%WWWDIR%%/js/gantry-yui-calendar.js
-%%WWWDIR%%/js/gantry.js
-%%WWWDIR%%/js/jquery.js
-%%WWWDIR%%/moxie/delete.tt
-%%WWWDIR%%/moxie/form.tt
-%%WWWDIR%%/moxie/form_onetomany.tt
-%%WWWDIR%%/moxie/gantry_wrapper.tt
-%%WWWDIR%%/moxie/results.tt
-%%WWWDIR%%/moxie/threeway.tt
-%%WWWDIR%%/sfbb/form.tt
+%%PERL5_MAN3%%/Gantry.3.gz
+%%PERL5_MAN3%%/Gantry::Build.3.gz
+%%PERL5_MAN3%%/Gantry::Conf.3.gz
+%%PERL5_MAN3%%/Gantry::Conf::FAQ.3.gz
+%%PERL5_MAN3%%/Gantry::Conf::Provider.3.gz
+%%PERL5_MAN3%%/Gantry::Conf::Provider::FlatFile::Config::General.3.gz
+%%PERL5_MAN3%%/Gantry::Conf::Provider::FlatFile::Config::Tiny.3.gz
+%%PERL5_MAN3%%/Gantry::Conf::Provider::HTTP.3.gz
+%%PERL5_MAN3%%/Gantry::Conf::Provider::HTTP::Config::General.3.gz
+%%PERL5_MAN3%%/Gantry::Conf::Provider::ParamBuilder.3.gz
+%%PERL5_MAN3%%/Gantry::Conf::Provider::PerlSetVar.3.gz
+%%PERL5_MAN3%%/Gantry::Conf::Provider::SQL::PostgreSQL.3.gz
+%%PERL5_MAN3%%/Gantry::Conf::Tutorial.3.gz
+%%PERL5_MAN3%%/Gantry::Control.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::Access.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::AuthenBase.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::AuthenCDBI.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::AuthenRegular.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::Authz::PageBasedBase.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::Authz::PageBasedCDBI.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::Authz::PageBasedRegular.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::AuthzBase.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::AuthzCDBI.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::AuthzRegular.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::Groups.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::Pages.3.gz
+%%PERL5_MAN3%%/Gantry::Control::C::Users.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::GEN::auth_group_members.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::GEN::auth_groups.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::GEN::auth_pages.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::GEN::auth_users.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::auth_group_members.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::auth_group_members_cdbi.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::auth_groups.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::auth_groups_cdbi.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::auth_pages.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::auth_pages_cdbi.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::auth_users.3.gz
+%%PERL5_MAN3%%/Gantry::Control::Model::auth_users_cdbi.3.gz
+%%PERL5_MAN3%%/Gantry::Docs.3.gz
+%%PERL5_MAN3%%/Gantry::Docs::About.3.gz
+%%PERL5_MAN3%%/Gantry::Docs::Cookbook.3.gz
+%%PERL5_MAN3%%/Gantry::Docs::DBConn.3.gz
+%%PERL5_MAN3%%/Gantry::Docs::FAQ.3.gz
+%%PERL5_MAN3%%/Gantry::Docs::QuickStart.3.gz
+%%PERL5_MAN3%%/Gantry::Docs::Tutorial.3.gz
+%%PERL5_MAN3%%/Gantry::Docs::Why.3.gz
+%%PERL5_MAN3%%/Gantry::Engine::CGI.3.gz
+%%PERL5_MAN3%%/Gantry::Engine::MP13.3.gz
+%%PERL5_MAN3%%/Gantry::Engine::MP20.3.gz
+%%PERL5_MAN3%%/Gantry::Exception.3.gz
+%%PERL5_MAN3%%/Gantry::Init.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::AjaxCRUD.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::AjaxFORM.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::AuthCookie.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::AutoCRUD.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::AutoCRUDHelper::CDBI.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::AutoCRUDHelper::DBIxClass.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::CRUD.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::Cache.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::Cache::FastMmap.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::Cache::Memcached.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::Cache::Storable.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::Calendar.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::DBIxClassConn.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::PageCache.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::SOAP::Doc.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::SOAP::RPC.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::Shibboleth.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::Static.3.gz
+%%PERL5_MAN3%%/Gantry::Plugins::Validate.3.gz
+%%PERL5_MAN3%%/Gantry::Server.3.gz
+%%PERL5_MAN3%%/Gantry::Stash.3.gz
+%%PERL5_MAN3%%/Gantry::Stash::Controller.3.gz
+%%PERL5_MAN3%%/Gantry::Stash::View.3.gz
+%%PERL5_MAN3%%/Gantry::Stash::View::Form.3.gz
+%%PERL5_MAN3%%/Gantry::State::Default.3.gz
+%%PERL5_MAN3%%/Gantry::State::Exceptions.3.gz
+%%PERL5_MAN3%%/Gantry::State::Simple.3.gz
+%%PERL5_MAN3%%/Gantry::Template::Default.3.gz
+%%PERL5_MAN3%%/Gantry::Template::Framing.3.gz
+%%PERL5_MAN3%%/Gantry::Template::TT.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::AuthCDBI.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::CDBI.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::CRON.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::CRUDHelp.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::Captcha.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::Crypt.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::DB.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::DBConnHelper.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::DBConnHelper::MP13.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::DBConnHelper::MP20.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::DBConnHelper::Script.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::DBIxClass.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::FormErrors.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::FormMunger.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::HTML.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::Model.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::Model::Auth.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::Model::Regular.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::ModelHelper.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::PODViewer.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::PerlbalFixup.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::SQL.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::TablePerms.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::Threeway.3.gz
+%%PERL5_MAN3%%/Gantry::Utils::Validate.3.gz
+%%PERL5_MAN3%%/Template::Plugin::GantryAuthCookie.3.gz
%%SITE_PERL%%/Gantry.pm
%%SITE_PERL%%/Gantry/Build.pm
%%SITE_PERL%%/Gantry/Conf.pm
@@ -139,9 +172,9 @@
%%SITE_PERL%%/Gantry/Plugins/Calendar.pm
%%SITE_PERL%%/Gantry/Plugins/DBIxClassConn.pm
%%SITE_PERL%%/Gantry/Plugins/PageCache.pm
-%%SITE_PERL%%/Gantry/Plugins/Shibboleth.pm
%%SITE_PERL%%/Gantry/Plugins/SOAP/Doc.pm
%%SITE_PERL%%/Gantry/Plugins/SOAP/RPC.pm
+%%SITE_PERL%%/Gantry/Plugins/Shibboleth.pm
%%SITE_PERL%%/Gantry/Plugins/Static.pm
%%SITE_PERL%%/Gantry/Plugins/Validate.pm
%%SITE_PERL%%/Gantry/Server.pm
@@ -182,13 +215,7 @@
%%SITE_PERL%%/Gantry/Utils/Threeway.pm
%%SITE_PERL%%/Gantry/Utils/Validate.pm
%%SITE_PERL%%/Template/Plugin/GantryAuthCookie.pm
-@dirrmtry %%WWWDIR%%/sfbb
-@dirrmtry %%WWWDIR%%/moxie
-@dirrmtry %%WWWDIR%%/js
-@dirrmtry %%WWWDIR%%/images/tenttut
-@dirrmtry %%WWWDIR%%/images
-@dirrmtry %%WWWDIR%%/css
-@dirrmtry %%WWWDIR%%
+@dirrmtry www/gantry
@dirrmtry %%SITE_PERL%%/Template/Plugin
@dirrmtry %%SITE_PERL%%/Template
@dirrmtry %%SITE_PERL%%/Gantry/Utils/Model
diff --git a/www/p5-Geo-Caching/Makefile b/www/p5-Geo-Caching/Makefile
index 90538bcbc508..23ec8d8ef613 100644
--- a/www/p5-Geo-Caching/Makefile
+++ b/www/p5-Geo-Caching/Makefile
@@ -16,10 +16,7 @@ BUILD_DEPENDS= p5-Geo-Cache>=0:${PORTSDIR}/misc/p5-Geo-Cache \
p5-Geo-Gpx>=0:${PORTSDIR}/graphics/p5-Geo-Gpx
RUN_DEPENDS:= ${BUILD_DEPENDS}
-MAN3= Geo::Caching.3
-
USES= perl5
USE_PERL5= configure
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/p5-Geo-Caching/pkg-plist b/www/p5-Geo-Caching/pkg-plist
index b06d8c463575..3701875b4f8c 100644
--- a/www/p5-Geo-Caching/pkg-plist
+++ b/www/p5-Geo-Caching/pkg-plist
@@ -1,5 +1,6 @@
+%%PERL5_MAN3%%/Geo::Caching.3.gz
%%SITE_PERL%%/Geo/Caching.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Caching/.packlist
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Caching
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
-@dirrm %%SITE_PERL%%/Geo
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Caching
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo
diff --git a/www/p5-Gungho/Makefile b/www/p5-Gungho/Makefile
index 2957279d18db..56c8e07a6fdd 100644
--- a/www/p5-Gungho/Makefile
+++ b/www/p5-Gungho/Makefile
@@ -12,7 +12,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= perl@FreeBSD.org
COMMENT= Event Based High Performance Web Crawler Framework
-RUN_DEPENDS= p5-Best>=0:${PORTSDIR}/devel/p5-Best \
+BUILD_DEPENDS= p5-Best>=0:${PORTSDIR}/devel/p5-Best \
p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Class-C3-Componentised>=0:${PORTSDIR}/devel/p5-Class-C3-Componentised \
p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
@@ -43,68 +43,12 @@ RUN_DEPENDS= p5-Best>=0:${PORTSDIR}/devel/p5-Best \
p5-POE-Component-Client-HTTP>=0.81:${PORTSDIR}/www/p5-POE-Component-Client-HTTP \
p5-POE>=0.9999:${PORTSDIR}/devel/p5-POE \
p5-UNIVERSAL-isa>=0.06:${PORTSDIR}/devel/p5-UNIVERSAL-isa
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN1= gungho.1
-MAN3= Gungho.3 \
- Gungho::Base.3 \
- Gungho::Base::Class.3 \
- Gungho::Component.3 \
- Gungho::Component::Authentication.3 \
- Gungho::Component::Authentication::Basic.3 \
- Gungho::Component::BlockPrivateIP.3 \
- Gungho::Component::Cache.3 \
- Gungho::Component::Core.3 \
- Gungho::Component::RobotRules.3 \
- Gungho::Component::RobotRules::Rule.3 \
- Gungho::Component::RobotRules::Storage.3 \
- Gungho::Component::RobotRules::Storage::Cache.3 \
- Gungho::Component::RobotRules::Storage::DB_File.3 \
- Gungho::Component::RobotsMETA.3 \
- Gungho::Component::Scraper.3 \
- Gungho::Component::Setup.3 \
- Gungho::Component::Throttle.3 \
- Gungho::Component::Throttle::Domain.3 \
- Gungho::Component::Throttle::Provider.3 \
- Gungho::Component::Throttle::Simple.3 \
- Gungho::Component::Throttle::Throttler.3 \
- Gungho::Engine.3 \
- Gungho::Engine::Danga::Socket.3 \
- Gungho::Engine::IO::Async.3 \
- Gungho::Engine::POE.3 \
- Gungho::Exception.3 \
- Gungho::Handler.3 \
- Gungho::Handler::FileWriter::Simple.3 \
- Gungho::Handler::Inline.3 \
- Gungho::Handler::Null.3 \
- Gungho::Inline.3 \
- Gungho::Log.3 \
- Gungho::Log::Dispatch.3 \
- Gungho::Log::Simple.3 \
- Gungho::Manual::FAQ.3 \
- Gungho::Manual::TODO.3 \
- Gungho::Plugin.3 \
- Gungho::Plugin::Apoptosis.3 \
- Gungho::Plugin::RequestLog.3 \
- Gungho::Plugin::RequestTimer.3 \
- Gungho::Plugin::Statistics.3 \
- Gungho::Plugin::Statistics::Format::XML.3 \
- Gungho::Plugin::Statistics::Storage::SQLite.3 \
- Gungho::Provider.3 \
- Gungho::Provider::File::Simple.3 \
- Gungho::Provider::Inline.3 \
- Gungho::Provider::Simple.3 \
- Gungho::Provider::YAML.3 \
- Gungho::Request.3 \
- Gungho::Request::http.3 \
- Gungho::Response.3 \
- Gungho::Util.3
-
-NO_STAGE= yes
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/script/gungho ${PREFIX}/bin/gungho
+ ${INSTALL_SCRIPT} ${WRKSRC}/script/gungho ${STAGEDIR}${PREFIX}/bin/gungho
.include <bsd.port.mk>
diff --git a/www/p5-Gungho/pkg-plist b/www/p5-Gungho/pkg-plist
index bae663ac1f4a..97cecb4c5968 100644
--- a/www/p5-Gungho/pkg-plist
+++ b/www/p5-Gungho/pkg-plist
@@ -1,4 +1,57 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Gungho/.packlist
+bin/gungho
+%%PERL5_MAN3%%/Gungho.3.gz
+%%PERL5_MAN3%%/Gungho::Base.3.gz
+%%PERL5_MAN3%%/Gungho::Base::Class.3.gz
+%%PERL5_MAN3%%/Gungho::Component.3.gz
+%%PERL5_MAN3%%/Gungho::Component::Authentication.3.gz
+%%PERL5_MAN3%%/Gungho::Component::Authentication::Basic.3.gz
+%%PERL5_MAN3%%/Gungho::Component::BlockPrivateIP.3.gz
+%%PERL5_MAN3%%/Gungho::Component::Cache.3.gz
+%%PERL5_MAN3%%/Gungho::Component::Core.3.gz
+%%PERL5_MAN3%%/Gungho::Component::RobotRules.3.gz
+%%PERL5_MAN3%%/Gungho::Component::RobotRules::Rule.3.gz
+%%PERL5_MAN3%%/Gungho::Component::RobotRules::Storage.3.gz
+%%PERL5_MAN3%%/Gungho::Component::RobotRules::Storage::Cache.3.gz
+%%PERL5_MAN3%%/Gungho::Component::RobotRules::Storage::DB_File.3.gz
+%%PERL5_MAN3%%/Gungho::Component::RobotsMETA.3.gz
+%%PERL5_MAN3%%/Gungho::Component::Scraper.3.gz
+%%PERL5_MAN3%%/Gungho::Component::Setup.3.gz
+%%PERL5_MAN3%%/Gungho::Component::Throttle.3.gz
+%%PERL5_MAN3%%/Gungho::Component::Throttle::Domain.3.gz
+%%PERL5_MAN3%%/Gungho::Component::Throttle::Provider.3.gz
+%%PERL5_MAN3%%/Gungho::Component::Throttle::Simple.3.gz
+%%PERL5_MAN3%%/Gungho::Component::Throttle::Throttler.3.gz
+%%PERL5_MAN3%%/Gungho::Engine.3.gz
+%%PERL5_MAN3%%/Gungho::Engine::Danga::Socket.3.gz
+%%PERL5_MAN3%%/Gungho::Engine::IO::Async.3.gz
+%%PERL5_MAN3%%/Gungho::Engine::POE.3.gz
+%%PERL5_MAN3%%/Gungho::Exception.3.gz
+%%PERL5_MAN3%%/Gungho::Handler.3.gz
+%%PERL5_MAN3%%/Gungho::Handler::FileWriter::Simple.3.gz
+%%PERL5_MAN3%%/Gungho::Handler::Inline.3.gz
+%%PERL5_MAN3%%/Gungho::Handler::Null.3.gz
+%%PERL5_MAN3%%/Gungho::Inline.3.gz
+%%PERL5_MAN3%%/Gungho::Log.3.gz
+%%PERL5_MAN3%%/Gungho::Log::Dispatch.3.gz
+%%PERL5_MAN3%%/Gungho::Log::Simple.3.gz
+%%PERL5_MAN3%%/Gungho::Manual::FAQ.3.gz
+%%PERL5_MAN3%%/Gungho::Manual::TODO.3.gz
+%%PERL5_MAN3%%/Gungho::Plugin.3.gz
+%%PERL5_MAN3%%/Gungho::Plugin::Apoptosis.3.gz
+%%PERL5_MAN3%%/Gungho::Plugin::RequestLog.3.gz
+%%PERL5_MAN3%%/Gungho::Plugin::RequestTimer.3.gz
+%%PERL5_MAN3%%/Gungho::Plugin::Statistics.3.gz
+%%PERL5_MAN3%%/Gungho::Plugin::Statistics::Format::XML.3.gz
+%%PERL5_MAN3%%/Gungho::Plugin::Statistics::Storage::SQLite.3.gz
+%%PERL5_MAN3%%/Gungho::Provider.3.gz
+%%PERL5_MAN3%%/Gungho::Provider::File::Simple.3.gz
+%%PERL5_MAN3%%/Gungho::Provider::Inline.3.gz
+%%PERL5_MAN3%%/Gungho::Provider::Simple.3.gz
+%%PERL5_MAN3%%/Gungho::Provider::YAML.3.gz
+%%PERL5_MAN3%%/Gungho::Request.3.gz
+%%PERL5_MAN3%%/Gungho::Request::http.3.gz
+%%PERL5_MAN3%%/Gungho::Response.3.gz
+%%PERL5_MAN3%%/Gungho::Util.3.gz
%%SITE_PERL%%/Gungho.pm
%%SITE_PERL%%/Gungho/Base.pm
%%SITE_PERL%%/Gungho/Base/Class.pm
@@ -52,7 +105,9 @@
%%SITE_PERL%%/Gungho/Request/http.pm
%%SITE_PERL%%/Gungho/Response.pm
%%SITE_PERL%%/Gungho/Util.pm
-bin/gungho
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Gungho/.packlist
+man/man1/gungho.1.gz
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gungho
@dirrmtry %%SITE_PERL%%/Gungho/Request
@dirrmtry %%SITE_PERL%%/Gungho/Provider/File
@dirrmtry %%SITE_PERL%%/Gungho/Provider
@@ -74,4 +129,3 @@ bin/gungho
@dirrmtry %%SITE_PERL%%/Gungho/Component
@dirrmtry %%SITE_PERL%%/Gungho/Base
@dirrmtry %%SITE_PERL%%/Gungho
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gungho