aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2016-09-13 18:37:43 +0000
committerDimitry Andric <dim@FreeBSD.org>2016-09-13 18:37:43 +0000
commit9b40b6af905fd84afaa7e1e2b968d3fef5363447 (patch)
tree3af2374b97307890fa23340c6485a2c941d844a7
parent33b0d66d1ed2bc5a4e331b0a01018425f23820e1 (diff)
downloadports-9b40b6af905fd84afaa7e1e2b968d3fef5363447.tar.gz
ports-9b40b6af905fd84afaa7e1e2b968d3fef5363447.zip
MFH: r421953
Fix build of audio/clementine-player with clang 3.9.0 Clang 3.9.0 has a new warning about undefined template variables, which is triggered by including cryptopp headers in the spotify blob downloader: In file included from /wrkdirs/usr/ports/audio/clementine-player/work/Clementine-1.3.1/src/internet/spotify/spotifyblobdownloader.cpp:43: /usr/local/include/cryptopp/pkcspad.h:74:53: error: instantiation of variable 'CryptoPP::PKCS_DigestDecoration<CryptoPP::SHA512>::decoration' required here, but no definition is available [-Werror,-Wundefined-var-template] return HashIdentifier(PKCS_DigestDecoration<H>::decoration, PKCS_DigestDecoration<H>::length); ^ This warning could be silenced by hacking on cryptopp, but just suppress it for now. Approved by: portmgr (feld) PR: 212343
Notes
Notes: svn path=/branches/2016Q3/; revision=422055
-rw-r--r--audio/clementine-player/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/audio/clementine-player/Makefile b/audio/clementine-player/Makefile
index ebcfb7d3cc49..0d301975f568 100644
--- a/audio/clementine-player/Makefile
+++ b/audio/clementine-player/Makefile
@@ -198,4 +198,10 @@ VISUALISATION_CMAKE_OFF=-DENABLE_VISUALISATIONS=OFF
WIIMOTEDEV_CMAKE_ON= -DENABLE_WIIMOTEDEV=ON
WIIMOTEDEV_CMAKE_OFF= -DENABLE_WIIMOTEDEV=OFF
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 39
+CXXFLAGS+= -Wno-undefined-var-template
+.endif
+
.include <bsd.port.mk>