aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-09-09 01:21:47 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-09-09 01:21:47 +0000
commita7d6d44ecb89da86a4b1cf4b0071abf5222be9cb (patch)
treee5669c99691623c8936472169b1bcce6e8339c5a
parentce9d222b68bbc2c4b6897648f6c4dfcd6f0d4e90 (diff)
downloadports-a7d6d44ecb89da86a4b1cf4b0071abf5222be9cb.tar.gz
ports-a7d6d44ecb89da86a4b1cf4b0071abf5222be9cb.zip
Notes
-rw-r--r--audio/soundtracker/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/audio/soundtracker/Makefile b/audio/soundtracker/Makefile
index 73dfd15439fd..58eac98eff15 100644
--- a/audio/soundtracker/Makefile
+++ b/audio/soundtracker/Makefile
@@ -15,6 +15,8 @@ MAINTAINER= kzentner@u.washington.edu
USE_X_PREFIX= yes
USE_GNOMENG= yes
WANT_GNOME= yes
+USE_GNOME= gtk12
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -22,18 +24,15 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
.include <bsd.port.pre.mk>
.if ${HAVE_GNOME:Mgnomelibs}!=""
-USE_GNOME= gtk12 esound
+USE_GNOME= gnomelibs esound gnomeprefix gnomehack
CONFIGURE_ARGS+=--enable-gnome
PKGNAMESUFFIX= -gnome
.else
CONFIGURE_ARGS+=--disable-gnome
.endif
-pre-patch:
- @${PERL} -pi -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.post.mk>