aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-10-19 03:05:02 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-10-19 03:05:02 +0000
commitb09f4b5d0440860809387e0968142c75c2b06120 (patch)
tree09d67c4d2759b95318856afb7d393fab03511982
parent2947fd0451773b83d24b7fac835983e881624132 (diff)
downloadports-b09f4b5d0440860809387e0968142c75c2b06120.tar.gz
ports-b09f4b5d0440860809387e0968142c75c2b06120.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/unison-devel/Makefile73
-rw-r--r--net/unison-devel/distinfo12
-rw-r--r--net/unison-devel/pkg-descr15
-rw-r--r--net/unison-devel/pkg-message4
-rw-r--r--net/unison-devel/pkg-plist9
6 files changed, 114 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 246fd3254c72..ab692cd69d56 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -893,6 +893,7 @@
SUBDIR += ulxmlrpcpp
SUBDIR += unfs3
SUBDIR += unison
+ SUBDIR += unison-devel
SUBDIR += unix2tcp
SUBDIR += uplog
SUBDIR += uproxy
diff --git a/net/unison-devel/Makefile b/net/unison-devel/Makefile
new file mode 100644
index 000000000000..e4cb39b8aac6
--- /dev/null
+++ b/net/unison-devel/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: unison
+# Date created: 4 October 2000
+# Whom: Dan Pelleg <dpelleg+unison@cs.cmu.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unison
+PORTVERSION= 2.27.29
+CATEGORIES= net
+MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${DISTNAME}/
+PKGNAMESUFFIX= -devel
+DISTFILES= ${EXTRACT_ONLY} ${EXTRA_DOCS}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
+
+MAINTAINER= daniel+unison@pelleg.org
+COMMENT= A user-level file synchronization tool
+
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+USE_GMAKE= yes
+MAKE_ARGS= CFLAGS=""
+CONFLICTS= unison-[0-9]*
+
+.include <bsd.port.pre.mk>
+
+.if !defined(NOPORTDOCS)
+DOCS= BUGS.txt NEWS README
+EXTRA_DOCS= unison-${PORTVERSION}-manual.html \
+ unison-${PORTVERSION}-manual.pdf unison-${PORTVERSION}-manual.ps
+.endif
+
+.if !defined(WITHOUT_GTK2) && !defined(WITHOUT_X11)
+WITH_GTK2= yes
+.endif
+
+.if defined(WITH_GTK2)
+MAKE_ARGS+= UISTYLE=gtk2
+PLIST_SUB+= TEXT=""
+BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml \
+ lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
+RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
+PATCH_DEPENDS+= ${BUILD_DEPENDS}
+CONFLICTS+= ocaml-nox11*
+.else
+MAKE_ARGS+= UISTYLE=text
+PLIST_SUB+= TEXT="@comment "
+BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml-nox11
+PATCH_DEPENDS+= ${BUILD_DEPENDS}
+.endif
+
+.if defined(WITH_GTK2)
+post-build:
+ @${ECHO} Building text-only version
+ @${ECHO} ${WRKSRC}
+ @${GMAKE} -C ${WRKSRC} UISTYLE=text NAME=unison-text
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/unison ${PREFIX}/bin
+
+post-install:
+.if defined(WITH_GTK2)
+ @${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${PREFIX}/bin
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net/unison-devel/distinfo b/net/unison-devel/distinfo
new file mode 100644
index 000000000000..57846598ceb2
--- /dev/null
+++ b/net/unison-devel/distinfo
@@ -0,0 +1,12 @@
+MD5 (unison-2.27.29/unison-2.27.29.tar.gz) = a79280de81c6cf47014ddc6881911323
+SHA256 (unison-2.27.29/unison-2.27.29.tar.gz) = 3665346238db717e0439476c1ddbde754e4becf5c0fdd70652f107dbda1254b7
+SIZE (unison-2.27.29/unison-2.27.29.tar.gz) = 591171
+MD5 (unison-2.27.29/unison-2.27.29-manual.html) = 6fbe74c53d36e7ef6dd5014d7818f4c1
+SHA256 (unison-2.27.29/unison-2.27.29-manual.html) = 8ebe142ae15ed66bcc061ad6935aab23f67c8fde5eb9ce54c96a712f53ea576a
+SIZE (unison-2.27.29/unison-2.27.29-manual.html) = 231860
+MD5 (unison-2.27.29/unison-2.27.29-manual.pdf) = 96e64571ea7d96d29ceab89df19b2f90
+SHA256 (unison-2.27.29/unison-2.27.29-manual.pdf) = 649eb962673ef830b472115262a7474d376f6ae0815a3fd9644789e306fcdda0
+SIZE (unison-2.27.29/unison-2.27.29-manual.pdf) = 451367
+MD5 (unison-2.27.29/unison-2.27.29-manual.ps) = 2cff68790108f324e4ce90f281e15a6b
+SHA256 (unison-2.27.29/unison-2.27.29-manual.ps) = 5e6fdb9b565169383a20cfe99e9f696bccedebb4d964ddab115473607b61c80a
+SIZE (unison-2.27.29/unison-2.27.29-manual.ps) = 530115
diff --git a/net/unison-devel/pkg-descr b/net/unison-devel/pkg-descr
new file mode 100644
index 000000000000..10d805d9eb0a
--- /dev/null
+++ b/net/unison-devel/pkg-descr
@@ -0,0 +1,15 @@
+Unison is a file-synchronization tool for Unix and Windows. It allows two
+replicas of a collection of files and directories to be stored on different
+hosts (or different disks on the same host), modified separately, and then
+brought up to date by propagating the changes in each replica to the other.
+
+Unison shares a number of features with tools such as configuration
+management packages (CVS, PRCS, etc.) distributed filesystems (Coda, etc.)
+uni-directional mirroring utilities (rsync, etc.) and other synchronizers
+(Intellisync, Reconcile, etc).
+
+WWW: http://www.cis.upenn.edu/~bcpierce/unison/
+
+- Dan Pelleg
+
+daniel+unison@pelleg.org
diff --git a/net/unison-devel/pkg-message b/net/unison-devel/pkg-message
new file mode 100644
index 000000000000..3c1cfd40d2c0
--- /dev/null
+++ b/net/unison-devel/pkg-message
@@ -0,0 +1,4 @@
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+Together with a gtk-enabled version, a text-only unison-text binary
+is installed as it depends on a smaller number of libraries.
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
diff --git a/net/unison-devel/pkg-plist b/net/unison-devel/pkg-plist
new file mode 100644
index 000000000000..7fc5e3d995b4
--- /dev/null
+++ b/net/unison-devel/pkg-plist
@@ -0,0 +1,9 @@
+bin/unison
+%%TEXT%%bin/unison-text
+%%PORTDOCS%%%%DOCSDIR%%/BUGS.txt
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/unison-%%PORTVERSION%%-manual.html
+%%PORTDOCS%%%%DOCSDIR%%/unison-%%PORTVERSION%%-manual.pdf
+%%PORTDOCS%%%%DOCSDIR%%/unison-%%PORTVERSION%%-manual.ps
+%%PORTDOCS%%@dirrm %%DOCSDIR%%