aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-11-07 12:45:47 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-11-07 12:45:47 +0000
commitcbf85e81627467ee413af6717deb5e6f5d97854e (patch)
treed79fbe52e5704f9d4200211fa336b26a5cdab108
parent8c7ed9150e6ee5047b310291cbe22092464b73b0 (diff)
downloadports-cbf85e81627467ee413af6717deb5e6f5d97854e.tar.gz
ports-cbf85e81627467ee413af6717deb5e6f5d97854e.zip
Notes
-rw-r--r--games/xtrojka/Makefile24
-rw-r--r--games/xtrojka/distinfo4
-rw-r--r--games/xtrojka/files/old-patch-Makefile (renamed from games/xtrojka/files/patch-aa)0
-rw-r--r--games/xtrojka/files/patch-Makefile78
-rw-r--r--games/xtrojka/files/patch-resgen12
-rw-r--r--games/xtrojka/pkg-plist1
6 files changed, 104 insertions, 15 deletions
diff --git a/games/xtrojka/Makefile b/games/xtrojka/Makefile
index 08956b4c7efd..5c01f5018b19 100644
--- a/games/xtrojka/Makefile
+++ b/games/xtrojka/Makefile
@@ -1,26 +1,24 @@
-# Created by: Edwin Mons
# $FreeBSD$
PORTNAME= xtrojka
-PORTVERSION= 1.1
-PORTREVISION= 3
+PORTVERSION= 1.2.3
CATEGORIES= games
-MASTER_SITES= ftp://ftp.funet.fi/pub/unix/games/
-DISTNAME= ${PORTNAME}
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= games/arcade/tetris
+DISTNAME= ${PORTNAME}${PORTVERSION:C/\.//g}
-MAINTAINER= e@ik.nu
+MAINTAINER= ports@edwinm.ik.nu
COMMENT= Game of skill similar to T*tris
-USE_XORG= x11 xt xproto xaw
-WRKSRC= ${WRKDIR}
-MAN6= xtrojka.6
-MANCOMPRESSED= yes
+USE_XORG= x11 xt xproto xaw xmu xext
+MAKE_JOBS_UNSAFE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
-NO_STAGE= yes
pre-install:
- ${MKDIR} ${PREFIX}/share/xtrojka
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/xtrojka
post-install:
- ${STRIP_CMD} ${PREFIX}/bin/xtrojka
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xtrojka
.include <bsd.port.mk>
diff --git a/games/xtrojka/distinfo b/games/xtrojka/distinfo
index ee040ed238d7..ea45efc6a7a2 100644
--- a/games/xtrojka/distinfo
+++ b/games/xtrojka/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xtrojka.tar.gz) = a94d3b2b1920a4b542ac6e4bc9f39de855a81991304015267975da1753550e93
-SIZE (xtrojka.tar.gz) = 27021
+SHA256 (xtrojka123.tar.gz) = dae9cb2094914060f00d6cb15842cd7ecd71a78347bf12b2e7539e9ba8d89932
+SIZE (xtrojka123.tar.gz) = 49446
diff --git a/games/xtrojka/files/patch-aa b/games/xtrojka/files/old-patch-Makefile
index fc405e53b436..fc405e53b436 100644
--- a/games/xtrojka/files/patch-aa
+++ b/games/xtrojka/files/old-patch-Makefile
diff --git a/games/xtrojka/files/patch-Makefile b/games/xtrojka/files/patch-Makefile
new file mode 100644
index 000000000000..6ef78229eb8a
--- /dev/null
+++ b/games/xtrojka/files/patch-Makefile
@@ -0,0 +1,78 @@
+--- Makefile.orig 1996-07-27 20:05:03.000000000 +0200
++++ Makefile 2013-09-12 11:55:14.000000000 +0200
+@@ -10,15 +10,15 @@
+ # xtrojka version (do not change!)
+ VERSION=123
+ # where to put the binary
+-TARGET_DIR=/usr/games
++TARGET_DIR=${PREFIX}/bin
+ # where to put the manpage
+-MANDIR=/usr/local/man/man6
++MANDIR=${PREFIX}/man/man6
+ # the location of the highscorefile
+-HSFILE=/fill_in_your_scorefile
++HSFILE=${PREFIX}/share/xtrojka/xtrojka.scores
+ # your favourite packer
+ COMPRESS=gzip -v9
+ # your favourite c-compiler
+-CC=gcc
++CC?=gcc
+ # used X libraries
+ XLIBS= -lXaw -lXmu -lXt -lX11 -lXext
+ # some more X libraries
+@@ -48,7 +48,7 @@
+ # comment out your favorite system (the one you use, that is...)
+ #
+ # search the libaries here
+-LIBPATH=-L/usr/X11/lib
++LIBPATH=-L${LOCALBASE}/lib
+ # doesn't work too well on all systems
+ #LCK=-DLOCKING
+ # add debug info
+@@ -75,7 +75,13 @@
+ #
+ # Linux
+ #
+-SYS=-DLINUX
++#SYS=-DLINUX
++
++#
++# FreeBSD
++#
++XDIR=-I${LOCALBASE}/include
++LIBS=-lm
+
+ #
+ #
+@@ -105,11 +111,17 @@
+ rm -rf xtrojka$(VERSION);
+
+ install:
+- @echo $(HSFILE)|sed -e 's/\//\\\//g'>/tmp/hsn; \
+- sed -e "s/__SCOREDIR__/`cat /tmp/hsn`/g" xtrojka.man > xtrojka.6; \
+- cp xtrojka.6 $(MANDIR); chmod go+r xtrojka.6; \
+- cp xtrojka $(TARGET_DIR);chmod go+rx xtrojka; \
+- touch $(HSFILE); chmod go+rwx $(HSFILE);
++ @rm -f hsn
++ echo $(HSFILE)|sed -e 's/\//\\\//g'>hsn
++ sed -e "s/__SCOREDIR__/`cat hsn`/g" xtrojka.man > xtrojka.6
++ gzip -c xtrojka.6 >$(MANDIR)/xtrojka.6.gz
++ cp xtrojka $(TARGET_DIR)
++ chmod 2755 $(TARGET_DIR)/xtrojka
++ chgrp games $(TARGET_DIR)/xtrojka
++ touch $(HSFILE)
++ chmod 664 $(HSFILE)
++ chgrp games $(HSFILE)
++ @rm -f hsn
+
+ clean:
+ rm -rf tags *.o core xtrojka xtrojka.6
+@@ -119,7 +131,7 @@
+ # DEPENDENCIES
+ #
+
+-_strdefs.h _resdefs.h: XTrojka
++_strdefs.h _resdefs.h: XTrojka.uk
+ $(RESGEN)
+
+ actions.o: actions.c actions.h xtrojka.h debug.h
diff --git a/games/xtrojka/files/patch-resgen b/games/xtrojka/files/patch-resgen
new file mode 100644
index 000000000000..c93d381020d7
--- /dev/null
+++ b/games/xtrojka/files/patch-resgen
@@ -0,0 +1,12 @@
+--- resgen.orig 2013-09-12 11:56:10.000000000 +0200
++++ resgen 2013-09-12 11:56:20.000000000 +0200
+@@ -16,7 +16,8 @@
+ # These files will be included
+ # in the source code as a fall-back resource.
+ #
+-INPUT=XTrojka
++set -x
++INPUT=XTrojka.uk
+ RESFILE=_resdefs.h
+ HFILE=_strdefs.h
+ H="/* hoi */"
diff --git a/games/xtrojka/pkg-plist b/games/xtrojka/pkg-plist
index 8675c31bec55..a76921978c5c 100644
--- a/games/xtrojka/pkg-plist
+++ b/games/xtrojka/pkg-plist
@@ -1,3 +1,4 @@
bin/xtrojka
share/xtrojka/xtrojka.scores
+man/man6/xtrojka.6.gz
@dirrm share/xtrojka