aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-03 07:36:27 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-03 07:36:27 +0000
commitce4a95abd3b40c19c0e3564360b7985d33abcb53 (patch)
tree7c102152716d606b0c7f013ac64b236af918860d
parent2881c2261a080efa6e115f750665311e278e2be2 (diff)
downloadports-ce4a95abd3b40c19c0e3564360b7985d33abcb53.tar.gz
ports-ce4a95abd3b40c19c0e3564360b7985d33abcb53.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/spat/Makefile42
-rw-r--r--net/spat/distinfo1
-rw-r--r--net/spat/files/patch-aa20
-rw-r--r--net/spat/files/patch-ab29
-rw-r--r--net/spat/files/patch-ac20
-rw-r--r--net/spat/files/patch-ad11
-rw-r--r--net/spat/files/patch-ae11
-rw-r--r--net/spat/files/patch-af11
-rw-r--r--net/spat/pkg-comment1
-rw-r--r--net/spat/pkg-descr19
-rw-r--r--net/spat/pkg-plist15
12 files changed, 0 insertions, 181 deletions
diff --git a/net/Makefile b/net/Makefile
index 11e2a6a4637b..512efab157bf 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -505,7 +505,6 @@
SUBDIR += sntop
SUBDIR += socat
SUBDIR += socks5
- SUBDIR += spat
SUBDIR += spread
SUBDIR += ssldump
SUBDIR += staticcharge
diff --git a/net/spat/Makefile b/net/spat/Makefile
deleted file mode 100644
index ea8d98c3c082..000000000000
--- a/net/spat/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# New ports collection makefile for: spat
-# Date created: 31 October 2000
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= spat
-PORTVERSION= 1.0
-CATEGORIES= net gnome
-MASTER_SITES= http://spat.codehost.com/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1$/-1/}.src
-
-MAINTAINER= sobomax@FreeBSD.org
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.1$//}
-
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-USE_GNOME= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-lcompat -L${LOCALBASE}/lib"
-
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
-
-post-install:
- ${MKDIR} ${PREFIX}/share/gnome/apps/Applications \
- ${PREFIX}/etc/CORBA/servers
-.for file in spat.desktop spatd.desktop
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/gnome/apps/Applications
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/spatd.gnorba ${PREFIX}/etc/CORBA/servers
- ${LN} -sf ${PREFIX}/share/gnome/pixmaps/spat/spat.png \
- ${PREFIX}/share/gnome/pixmaps/spat.png
-
-.include <bsd.port.mk>
diff --git a/net/spat/distinfo b/net/spat/distinfo
deleted file mode 100644
index ff155e03027f..000000000000
--- a/net/spat/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (spat-1.0.src.tar.gz) = 25b81ab1d7430ea93fef91a9151d0069
diff --git a/net/spat/files/patch-aa b/net/spat/files/patch-aa
deleted file mode 100644
index 782020f4960b..000000000000
--- a/net/spat/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- spatd/main.c 2000/10/31 11:17:27 1.1
-+++ spatd/main.c 2000/10/31 11:33:07
-@@ -48,8 +48,16 @@
- void
- launch_spat()
- {
-- system("/usr/local/bin/spat &");
-+ system(PREFIX "/bin/spat &");
-+}
-+
-+#ifdef __FreeBSD__
-+char *gcvt(double value, int ndigit, char *buf)
-+{
-+ sprintf(buf, "%.*g", ndigit, value);
-+ return buf;
- }
-+#endif
-
- void
- show_back()
diff --git a/net/spat/files/patch-ab b/net/spat/files/patch-ab
deleted file mode 100644
index 3cc763c2ddc9..000000000000
--- a/net/spat/files/patch-ab
+++ /dev/null
@@ -1,29 +0,0 @@
---- spatd/prefs.c.orig Wed Jan 3 20:42:27 2001
-+++ spatd/prefs.c Thu Jan 4 13:45:30 2001
-@@ -16,7 +16,7 @@
- {
- struct ifreq ifi;
- int sock, iftype = 0;
-- char *bcast_addy, *interface = "eth0";
-+ char *bcast_addy, *interface = "ed0";
-
- sock = socket(AF_INET, SOCK_DGRAM, 0);
- if (sock < 0)
-@@ -86,7 +86,7 @@
- printf("Failure to create config. ARG!\n"); /* If this happens then somthing serious went down */
- exit(0);
- }
-- fprintf(fp, "interface: eth0\n");
-+ fprintf(fp, "interface: ed0\n");
- fprintf(fp, "away: no\n");
- fclose(fp);
- printf("Wrote ~/.spat/spatrc\n");
-@@ -173,7 +173,7 @@
- printf("Failure to create config. ARG!\n");
- exit(0);
- }
-- fprintf(fp, "interface: eth0\n");
-+ fprintf(fp, "interface: ed0\n");
- fprintf(fp, "away: no\n");
- fclose(fp);
- printf("Wrote ~/.spat/spatrc\n");
diff --git a/net/spat/files/patch-ac b/net/spat/files/patch-ac
deleted file mode 100644
index 0fba19c83f8b..000000000000
--- a/net/spat/files/patch-ac
+++ /dev/null
@@ -1,20 +0,0 @@
---- spat/callbacks.c 2000/10/31 11:30:56 1.1
-+++ spat/callbacks.c 2000/10/31 11:31:13
-@@ -52,7 +52,7 @@
- printf("Failure to create config. ARG!\n");
- exit(0);
- }
-- fprintf(fp, "spatrc -> interface: eth0\n");
-+ fprintf(fp, "spatrc -> interface: ed0\n");
- fclose(fp);
- printf("Wrote ~/.spat/spatrc\n");
- fp = fopen(dir, "r");
-@@ -104,7 +104,7 @@
- {
- struct ifreq ifi;
- int sock, iftype = 0;
-- char *bcast_addy, *interface = "eth0";
-+ char *bcast_addy, *interface = "ed0";
-
- sock = socket(AF_INET, SOCK_DGRAM, 0);
- if (sock < 0)
diff --git a/net/spat/files/patch-ad b/net/spat/files/patch-ad
deleted file mode 100644
index 35adabd35aa5..000000000000
--- a/net/spat/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- spatd/Makefile.in 2000/10/31 11:38:24 1.1
-+++ spatd/Makefile.in 2000/10/31 11:39:48
-@@ -124,7 +124,7 @@
-
-
- DEFS = @DEFS@ -I. -I$(srcdir) -I..
--CPPFLAGS = @CPPFLAGS@
-+CPPFLAGS = @CPPFLAGS@ -DPREFIX=\"@prefix@\"
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
- spatd_OBJECTS = main.o support.o interface.o callbacks.o prefs.o
diff --git a/net/spat/files/patch-ae b/net/spat/files/patch-ae
deleted file mode 100644
index 15d231fac55c..000000000000
--- a/net/spat/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- spatd/callbacks.c.orig Wed Jan 3 20:42:27 2001
-+++ spatd/callbacks.c Thu Jan 4 13:48:04 2001
-@@ -110,7 +110,7 @@
- {
- //exit(0);
- }
-- strcpy(command, "/usr/local/bin/spat ");
-+ strcpy(command, PREFIX "/bin/spat ");
- strcat(command, remote_login);
-
- strcat(command, " &");
diff --git a/net/spat/files/patch-af b/net/spat/files/patch-af
deleted file mode 100644
index 5ee9ce94425a..000000000000
--- a/net/spat/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in 2000/10/31 12:18:31 1.1
-+++ Makefile.in 2000/10/31 12:21:40
-@@ -95,7 +95,7 @@
- ORBIT_LIBS = @ORBIT_LIBS@
- PACKAGE = @PACKAGE@
- PACKAGE_PIXMAPS_DIR = @PACKAGE_PIXMAPS_DIR@
--PACKAGE_DOC_DIR = /usr/doc/spat-@VERSION@
-+PACKAGE_DOC_DIR = @prefix@/share/doc/spat
- POFILES = @POFILES@
- POSUB = @POSUB@
- PTHREAD_LIB = @PTHREAD_LIB@
diff --git a/net/spat/pkg-comment b/net/spat/pkg-comment
deleted file mode 100644
index 5792afd95b41..000000000000
--- a/net/spat/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A lightweight Intranet Messaging Application for GNOME desktop
diff --git a/net/spat/pkg-descr b/net/spat/pkg-descr
deleted file mode 100644
index 8bc5a7bb50a4..000000000000
--- a/net/spat/pkg-descr
+++ /dev/null
@@ -1,19 +0,0 @@
-Spat. The Gnome messaging system
---------------------------------
-
-Spat is a lightweight, GNOME compliant Intranet Messaging Application designed
-and distributed by Codehost.com, Inc. This Intranet Messaging System was
-developed to easily install and run on a TCP/IP network.
-
-Until now, an easy to configure - easy to use, Messaging system has not existed
-for Unix since write(1).
-
-Easy to use - Easy to configure
--------------------------------
-
-Spat was designed with the User in mind. Geared for the user friendly GNOME
-Desktop, this messaging system needs little or no configuration whatsoever. Use
-is simple too. Just run the application and select the user you want to send a
-message to. With Spat there is no need to remember IP Addresses.
-
-WWW: http://spat.codehost.com/
diff --git a/net/spat/pkg-plist b/net/spat/pkg-plist
deleted file mode 100644
index 056c50cc7401..000000000000
--- a/net/spat/pkg-plist
+++ /dev/null
@@ -1,15 +0,0 @@
-bin/spat
-bin/spatd
-etc/CORBA/servers/spatd.gnorba
-share/doc/spat/FAQ
-share/doc/spat/INSTALL
-share/gnome/apps/Applications/spat.desktop
-share/gnome/apps/Applications/spatd.desktop
-share/gnome/pixmaps/spat.png
-share/gnome/pixmaps/spat/about.jpg
-share/gnome/pixmaps/spat/away_with_msg.png
-share/gnome/pixmaps/spat/gnome-intranet.png
-share/gnome/pixmaps/spat/ok.png
-share/gnome/pixmaps/spat/spat.png
-@dirrm share/gnome/pixmaps/spat
-@dirrm share/doc/spat