aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2016-09-29 19:53:06 +0000
committerDavid Naylor <dbn@FreeBSD.org>2016-09-29 19:53:06 +0000
commitdedf766eb6b3c0943a43f4f0064d38ece3171f77 (patch)
tree22c6d2a4422a63f8364a13e5ca4091b779377279
parent4b2f78764123c7cf352577ef9792d211bd37b3e6 (diff)
downloadports-dedf766eb6b3c0943a43f4f0064d38ece3171f77.tar.gz
ports-dedf766eb6b3c0943a43f4f0064d38ece3171f77.zip
MFH: r422903
x11/kde4-workspace: fix OpenGL test for nvidia-driver. Restore patch introduced in r408463 and accidentially removed in r417328. Approved by: ports-secteam (feld)
Notes
Notes: svn path=/branches/2016Q3/; revision=422943
-rw-r--r--x11/kde4-workspace/Makefile1
-rw-r--r--x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt15
2 files changed, 16 insertions, 0 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 084d7145dcd0..704399afd25b 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kde-workspace
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${KDE4_APPLICATIONS_VERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt b/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt
new file mode 100644
index 000000000000..be76904999e2
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- kwin/opengltest/CMakeLists.txt.orig 2014-11-06 22:36:58 UTC
++++ kwin/opengltest/CMakeLists.txt
+@@ -2,9 +2,11 @@
+
+ set(kwin_opengl_test_SRCS opengltest.cpp )
+
++find_package(Threads)
++
+ kde4_add_executable(kwin_opengl_test ${kwin_opengl_test_SRCS})
+
+-target_link_libraries(kwin_opengl_test ${X11_LIBRARIES} ${OPENGL_gl_LIBRARY})
++target_link_libraries(kwin_opengl_test ${X11_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_THREAD_LIBS_INIT})
+
+ install(TARGETS kwin_opengl_test DESTINATION ${LIBEXEC_INSTALL_DIR} )
+