aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2011-11-29 12:47:07 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2011-11-29 12:47:07 +0000
commite9886a9452aaec7663f42633f7934b2c0f852def (patch)
tree72c257c84ddb732adbd2e8cb71440af69e69b7ae
parent9099c0a0ba0344fe1e44043b9a27634c955d2994 (diff)
Notes
-rw-r--r--security/snortsam/Makefile1
-rw-r--r--security/snortsam/files/patch-ssp_ipfw2.c13
2 files changed, 14 insertions, 0 deletions
diff --git a/security/snortsam/Makefile b/security/snortsam/Makefile
index abb3abde5aee..a7fb01a45ad1 100644
--- a/security/snortsam/Makefile
+++ b/security/snortsam/Makefile
@@ -7,6 +7,7 @@
PORTNAME= snortsam
PORTVERSION= 2.70
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.snortsam.net/files/snortsam/
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
diff --git a/security/snortsam/files/patch-ssp_ipfw2.c b/security/snortsam/files/patch-ssp_ipfw2.c
new file mode 100644
index 000000000000..1a60d792ac38
--- /dev/null
+++ b/security/snortsam/files/patch-ssp_ipfw2.c
@@ -0,0 +1,13 @@
+--- src/ssp_ipfw2.c 2008-04-26 15:53:21.000000000 -0400
++++ src/ssp_ipfw2.c 2011-10-07 15:47:50.000000000 -0400
+@@ -167,8 +167,8 @@
+ printf("Debug: [ipfw2][%lx] command \"%s\"\n", (unsigned long)threadid, ipfw2cmd);
+ #endif
+ /* Run the command */
+- if (system(ipfw2cmd) )
++ if ((system(ipfw2cmd) && 0xff) )
+ { snprintf(msg,sizeof(msg)-1,"Error: Command \"%s\" Failed", ipfw2cmd);
+ logmessage(1,msg,"ipfw2",0);
+ }
+ else
+