aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2016-09-18 10:39:38 +0000
committerBernard Spil <brnrd@FreeBSD.org>2016-09-18 10:39:38 +0000
commitedae294ff5765468e4d4a82110248ae39f92cbaa (patch)
treee4ec86cb4557e9e71fd9b9843b3a510ec28d3011
parent02883f8dceac589508efd58c1f472ca501c264fa (diff)
downloadports-edae294ff5765468e4d4a82110248ae39f92cbaa.tar.gz
ports-edae294ff5765468e4d4a82110248ae39f92cbaa.zip
MFH: r418977
databases/mariadb101-server: Fix lz4 linking fix - Remove some testing leftover - Fix patch error Approved by: ports-secteam
Notes
Notes: svn path=/branches/2016Q3/; revision=422368
-rw-r--r--databases/mariadb101-server/Makefile14
-rw-r--r--databases/mariadb101-server/files/patch-storage_oqgraph_oqgraph__shim.h9
2 files changed, 10 insertions, 13 deletions
diff --git a/databases/mariadb101-server/Makefile b/databases/mariadb101-server/Makefile
index 4ec8ac82defa..6054b4694584 100644
--- a/databases/mariadb101-server/Makefile
+++ b/databases/mariadb101-server/Makefile
@@ -27,7 +27,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
SLAVEDIRS= databases/mariadb101-client
-USES= bison:build cmake compiler:c++11-lib cpe execinfo shebangfix
+USES= bison:build cmake compiler:c++11-lib cpe execinfo ssl shebangfix
USE_LDCONFIG= ${PREFIX}/lib/mysql
SHEBANG_FILES= scripts/*.sh
SITESDIR= mariadb/mariadb-${PORTVERSION}/source
@@ -95,7 +95,6 @@ CONFLICTS_INSTALL= mariadb5*-${PKGNAMESUFFIX:C/^[0-9]*-//}-* \
mysql[0-9]*-${PKGNAMESUFFIX:C/^[0-9]*-//}-* \
percona[0-9]*-${PKGNAMESUFFIX:C/^[0-9]*-//}-*
-USE_OPENSSL= yes
FASTMTX_CMAKE_ON= -DWITH_FAST_MUTEXES=1
OPTIONS_SUB= yes
@@ -105,8 +104,8 @@ USES+= readline
GSSAPI_NONE_CMAKE_ON= -DPLUGIN_AUTH_GSSAPI_CLIENT=NO
.else
# MySQL-Server part
-USE_MYSQL= yes
-WANT_MYSQL_VER= 101m
+USES+= mysql:101m
+USE_GNOME= libxml2
USE_LDCONFIG+= ${PREFIX}/lib/mysql/plugin
USE_RC_SUBR= mysql-server
USERS= mysql
@@ -123,6 +122,7 @@ ${ENGINE}_CMAKE_OFF= -DPLUGIN_${ENGINE}=NO \
GSSAPI_NONE_CMAKE_ON= -DPLUGIN_AUTH_GSSAPI=NO
MAXKEY_EXTRA_PATCHES+= ${FILESDIR}/extra-patch-include_my__compare.h
+MROONGA_LIB_DEPENDS= liblz4.so:archivers/liblz4
OQGRAPH_LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libJudy.so:devel/judy
TOKUDB_LIB_DEPENDS= libsnappy.so:archivers/snappy
@@ -172,4 +172,10 @@ post-patch:
${WRKSRC}/cmake/os/DragonFly.cmake
.endif
+.if exists(${WRKSRC}/storage/mroonga/CMakeFiles/mroonga.dir/link.txt)
+post-configure:
+ @${REINPLACE_CMD} "s|/usr/bin/c++ |/usr/bin/c++ -L${LOCALBASE}/lib |" \
+ ${WRKSRC}/storage/mroonga/CMakeFiles/mroonga.dir/link.txt
+.endif
+
.include <bsd.port.post.mk>
diff --git a/databases/mariadb101-server/files/patch-storage_oqgraph_oqgraph__shim.h b/databases/mariadb101-server/files/patch-storage_oqgraph_oqgraph__shim.h
index 6ee9e0672bb0..9966cc97a62c 100644
--- a/databases/mariadb101-server/files/patch-storage_oqgraph_oqgraph__shim.h
+++ b/databases/mariadb101-server/files/patch-storage_oqgraph_oqgraph__shim.h
@@ -3,15 +3,6 @@ https://jira.mariadb.org/projects/MDEV/issues/MDEV-8051
--- storage/oqgraph/oqgraph_shim.h.orig 2016-01-28 12:12:55 UTC
+++ storage/oqgraph/oqgraph_shim.h
-@@ -254,7 +254,7 @@ namespace boost
- typedef no_property type;
- };
-
--#if BOOST_VERSION >= 104601
-+#if BOOST_VERSION >= 104601 && BOOST_VERSION < 104900
- template <>
- struct graph_bundle_type<oqgraph3::graph>
- {
@@ -274,6 +274,33 @@ namespace boost
};
#endif