aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2004-02-03 12:43:37 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2004-02-03 12:43:37 +0000
commitf2a21cccf8180056412927ac59b8fa646b0f7dde (patch)
tree859265f16a08a4b0d01f18d99ca927aa83cf4845
parenteb6a3b4b6bcc3e7067900e538a381057d6fb8148 (diff)
Do not grep directories when recursing.
Notes
Notes: svn path=/head/; revision=99879
-rw-r--r--textproc/freegrep/Makefile1
-rw-r--r--textproc/freegrep/files/patch-ab15
2 files changed, 16 insertions, 0 deletions
diff --git a/textproc/freegrep/Makefile b/textproc/freegrep/Makefile
index cfe05d98c4e0..470a6006bcec 100644
--- a/textproc/freegrep/Makefile
+++ b/textproc/freegrep/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freegrep
PORTVERSION= 0.16
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www.vocito.com/downloads/software/grep/ \
ftp://ftp.vocito.com/pub/vocito.com/software/grep/
diff --git a/textproc/freegrep/files/patch-ab b/textproc/freegrep/files/patch-ab
new file mode 100644
index 000000000000..73a0b3a93d0d
--- /dev/null
+++ b/textproc/freegrep/files/patch-ab
@@ -0,0 +1,15 @@
+--- util.c.orig Tue Feb 3 13:36:42 2004
++++ util.c Tue Feb 3 13:39:49 2004
+@@ -72,10 +72,11 @@
+ while ((p = fts_read(fts)) != NULL) {
+ switch (p->fts_info) {
+ case FTS_DNR:
+- break;
++ /* FALL THROUGH */
+ case FTS_ERR:
+ errx(1, "%s: %s", p->fts_path, strerror(p->fts_errno));
+ break;
++ case FTS_D:
+ case FTS_DP:
+ break;
+ default: