aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2016-12-23 01:35:39 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2016-12-23 01:35:39 +0000
commit525a092e0e8ac68d3b17960bd6af4839f142de61 (patch)
treeb706c844642d8577a1c1ff13c426f0524b9b4e74
parenta8181ed3ed8da4768446f4d6d5576c897469b351 (diff)
downloadports-525a092e0e8ac68d3b17960bd6af4839f142de61.tar.gz
ports-525a092e0e8ac68d3b17960bd6af4839f142de61.zip
MFH: r423366 r424094 r425833 r428479
editors/neovim: update 0.1.4 -> 0.1.7 PR: 214897 Submitted by: Oleg Gushchenkov <gor@clogic.com.ua> (maintainer) Reported by: ohauer (as a security issue) Security: CVE-2016-1248 Security: https://vuxml.FreeBSD.org/freebsd/c11629d3-c8ad-11e6-ae1b-002590263bf5.html Approved by: ports-secteam (with hat)
Notes
Notes: svn path=/branches/2016Q4/; revision=429212
-rw-r--r--editors/neovim/Makefile9
-rw-r--r--editors/neovim/distinfo9
-rw-r--r--editors/neovim/files/patch-CMakeLists.txt11
-rw-r--r--editors/neovim/files/patch-config__CMakeLists.txt26
-rw-r--r--editors/neovim/files/patch-config__config.h.in9
-rw-r--r--editors/neovim/files/patch-src__nvim__shada.c11
-rw-r--r--editors/neovim/files/patch-src_nvim_os_pty__process__unix.c (renamed from editors/neovim/files/patch-src_nvim_event_pty__process.c)8
-rw-r--r--editors/neovim/pkg-plist40
8 files changed, 43 insertions, 80 deletions
diff --git a/editors/neovim/Makefile b/editors/neovim/Makefile
index 80139eb3c7ed..9507add04026 100644
--- a/editors/neovim/Makefile
+++ b/editors/neovim/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= neovim
-PORTVERSION= 0.1.4
+PORTVERSION= 0.1.7
DISTVERSIONPREFIX= v
-PORTREVISION= 2
CATEGORIES= editors
MAINTAINER= gor@clogic.com.ua
@@ -13,7 +12,8 @@ COMMENT= Next generation Vim
LICENSE= APACHE20
BUILD_DEPENDS= ${LUA_MODLIBDIR}/bit.so:devel/lua-bitop \
- ${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg
+ ${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg \
+ gperf:devel/gperf
LIB_DEPENDS= libunibilium.so:devel/unibilium \
libvterm.so:devel/libvterm \
libtermkey.so:devel/libtermkey \
@@ -23,7 +23,7 @@ LIB_DEPENDS= libunibilium.so:devel/unibilium \
USES= cmake:outsource gettext iconv ninja lua:build pathfix pkgconfig
USE_GITHUB= yes
-GH_TUPLE= tarruda:libmpack:1.0.2:libmpack
+GH_TUPLE= tarruda:libmpack:1.0.3:libmpack
CMAKE_ARGS= -DLUA_PRG:FILEPATH="${LUA_CMD}" \
-DCMAKE_INSTALL_MANDIR:PATH="${MANPREFIX}/man" \
@@ -42,5 +42,6 @@ pre-build:
-I${LUA_INCDIR} -shared lmpack.c -o \
${BUILD_WRKSRC}/src/nvim/mpack.so \
${LUA_LIBDIR}/liblua-${LUA_VER}.so)
+ @${LN} -s ${BUILD_WRKSRC}/src/nvim/mpack.so ${BUILD_WRKSRC}/runtime/mpack.so
.include <bsd.port.mk>
diff --git a/editors/neovim/distinfo b/editors/neovim/distinfo
index 6e401f015bd8..2b5575aa5e0c 100644
--- a/editors/neovim/distinfo
+++ b/editors/neovim/distinfo
@@ -1,4 +1,5 @@
-SHA256 (neovim-neovim-v0.1.4_GH0.tar.gz) = bb7e359eb83db20c5ec5984b470b249372b6dcd813ae2ccf72c01cce560f93e9
-SIZE (neovim-neovim-v0.1.4_GH0.tar.gz) = 7678847
-SHA256 (tarruda-libmpack-1.0.2_GH0.tar.gz) = 9c570b2aab81b0c56d97cbd8fc483dc431b69510fd9becb4a1845291563e8bc9
-SIZE (tarruda-libmpack-1.0.2_GH0.tar.gz) = 44671
+TIMESTAMP = 1480313427
+SHA256 (neovim-neovim-v0.1.7_GH0.tar.gz) = d8f885d019b1ad608f36ae23b8f1b15b7e33585e16f7514666ab6c9809bb4b7e
+SIZE (neovim-neovim-v0.1.7_GH0.tar.gz) = 7601279
+SHA256 (tarruda-libmpack-1.0.3_GH0.tar.gz) = 65eb21cfa9313204ac5296e3b305d752b8422c724b6375caecc6385f0a6d6e22
+SIZE (tarruda-libmpack-1.0.3_GH0.tar.gz) = 45720
diff --git a/editors/neovim/files/patch-CMakeLists.txt b/editors/neovim/files/patch-CMakeLists.txt
index 1856019417f2..1335b47b7586 100644
--- a/editors/neovim/files/patch-CMakeLists.txt
+++ b/editors/neovim/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2016-05-09 13:04:04 UTC
+--- CMakeLists.txt.orig 2016-11-08 05:44:53 UTC
+++ CMakeLists.txt
-@@ -213,7 +213,7 @@ else()
+@@ -221,7 +221,7 @@ else()
# On FreeBSD 64 math.h uses unguarded C11 extension, which taints clang
# 3.4.1 used there.
@@ -9,12 +9,15 @@
add_definitions(-Wno-c11-extensions)
endif()
endif()
-@@ -367,7 +367,7 @@ endforeach()
+@@ -386,9 +386,9 @@ endforeach()
# Find Lua interpreter
include(LuaHelpers)
-set(LUA_DEPENDENCIES lpeg mpack bit)
+set(LUA_DEPENDENCIES lpeg bit)
if(NOT LUA_PRG)
- foreach(CURRENT_LUA_PRG luajit lua)
+- foreach(CURRENT_LUA_PRG luajit lua5.1 lua5.2 lua)
++ foreach(CURRENT_LUA_PRG luajit)
# If LUA_PRG is set find_program() will not search
+ unset(LUA_PRG CACHE)
+ unset(LUA_PRG_WORKS)
diff --git a/editors/neovim/files/patch-config__CMakeLists.txt b/editors/neovim/files/patch-config__CMakeLists.txt
deleted file mode 100644
index 833dad3a0cfb..000000000000
--- a/editors/neovim/files/patch-config__CMakeLists.txt
+++ /dev/null
@@ -1,26 +0,0 @@
---- config/CMakeLists.txt.orig 2016-06-05 14:13:28 UTC
-+++ config/CMakeLists.txt
-@@ -67,6 +67,14 @@ if(HAVE_LANGINFO_H)
- check_symbol_exists(CODESET "langinfo.h" HAVE_NL_LANGINFO_CODESET)
- endif()
-
-+check_include_files("endian.h" HAVE_ENDIAN_H)
-+check_include_files("sys/endian.h" HAVE_SYS_ENDIAN_H)
-+
-+set(ENDIAN_INCLUDE_FILE "endian.h")
-+if(HAVE_SYS_ENDIAN_H AND NOT HAVE_ENDIAN_H)
-+ set(ENDIAN_INCLUDE_FILE "sys/endian.h")
-+endif()
-+
- set(SI "#include <stdint.h>\n")
- set(MS "int main(int argc,char**argv)\n{\n uint64_t i=0x0102030405060708ULL;")
- set(ME "}")
-@@ -74,7 +82,7 @@ check_c_source_compiles("
- #define _BSD_SOURCE 1
- #define _DEFAULT_SOURCE 1
- ${SI}
-- #include <endian.h>
-+ #include <${ENDIAN_INCLUDE_FILE}>
- #ifndef be64toh
- # error No be64toh macros
- #endif
diff --git a/editors/neovim/files/patch-config__config.h.in b/editors/neovim/files/patch-config__config.h.in
deleted file mode 100644
index 72fb3e957c9f..000000000000
--- a/editors/neovim/files/patch-config__config.h.in
+++ /dev/null
@@ -1,9 +0,0 @@
---- config/config.h.in.orig 2016-06-05 14:13:28 UTC
-+++ config/config.h.in
-@@ -57,5 +57,6 @@
-
- #cmakedefine HAVE_BE64TOH
- #cmakedefine ORDER_BIG_ENDIAN
-+#define ENDIAN_INCLUDE_FILE <@ENDIAN_INCLUDE_FILE@>
-
- #endif // AUTO_CONFIG_H
diff --git a/editors/neovim/files/patch-src__nvim__shada.c b/editors/neovim/files/patch-src__nvim__shada.c
deleted file mode 100644
index c665c7c5695d..000000000000
--- a/editors/neovim/files/patch-src__nvim__shada.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/nvim/shada.c.orig 2016-06-05 14:13:28 UTC
-+++ src/nvim/shada.c
-@@ -46,7 +46,7 @@
- #ifdef HAVE_BE64TOH
- # define _BSD_SOURCE 1
- # define _DEFAULT_SOURCE 1
--# include <endian.h>
-+# include ENDIAN_INCLUDE_FILE
- #endif
-
- // Note: when using bufset hash pointers are intentionally casted to uintptr_t
diff --git a/editors/neovim/files/patch-src_nvim_event_pty__process.c b/editors/neovim/files/patch-src_nvim_os_pty__process__unix.c
index 651aa713ae3b..993dc4fc0a31 100644
--- a/editors/neovim/files/patch-src_nvim_event_pty__process.c
+++ b/editors/neovim/files/patch-src_nvim_os_pty__process__unix.c
@@ -1,11 +1,11 @@
---- src/nvim/event/pty_process.c.orig 2016-04-25 01:46:34 UTC
-+++ src/nvim/event/pty_process.c
-@@ -10,7 +10,7 @@
+--- src/nvim/os/pty_process_unix.c.orig 2016-11-08 05:50:09 UTC
++++ src/nvim/os/pty_process_unix.c
+@@ -9,7 +9,7 @@
#include <sys/ioctl.h>
// forkpty is not in POSIX, so headers are platform-specific
-#if defined(__FreeBSD__)
-+#if defined(__FreeBSD__) || defined __DragonFly__
++#if defined(__FreeBSD__) || defined (__DragonFly__)
# include <libutil.h>
#elif defined(__OpenBSD__) || defined(__NetBSD__) || defined(__APPLE__)
# include <util.h>
diff --git a/editors/neovim/pkg-plist b/editors/neovim/pkg-plist
index bdd4d424b504..6ba38d1e689d 100644
--- a/editors/neovim/pkg-plist
+++ b/editors/neovim/pkg-plist
@@ -13,30 +13,21 @@ share/locale/fr/LC_MESSAGES/nvim.mo
share/locale/ga/LC_MESSAGES/nvim.mo
share/locale/it/LC_MESSAGES/nvim.mo
share/locale/ja.euc-jp/LC_MESSAGES/nvim.mo
-share/locale/ja.sjis/LC_MESSAGES/nvim.mo
share/locale/ja/LC_MESSAGES/nvim.mo
share/locale/ko.UTF-8/LC_MESSAGES/nvim.mo
-share/locale/ko/LC_MESSAGES/nvim.mo
share/locale/nb/LC_MESSAGES/nvim.mo
share/locale/nl/LC_MESSAGES/nvim.mo
share/locale/no/LC_MESSAGES/nvim.mo
share/locale/pl.UTF-8/LC_MESSAGES/nvim.mo
-share/locale/pl.cp1250/LC_MESSAGES/nvim.mo
-share/locale/pl/LC_MESSAGES/nvim.mo
share/locale/pt_BR/LC_MESSAGES/nvim.mo
-share/locale/ru.cp1251/LC_MESSAGES/nvim.mo
share/locale/ru/LC_MESSAGES/nvim.mo
share/locale/sk.cp1250/LC_MESSAGES/nvim.mo
share/locale/sk/LC_MESSAGES/nvim.mo
share/locale/sv/LC_MESSAGES/nvim.mo
-share/locale/uk.cp1251/LC_MESSAGES/nvim.mo
share/locale/uk/LC_MESSAGES/nvim.mo
share/locale/vi/LC_MESSAGES/nvim.mo
share/locale/zh_CN.UTF-8/LC_MESSAGES/nvim.mo
-share/locale/zh_CN.cp936/LC_MESSAGES/nvim.mo
-share/locale/zh_CN/LC_MESSAGES/nvim.mo
share/locale/zh_TW.UTF-8/LC_MESSAGES/nvim.mo
-share/locale/zh_TW/LC_MESSAGES/nvim.mo
share/nvim/runtime/autoload/ada.vim
share/nvim/runtime/autoload/adacomplete.vim
share/nvim/runtime/autoload/ccomplete.vim
@@ -45,6 +36,9 @@ share/nvim/runtime/autoload/csscomplete.vim
share/nvim/runtime/autoload/decada.vim
share/nvim/runtime/autoload/gnat.vim
share/nvim/runtime/autoload/gzip.vim
+share/nvim/runtime/autoload/health.vim
+share/nvim/runtime/autoload/health/nvim.vim
+share/nvim/runtime/autoload/health/provider.vim
share/nvim/runtime/autoload/htmlcomplete.vim
share/nvim/runtime/autoload/javascriptcomplete.vim
share/nvim/runtime/autoload/man.vim
@@ -60,6 +54,7 @@ share/nvim/runtime/autoload/provider/python.vim
share/nvim/runtime/autoload/provider/python3.vim
share/nvim/runtime/autoload/provider/pythonx.vim
share/nvim/runtime/autoload/provider/ruby.vim
+share/nvim/runtime/autoload/provider/script_host.rb
share/nvim/runtime/autoload/python3complete.vim
share/nvim/runtime/autoload/pythoncomplete.vim
share/nvim/runtime/autoload/remote/define.vim
@@ -72,7 +67,6 @@ share/nvim/runtime/autoload/syntaxcomplete.vim
share/nvim/runtime/autoload/tar.vim
share/nvim/runtime/autoload/tohtml.vim
share/nvim/runtime/autoload/tutor.vim
-share/nvim/runtime/autoload/vimball.vim
share/nvim/runtime/autoload/vimexpect.vim
share/nvim/runtime/autoload/xml/html32.vim
share/nvim/runtime/autoload/xml/html401f.vim
@@ -173,6 +167,7 @@ share/nvim/runtime/doc/autocmd.txt
share/nvim/runtime/doc/change.txt
share/nvim/runtime/doc/cmdline.txt
share/nvim/runtime/doc/debug.txt
+share/nvim/runtime/doc/deprecated.txt
share/nvim/runtime/doc/develop.txt
share/nvim/runtime/doc/diff.txt
share/nvim/runtime/doc/digraph.txt
@@ -184,13 +179,13 @@ share/nvim/runtime/doc/fold.txt
share/nvim/runtime/doc/ft_ada.txt
share/nvim/runtime/doc/ft_sql.txt
share/nvim/runtime/doc/gui.txt
-share/nvim/runtime/doc/gui_w32.txt
share/nvim/runtime/doc/hebrew.txt
share/nvim/runtime/doc/help.txt
share/nvim/runtime/doc/helphelp.txt
share/nvim/runtime/doc/howto.txt
share/nvim/runtime/doc/if_cscop.txt
share/nvim/runtime/doc/if_pyth.txt
+share/nvim/runtime/doc/if_ruby.txt
share/nvim/runtime/doc/indent.txt
share/nvim/runtime/doc/index.txt
share/nvim/runtime/doc/insert.txt
@@ -205,15 +200,12 @@ share/nvim/runtime/doc/mlang.txt
share/nvim/runtime/doc/motion.txt
share/nvim/runtime/doc/msgpack_rpc.txt
share/nvim/runtime/doc/nvim.txt
-share/nvim/runtime/doc/nvim_clipboard.txt
-share/nvim/runtime/doc/nvim_from_vim.txt
-share/nvim/runtime/doc/nvim_provider.txt
-share/nvim/runtime/doc/nvim_python.txt
share/nvim/runtime/doc/nvim_terminal_emulator.txt
share/nvim/runtime/doc/options.txt
share/nvim/runtime/doc/os_win32.txt
share/nvim/runtime/doc/pattern.txt
share/nvim/runtime/doc/pi_gzip.txt
+share/nvim/runtime/doc/pi_health.txt
share/nvim/runtime/doc/pi_matchit.txt
share/nvim/runtime/doc/pi_msgpack.txt
share/nvim/runtime/doc/pi_netrw.txt
@@ -221,12 +213,11 @@ share/nvim/runtime/doc/pi_paren.txt
share/nvim/runtime/doc/pi_spec.txt
share/nvim/runtime/doc/pi_tar.txt
share/nvim/runtime/doc/pi_tutor.txt
-share/nvim/runtime/doc/pi_vimball.txt
share/nvim/runtime/doc/pi_zip.txt
share/nvim/runtime/doc/print.txt
+share/nvim/runtime/doc/provider.txt
share/nvim/runtime/doc/quickfix.txt
share/nvim/runtime/doc/quickref.txt
-share/nvim/runtime/doc/quotes.txt
share/nvim/runtime/doc/recover.txt
share/nvim/runtime/doc/remote.txt
share/nvim/runtime/doc/remote_plugin.txt
@@ -332,6 +323,7 @@ share/nvim/runtime/ftplugin/dosbatch.vim
share/nvim/runtime/ftplugin/dosini.vim
share/nvim/runtime/ftplugin/dtd.vim
share/nvim/runtime/ftplugin/dtrace.vim
+share/nvim/runtime/ftplugin/eiffel.vim
share/nvim/runtime/ftplugin/elinks.vim
share/nvim/runtime/ftplugin/erlang.vim
share/nvim/runtime/ftplugin/eruby.vim
@@ -350,12 +342,15 @@ share/nvim/runtime/ftplugin/gitsendemail.vim
share/nvim/runtime/ftplugin/go.vim
share/nvim/runtime/ftplugin/gpg.vim
share/nvim/runtime/ftplugin/gprof.vim
+share/nvim/runtime/ftplugin/groovy.vim
share/nvim/runtime/ftplugin/group.vim
share/nvim/runtime/ftplugin/grub.vim
share/nvim/runtime/ftplugin/haml.vim
share/nvim/runtime/ftplugin/hamster.vim
share/nvim/runtime/ftplugin/haskell.vim
share/nvim/runtime/ftplugin/help.vim
+share/nvim/runtime/ftplugin/hgcommit.vim
+share/nvim/runtime/ftplugin/hog.vim
share/nvim/runtime/ftplugin/hostconf.vim
share/nvim/runtime/ftplugin/hostsaccess.vim
share/nvim/runtime/ftplugin/html.vim
@@ -531,6 +526,7 @@ share/nvim/runtime/indent/gitolite.vim
share/nvim/runtime/indent/go.vim
share/nvim/runtime/indent/haml.vim
share/nvim/runtime/indent/hamster.vim
+share/nvim/runtime/indent/hog.vim
share/nvim/runtime/indent/html.vim
share/nvim/runtime/indent/htmldjango.vim
share/nvim/runtime/indent/idlang.vim
@@ -684,7 +680,15 @@ share/nvim/runtime/makemenu.vim
share/nvim/runtime/menu.vim
share/nvim/runtime/mswin.vim
share/nvim/runtime/optwin.vim
+share/nvim/runtime/pack/dist/opt/justify/plugin/justify.vim
+share/nvim/runtime/pack/dist/opt/shellmenu/plugin/shellmenu.vim
+share/nvim/runtime/pack/dist/opt/swapmouse/plugin/swapmouse.vim
+share/nvim/runtime/pack/dist/opt/vimball/autoload/vimball.vim
+share/nvim/runtime/pack/dist/opt/vimball/doc/tags
+share/nvim/runtime/pack/dist/opt/vimball/doc/vimball.txt
+share/nvim/runtime/pack/dist/opt/vimball/plugin/vimballPlugin.vim
share/nvim/runtime/plugin/gzip.vim
+share/nvim/runtime/plugin/health.vim
share/nvim/runtime/plugin/man.vim
share/nvim/runtime/plugin/matchit.vim
share/nvim/runtime/plugin/matchparen.vim
@@ -696,7 +700,6 @@ share/nvim/runtime/plugin/spellfile.vim
share/nvim/runtime/plugin/tarPlugin.vim
share/nvim/runtime/plugin/tohtml.vim
share/nvim/runtime/plugin/tutor.vim
-share/nvim/runtime/plugin/vimballPlugin.vim
share/nvim/runtime/plugin/zipPlugin.vim
share/nvim/runtime/print/ascii.ps
share/nvim/runtime/print/cidfont.ps
@@ -769,6 +772,7 @@ share/nvim/runtime/syntax/autohotkey.vim
share/nvim/runtime/syntax/autoit.vim
share/nvim/runtime/syntax/automake.vim
share/nvim/runtime/syntax/ave.vim
+share/nvim/runtime/syntax/avra.vim
share/nvim/runtime/syntax/awk.vim
share/nvim/runtime/syntax/ayacc.vim
share/nvim/runtime/syntax/b.vim