aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-12-11 15:35:34 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-12-11 15:35:34 +0000
commit8667c09035223418013a0f1a0ac05af6bc875963 (patch)
tree3bd78365663ce0d6977b2c6ec0e0be43efe859fe
parentabf75c0ae2f0b7774ef061d74cc06dc3f383fe2c (diff)
downloadports-8667c09035223418013a0f1a0ac05af6bc875963.tar.gz
ports-8667c09035223418013a0f1a0ac05af6bc875963.zip
MFH: r424697 r424815 r425883 r427103 r427462 r428328
- Update asterisk13 to 13.13.1 [3] - Include patches submitted upstream to fix a regression [2] - Make user provided makeopts work again [1] PR: 214810 [1] Submitted by: yani@pi-greece.eu Obtained from: https://issues.asterisk.org/jira/browse/ASTERISK-26617 [2] Security: c0b13887-be44-11e6-b04f-001999f8d30b [3] Security: 9e6640fe-be3a-11e6-b04f-001999f8d30b [3] Approved by: ports-secteam (junovitch)
Notes
Notes: svn path=/branches/2016Q4/; revision=428356
-rw-r--r--net/asterisk13/Makefile9
-rw-r--r--net/asterisk13/distinfo6
-rw-r--r--net/asterisk13/files/patch-include_asterisk_utils.h16
-rw-r--r--net/asterisk13/files/patch-main_utils.c21
-rw-r--r--net/asterisk13/files/patch-res_res__pjsip__sdp__rtp.c23
-rw-r--r--net/asterisk13/files/patch-res_res__pjsip__t38.c23
-rw-r--r--net/asterisk13/files/patch-res_res__rtp__asterisk.c15
7 files changed, 89 insertions, 24 deletions
diff --git a/net/asterisk13/Makefile b/net/asterisk13/Makefile
index 08a875cc26b4..9e114a1509ee 100644
--- a/net/asterisk13/Makefile
+++ b/net/asterisk13/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= asterisk
-PORTVERSION= 13.11.2
+PORTVERSION= 13.13.1
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
MASTER_SITE_SUBDIR= asterisk/ \
@@ -250,15 +250,12 @@ post-patch-SYSINFO-on:
post-patch-SYSINFO-off:
@${REINPLACE_CMD} -e '/#define HAVE_SYSINFO 1/d' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/%%LIBSYSINFO%%/d' ${WRKSRC}/main/Makefile
-
.if exists(${FILESDIR}/.asterisk.makeopts)
-USER_MAKEOPTS_FILE=${FILESDIR}/.asterisk.makeopts
-.else
-USER_MAKEOPTS_FILE=
+ ${CP} ${USER_MAKEOPTS_FILE} ${WRKSRC}/menuselect.makeopts
.endif
post-configure:
- @cd ${WRKSRC} && ${MAKE_CMD} menuselect.makeopts USER_MAKEOPTS="${USER_MAKEOPTS_FILE}"
+ @cd ${WRKSRC} && ${MAKE_CMD} menuselect.makeopts
@cd ${WRKSRC} && ./menuselect/menuselect --disable res_timing_kqueue menuselect.makeopts
@cd ${WRKSRC} && ./menuselect/menuselect --enable chan_mgcp menuselect.makeopts
@cd ${WRKSRC} && ./menuselect/menuselect --enable res_pktccops menuselect.makeopts
diff --git a/net/asterisk13/distinfo b/net/asterisk13/distinfo
index c36ebcc06b2e..e7616aa2c15c 100644
--- a/net/asterisk13/distinfo
+++ b/net/asterisk13/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1473494815
-SHA256 (asterisk-13.11.2.tar.gz) = 6ea7001bb11ba11fcdbb5febb028b2fd62c44c7bda3cc966b8aaafcb429c5a3a
-SIZE (asterisk-13.11.2.tar.gz) = 32630702
+TIMESTAMP = 1481311854
+SHA256 (asterisk-13.13.1.tar.gz) = 6da3c46a22e919b92edf2ccb5b3a2f51bc17e8819e6fca704026869bf349007a
+SIZE (asterisk-13.13.1.tar.gz) = 32743348
SHA256 (asterisk-core-sounds-en-g729-1.5.tar.gz) = 8b28a59cfa53b59c76e0a191704f0708e3d83acffab8c5e6f25dfc599f0123f9
SIZE (asterisk-core-sounds-en-g729-1.5.tar.gz) = 1551123
SHA256 (asterisk-moh-opsound-g729-2.03.tar.gz) = 0147ca9a97f0c550227aacb7793499057c4d2c64e021c95f93722f27d5549585
diff --git a/net/asterisk13/files/patch-include_asterisk_utils.h b/net/asterisk13/files/patch-include_asterisk_utils.h
new file mode 100644
index 000000000000..ea372d7f2425
--- /dev/null
+++ b/net/asterisk13/files/patch-include_asterisk_utils.h
@@ -0,0 +1,16 @@
+--- include/asterisk/utils.h.orig 2016-11-23 15:26:01 UTC
++++ include/asterisk/utils.h
+@@ -1127,4 +1127,13 @@ int ast_file_is_readable(const char *fil
+ */
+ int ast_compare_versions(const char *version1, const char *version2);
+
++/*
++ * \brief Test that an OS supports IPv6 Networking.
++ * \since 13.14.0
++ *
++ * \return True (non-zero) if the IPv6 supported.
++ * \return False (zero) if the OS doesn't support IPv6.
++ */
++int ast_check_ipv6(void);
++
+ #endif /* _ASTERISK_UTILS_H */
diff --git a/net/asterisk13/files/patch-main_utils.c b/net/asterisk13/files/patch-main_utils.c
new file mode 100644
index 000000000000..0be8c40bff87
--- /dev/null
+++ b/net/asterisk13/files/patch-main_utils.c
@@ -0,0 +1,21 @@
+--- main/utils.c.orig 2016-11-23 15:26:01 UTC
++++ main/utils.c
+@@ -2425,6 +2425,18 @@ char *ast_utils_which(const char *binary
+ return NULL;
+ }
+
++int ast_check_ipv6(void)
++{
++ int udp6_socket = socket(AF_INET6, SOCK_DGRAM, 0);
++
++ if (udp6_socket < 0) {
++ return 0;
++ }
++
++ close(udp6_socket);
++ return 1;
++}
++
+ void DO_CRASH_NORETURN ast_do_crash(void)
+ {
+ #if defined(DO_CRASH)
diff --git a/net/asterisk13/files/patch-res_res__pjsip__sdp__rtp.c b/net/asterisk13/files/patch-res_res__pjsip__sdp__rtp.c
new file mode 100644
index 000000000000..88ee0dac606e
--- /dev/null
+++ b/net/asterisk13/files/patch-res_res__pjsip__sdp__rtp.c
@@ -0,0 +1,23 @@
+--- res/res_pjsip_sdp_rtp.c.orig 2016-11-23 15:26:01 UTC
++++ res/res_pjsip_sdp_rtp.c
+@@ -51,6 +51,7 @@ ASTERISK_FILE_VERSION(__FILE__, "$Revisi
+ #include "asterisk/acl.h"
+ #include "asterisk/sdp_srtp.h"
+ #include "asterisk/dsp.h"
++#include "asterisk/utils.h"
+
+ #include "asterisk/res_pjsip.h"
+ #include "asterisk/res_pjsip_session.h"
+@@ -1493,7 +1494,11 @@ static int load_module(void)
+ {
+ CHECK_PJSIP_SESSION_MODULE_LOADED();
+
+- ast_sockaddr_parse(&address_rtp, "::", 0);
++ if (ast_check_ipv6()) {
++ ast_sockaddr_parse(&address_rtp, "::", 0);
++ } else {
++ ast_sockaddr_parse(&address_rtp, "0.0.0.0", 0);
++ }
+
+ if (!(sched = ast_sched_context_create())) {
+ ast_log(LOG_ERROR, "Unable to create scheduler context.\n");
diff --git a/net/asterisk13/files/patch-res_res__pjsip__t38.c b/net/asterisk13/files/patch-res_res__pjsip__t38.c
new file mode 100644
index 000000000000..543337212377
--- /dev/null
+++ b/net/asterisk13/files/patch-res_res__pjsip__t38.c
@@ -0,0 +1,23 @@
+--- res/res_pjsip_t38.c.orig 2016-11-23 15:26:01 UTC
++++ res/res_pjsip_t38.c
+@@ -44,6 +44,7 @@ ASTERISK_FILE_VERSION(__FILE__, "$Revisi
+ #include "asterisk/netsock2.h"
+ #include "asterisk/channel.h"
+ #include "asterisk/acl.h"
++#include "asterisk/utils.h"
+
+ #include "asterisk/res_pjsip.h"
+ #include "asterisk/res_pjsip_session.h"
+@@ -918,7 +919,11 @@ static int load_module(void)
+ {
+ CHECK_PJSIP_SESSION_MODULE_LOADED();
+
+- ast_sockaddr_parse(&address, "::", 0);
++ if (ast_check_ipv6()) {
++ ast_sockaddr_parse(&address, "::", 0);
++ } else {
++ ast_sockaddr_parse(&address, "0.0.0.0", 0);
++ }
+
+ if (ast_sip_session_register_supplement(&t38_supplement)) {
+ ast_log(LOG_ERROR, "Unable to register T.38 session supplement\n");
diff --git a/net/asterisk13/files/patch-res_res__rtp__asterisk.c b/net/asterisk13/files/patch-res_res__rtp__asterisk.c
deleted file mode 100644
index 5ce31556353f..000000000000
--- a/net/asterisk13/files/patch-res_res__rtp__asterisk.c
+++ /dev/null
@@ -1,15 +0,0 @@
-$OpenBSD: patch-res_res_rtp_asterisk_c,v 1.1 2016/07/30 21:12:15 sthen Exp $
-
-Obtained from OpenBSD cvs
-
---- res/res_rtp_asterisk.c.orig 2016-07-21 14:54:02 UTC
-+++ res/res_rtp_asterisk.c
-@@ -1357,7 +1357,7 @@ static int ast_rtp_dtls_set_configuratio
- return 0;
- }
-
--#if OPENSSL_VERSION_NUMBER < 0x10002000L
-+#if OPENSSL_VERSION_NUMBER < 0x10002000L || defined(LIBRESSL_VERSION_NUMBER)
- rtp->ssl_ctx = SSL_CTX_new(DTLSv1_method());
- #else
- rtp->ssl_ctx = SSL_CTX_new(DTLS_method());