aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoger Pau Monné <royger@FreeBSD.org>2016-12-16 10:35:43 +0000
committerRoger Pau Monné <royger@FreeBSD.org>2016-12-16 10:35:43 +0000
commitaaf04b52fd22faac22bfec047d5fa98908fe18a5 (patch)
tree4b9d1a52c5e1eb4bcf40003e6d20e3210362d721
parent67155c6f683b20ebcb306ea185b5cab3fa5f4f07 (diff)
downloadports-aaf04b52fd22faac22bfec047d5fa98908fe18a5.tar.gz
ports-aaf04b52fd22faac22bfec047d5fa98908fe18a5.zip
MFH: r428628
xen-tools: fix path of xenstore device When xenstore is not running on the same domain as the toolstack the xenstore device is used in order to access it (like when running some tools from an unprivileged domain). Fix the path to point to the FreeBSD path (/dev/xen/xenstore). This is a backport of upstream commit 7ff99b. Sponsored by: Citrix Systems R&D Approved by: portmgr (junovitch) --This line, and hose below, will be ignored-- M sysutils/xen-tools/Makefile AM sysutils/xen-tools/files/0001-libs-xenstore-set-correct-FreeBSD-device.patch
Notes
Notes: svn path=/branches/2016Q4/; revision=428669
-rw-r--r--sysutils/xen-tools/Makefile5
-rw-r--r--sysutils/xen-tools/files/0001-libs-xenstore-set-correct-FreeBSD-device.patch32
2 files changed, 35 insertions, 2 deletions
diff --git a/sysutils/xen-tools/Makefile b/sysutils/xen-tools/Makefile
index 046905ac84d7..1508ddb086e6 100644
--- a/sysutils/xen-tools/Makefile
+++ b/sysutils/xen-tools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xen
PKGNAMESUFFIX= -tools
PORTVERSION= 4.7.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= sysutils emulators
MASTER_SITES= http://downloads.xenproject.org/release/xen/${PORTVERSION}/
@@ -46,7 +46,8 @@ QEMU_ARGS= --disable-gtk \
EXTRA_PATCHES= ${FILESDIR}/var_paths.patch:-p1 \
${FILESDIR}/xsa198.patch:-p1 \
${FILESDIR}/0001-libxl-fix-creation-of-pkgconf-install-dir.patch \
- ${FILESDIR}/0001-tools-configure-fix-pkg-config-install-path-for-Free.patch
+ ${FILESDIR}/0001-tools-configure-fix-pkg-config-install-path-for-Free.patch \
+ ${FILESDIR}/0001-libs-xenstore-set-correct-FreeBSD-device.patch
CONFIGURE_ARGS+= --with-extra-qemuu-configure-args="${QEMU_ARGS}" \
--with-system-seabios=${LOCALBASE}/share/seabios/bios.bin
diff --git a/sysutils/xen-tools/files/0001-libs-xenstore-set-correct-FreeBSD-device.patch b/sysutils/xen-tools/files/0001-libs-xenstore-set-correct-FreeBSD-device.patch
new file mode 100644
index 000000000000..e93a70206229
--- /dev/null
+++ b/sysutils/xen-tools/files/0001-libs-xenstore-set-correct-FreeBSD-device.patch
@@ -0,0 +1,32 @@
+From 7ff99b232e0f91a5189f429498868bfccf8d7154 Mon Sep 17 00:00:00 2001
+From: Roger Pau Monne <roger.pau@citrix.com>
+Date: Mon, 12 Dec 2016 16:07:40 +0000
+Subject: [PATCH] libs/xenstore: set correct FreeBSD device
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The path to the xenstore FreeBSD device is /dev/xen/xenstore.
+
+Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
+Acked-by: Wei Liu <wei.liu2@citrix.com>
+---
+ tools/xenstore/xs_lib.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tools/xenstore/xs_lib.c b/tools/xenstore/xs_lib.c
+index 5ef3d6d..3e43f88 100644
+--- a/tools/xenstore/xs_lib.c
++++ b/tools/xenstore/xs_lib.c
+@@ -85,6 +85,8 @@ const char *xs_domain_dev(void)
+ return "/proc/xen/xenbus";
+ #elif defined(__NetBSD__)
+ return "/kern/xen/xenbus";
++#elif defined(__FreeBSD__)
++ return "/dev/xen/xenstore";
+ #else
+ return "/dev/xen/xenbus";
+ #endif
+--
+2.10.1 (Apple Git-78)
+