aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-03-07 18:43:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-03-07 18:43:13 +0000
commit31942753669f0c89d8cb073191ac864fa6301939 (patch)
tree145d95e14f5497c5b247581884246cc4903b16f1
parent3a1face15676fd263cb2ca5327f13883320e85a3 (diff)
downloadports-31942753669f0c89d8cb073191ac864fa6301939.tar.gz
ports-31942753669f0c89d8cb073191ac864fa6301939.zip
MFH: r435374
www/firefox: attempt to unbreak wifi geo and safebrowsing since 51.0 Approved by: ports-secteam (junovitch)
Notes
Notes: svn path=/branches/2017Q1/; revision=435635
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-env-api-keys21
2 files changed, 22 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 98943fefc804..3db462765ac7 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 52.0
DISTVERSIONSUFFIX=.source
-PORTREVISION= 1
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/files/patch-env-api-keys b/www/firefox/files/patch-env-api-keys
new file mode 100644
index 000000000000..e20b012f27cf
--- /dev/null
+++ b/www/firefox/files/patch-env-api-keys
@@ -0,0 +1,21 @@
+# Accept API keys from environment like before bug 1294585
+
+--- build/moz.configure/keyfiles.configure
++++ build/moz.configure/keyfiles.configure
+@@ -18,6 +18,7 @@ def keyfile(desc, help=None, callback=lambda x: x):
+ @checking('for the %s key' % desc, lambda x: x and x is not no_key)
+ @imports(_from='__builtin__', _import='open')
+ @imports(_from='__builtin__', _import='IOError')
++ @imports(_from='os', _import='environ')
+ def keyfile(value):
+ if value:
+ try:
+@@ -28,7 +29,7 @@ def keyfile(desc, help=None, callback=lambda x: x):
+ raise FatalCheckError("'%s' is empty." % value[0])
+ except IOError as e:
+ raise FatalCheckError("'%s': %s." % (value[0], e.strerror))
+- return no_key
++ return environ.get('MOZ_%s_KEY' % desc.upper().replace(' ', '_')) or no_key
+
+ return keyfile
+