aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-03-11 05:21:52 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-03-11 05:21:52 +0000
commitc102bed1ade4b43322268532b5d59871fa97733d (patch)
treec8c481888758366a29461af1262d2fc4ec1b7296
parentf4439315146332e60de7fce807b0694e791934b7 (diff)
downloadports-c102bed1ade4b43322268532b5d59871fa97733d.tar.gz
ports-c102bed1ade4b43322268532b5d59871fa97733d.zip
MFH: r435838
x11-drivers/xf86-input-wacom: update to 0.34.2 Changes: https://sourceforge.net/p/linuxwacom/mailman/message/35711101/ Approved by: ports-secteam (junovitch)
Notes
Notes: svn path=/branches/2017Q1/; revision=435880
-rw-r--r--x11-drivers/xf86-input-wacom/Makefile2
-rw-r--r--x11-drivers/xf86-input-wacom/distinfo6
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-src-xf86Wacom.c12
3 files changed, 15 insertions, 5 deletions
diff --git a/x11-drivers/xf86-input-wacom/Makefile b/x11-drivers/xf86-input-wacom/Makefile
index 096f867118da..3cfb89acdf80 100644
--- a/x11-drivers/xf86-input-wacom/Makefile
+++ b/x11-drivers/xf86-input-wacom/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-input-wacom
-PORTVERSION= 0.34.0
+PORTVERSION= 0.34.2
CATEGORIES= x11-drivers
MASTER_SITES= SF/linuxwacom/${PORTNAME}
diff --git a/x11-drivers/xf86-input-wacom/distinfo b/x11-drivers/xf86-input-wacom/distinfo
index 922b5635d6bf..8335b3e28eff 100644
--- a/x11-drivers/xf86-input-wacom/distinfo
+++ b/x11-drivers/xf86-input-wacom/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480975206
-SHA256 (xorg/driver/xf86-input-wacom-0.34.0.tar.bz2) = f15d8e4f3bf3a5b2db0b3f9c9565361b084896c3cb54ac11b8de5e405f9cb045
-SIZE (xorg/driver/xf86-input-wacom-0.34.0.tar.bz2) = 598624
+TIMESTAMP = 1489012292
+SHA256 (xorg/driver/xf86-input-wacom-0.34.2.tar.bz2) = 2ad1b9db141104370aef4966aae419dde915caea316e1df2c6ac063545706b1c
+SIZE (xorg/driver/xf86-input-wacom-0.34.2.tar.bz2) = 632058
diff --git a/x11-drivers/xf86-input-wacom/files/patch-src-xf86Wacom.c b/x11-drivers/xf86-input-wacom/files/patch-src-xf86Wacom.c
index 77db151e5ed9..3f2e4f13414f 100644
--- a/x11-drivers/xf86-input-wacom/files/patch-src-xf86Wacom.c
+++ b/x11-drivers/xf86-input-wacom/files/patch-src-xf86Wacom.c
@@ -1,4 +1,4 @@
---- src/xf86Wacom.c.orig 2015-10-23 17:26:33 UTC
+--- src/xf86Wacom.c.orig 2017-02-24 04:04:55 UTC
+++ src/xf86Wacom.c
@@ -667,6 +667,17 @@ void wcmReadPacket(InputInfoPtr pInfo)
@@ -18,3 +18,13 @@
/* for all other errors, hope that the hotplugging code will
* remove the device */
if (errno != EAGAIN && errno != EINTR)
+@@ -823,9 +834,7 @@ static void wcmUnlinkTouchAndPen(InputIn
+ static int wcmDevProc(DeviceIntPtr pWcm, int what)
+ {
+ InputInfoPtr pInfo = (InputInfoPtr)pWcm->public.devicePrivate;
+-#ifdef DEBUG
+ WacomDevicePtr priv = (WacomDevicePtr)pInfo->private;
+-#endif
+ Status rc = !Success;
+
+ DBG(2, priv, "BEGIN dev=%p priv=%p "