aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-06 17:53:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-06 17:53:30 +0000
commit15004661f2c016531033f2625c935a9d1a30e53c (patch)
treedb41f70e56d8c130e6f5b2efd801cba9a1ec425a
parentfdcb2002fb89839360a971f4ee4437d0d00cae95 (diff)
downloadports-15004661f2c016531033f2625c935a9d1a30e53c.tar.gz
ports-15004661f2c016531033f2625c935a9d1a30e53c.zip
Notes
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-python-lhafile/Makefile22
-rw-r--r--archivers/py-python-lhafile/distinfo3
-rw-r--r--archivers/py-python-lhafile/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index e4a2d60d3b3f..327047e5ee44 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -171,6 +171,7 @@
SUBDIR += py-lz4
SUBDIR += py-lzma
SUBDIR += py-pyliblzma
+ SUBDIR += py-python-lhafile
SUBDIR += py-python-snappy
SUBDIR += py-rarfile
SUBDIR += py-rcssmin
diff --git a/archivers/py-python-lhafile/Makefile b/archivers/py-python-lhafile/Makefile
new file mode 100644
index 000000000000..23d21ce18a60
--- /dev/null
+++ b/archivers/py-python-lhafile/Makefile
@@ -0,0 +1,22 @@
+# Created by: Carsten Larsen <cs@innolan.dk>
+# $FreeBSD$
+
+PORTNAME= python-lhafile
+PORTVERSION= 0.2.1
+CATEGORIES= archivers python
+MASTER_SITES= http://fengestad.no/python-lhafile/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= cs@innolan.dk
+COMMENT= LHA(.lzh) file extract interface
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/lzhlib.so
+
+.include <bsd.port.mk>
diff --git a/archivers/py-python-lhafile/distinfo b/archivers/py-python-lhafile/distinfo
new file mode 100644
index 000000000000..0b4b05bad8b7
--- /dev/null
+++ b/archivers/py-python-lhafile/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469201699
+SHA256 (python-lhafile-0.2.1.tar.gz) = ccddfa7312d08a48159fa702c5e92efcc0e341d580e4dfb2c5a1bbdc2704e35e
+SIZE (python-lhafile-0.2.1.tar.gz) = 265756
diff --git a/archivers/py-python-lhafile/pkg-descr b/archivers/py-python-lhafile/pkg-descr
new file mode 100644
index 000000000000..79fa2e7574ac
--- /dev/null
+++ b/archivers/py-python-lhafile/pkg-descr
@@ -0,0 +1,4 @@
+The interface is like zipfile extension included in regular
+python distribution.
+
+WWW: http://fengestad.no/python-lhafile/