aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2017-06-28 16:56:17 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2017-06-28 16:56:17 +0000
commit34084f34e81e847aac666da8bcf9fabfbb38149c (patch)
tree5e5ffb8516d793ec89608bbf93099b603cec092b
parentcfe93133b9a4144d4c82816d4351b1e2a0020b1f (diff)
downloadports-34084f34e81e847aac666da8bcf9fabfbb38149c.tar.gz
ports-34084f34e81e847aac666da8bcf9fabfbb38149c.zip
MFH: r444364
security/py-{acme,certbot}: fix missing dependency on py-mock Common: - Move py-mock requirement to dev_extras in setup.py - Bump PORTREVISION PR: 220274 Submitted by: cpm Reported by: Randy Westlund <rwestlun@gmail.com> Approved by: koobs (maintainer, py-certbot) Approved by: ports-secteam (miwi)
Notes
Notes: svn path=/branches/2017Q2/; revision=444601
-rw-r--r--security/py-acme/Makefile1
-rw-r--r--security/py-acme/files/patch-setup.py18
-rw-r--r--security/py-certbot/Makefile1
-rw-r--r--security/py-certbot/files/patch-setup.py18
4 files changed, 38 insertions, 0 deletions
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
index e21c4fe2ab1c..afa5f5d6e771 100644
--- a/security/py-acme/Makefile
+++ b/security/py-acme/Makefile
@@ -3,6 +3,7 @@
PORTNAME= acme
PORTVERSION= 0.12.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
diff --git a/security/py-acme/files/patch-setup.py b/security/py-acme/files/patch-setup.py
new file mode 100644
index 000000000000..cac716fe5406
--- /dev/null
+++ b/security/py-acme/files/patch-setup.py
@@ -0,0 +1,18 @@
+--- setup.py.orig 2017-06-26 10:16:14 UTC
++++ setup.py
+@@ -12,7 +12,6 @@ install_requires = [
+ # rsa_recover_prime_factors (>=0.8)
+ 'cryptography>=0.8',
+ # Connection.set_tlsext_host_name (>=0.13)
+- 'mock',
+ 'PyOpenSSL>=0.13',
+ 'pyrfc3339',
+ 'pytz',
+@@ -35,6 +34,7 @@ if sys.version_info < (2, 7):
+ ])
+
+ dev_extras = [
++ 'mock',
+ 'nose',
+ 'tox',
+ ]
diff --git a/security/py-certbot/Makefile b/security/py-certbot/Makefile
index fc2208ef1584..1dea909137d9 100644
--- a/security/py-certbot/Makefile
+++ b/security/py-certbot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= certbot
PORTVERSION= 0.12.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
diff --git a/security/py-certbot/files/patch-setup.py b/security/py-certbot/files/patch-setup.py
new file mode 100644
index 000000000000..a13fd00ab36e
--- /dev/null
+++ b/security/py-certbot/files/patch-setup.py
@@ -0,0 +1,18 @@
+--- setup.py.orig 2017-06-26 10:13:14 UTC
++++ setup.py
+@@ -42,7 +42,6 @@ install_requires = [
+ 'ConfigArgParse>=0.9.3',
+ 'configobj',
+ 'cryptography>=1.2', # load_pem_x509_certificate
+- 'mock',
+ 'parsedatetime>=1.3', # Calendar.parseDT
+ 'PyOpenSSL',
+ 'pyrfc3339',
+@@ -67,6 +66,7 @@ dev_extras = [
+ 'astroid==1.3.5',
+ 'coverage',
+ 'ipdb',
++ 'mock',
+ 'nose',
+ 'pylint==1.4.2', # upstream #248
+ 'tox',