aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-06-28 02:55:47 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-06-28 02:55:47 +0000
commit7432f9865c4e5c4cd67f2c18547640215b2dcb6b (patch)
treebd665757789fdadde8b60ffd2b50b16b71e2befc
parentb3d03f02260af4b3cb9d05cce5f41e057e5ae171 (diff)
downloadports-7432f9865c4e5c4cd67f2c18547640215b2dcb6b.tar.gz
ports-7432f9865c4e5c4cd67f2c18547640215b2dcb6b.zip
MFH: r444423
games/xscavenger: fix font mapping with Clang or GCC 7.* Characters of user name and some menu couldn't display the correct letters because of incorrect font mapping. PR: 220106 Submitted by: Yasuhito FUTATSUKI Approved by: ports-secteam (miwi)
Notes
Notes: svn path=/branches/2017Q2/; revision=444536
-rw-r--r--games/xscavenger/Makefile1
-rw-r--r--games/xscavenger/files/patch-x.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/games/xscavenger/Makefile b/games/xscavenger/Makefile
index fdd392272699..415ce99b0447 100644
--- a/games/xscavenger/Makefile
+++ b/games/xscavenger/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xscavenger
PORTVERSION= 1.4.5
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.linuxmotors.com/scavenger/downloads/
diff --git a/games/xscavenger/files/patch-x.c b/games/xscavenger/files/patch-x.c
new file mode 100644
index 000000000000..7a42be4e352e
--- /dev/null
+++ b/games/xscavenger/files/patch-x.c
@@ -0,0 +1,12 @@
+--- x.c.orig 2014-11-18 19:58:49 UTC
++++ x.c
+@@ -445,7 +445,8 @@ int i;
+ i=0;
+ while(*p)
+ {
+- fmap[tolower(*p)]=fmap[*p++]=i++;
++ fmap[tolower(*p)]=fmap[*p]=i++;
++ p++;
+ }
+ }
+