aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 12:12:37 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 12:12:37 +0000
commit03f0ef55d3c92597d305c1fe39b0c6312f8560cd (patch)
tree056edde52ce5d7d422bc0fb497bb85fe7ed53b6a
parente890501d35dcca3b4eaf36b75cc0e192f9277054 (diff)
downloadports-03f0ef55d3c92597d305c1fe39b0c6312f8560cd.tar.gz
ports-03f0ef55d3c92597d305c1fe39b0c6312f8560cd.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POE-Component-JobQueue/Makefile26
-rw-r--r--devel/p5-POE-Component-JobQueue/distinfo1
-rw-r--r--devel/p5-POE-Component-JobQueue/pkg-comment1
-rw-r--r--devel/p5-POE-Component-JobQueue/pkg-descr9
-rw-r--r--devel/p5-POE-Component-JobQueue/pkg-plist7
6 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4242e59f5f72..16511a426bef 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -396,6 +396,7 @@
SUBDIR += p5-OLE-Storage_Lite
SUBDIR += p5-ORBit
SUBDIR += p5-POE
+ SUBDIR += p5-POE-Component-JobQueue
SUBDIR += p5-POE-Component-Pcap
SUBDIR += p5-POE-Component-RSS
SUBDIR += p5-PV
diff --git a/devel/p5-POE-Component-JobQueue/Makefile b/devel/p5-POE-Component-JobQueue/Makefile
new file mode 100644
index 000000000000..3b39c1761a42
--- /dev/null
+++ b/devel/p5-POE-Component-JobQueue/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: POE-Component-JobQueue
+# Date created: 10 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-JobQueue
+PORTVERSION= 0.51
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
+ http://poe.perl.org/poedown/
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= POE::Component::JobQueue.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POE-Component-JobQueue/distinfo b/devel/p5-POE-Component-JobQueue/distinfo
new file mode 100644
index 000000000000..256042b715d4
--- /dev/null
+++ b/devel/p5-POE-Component-JobQueue/distinfo
@@ -0,0 +1 @@
+MD5 (POE-Component-JobQueue-0.51.tar.gz) = f72a5ad34446e51f1443c8d950f94565
diff --git a/devel/p5-POE-Component-JobQueue/pkg-comment b/devel/p5-POE-Component-JobQueue/pkg-comment
new file mode 100644
index 000000000000..89f00f31a7d4
--- /dev/null
+++ b/devel/p5-POE-Component-JobQueue/pkg-comment
@@ -0,0 +1 @@
+POE component for processing large numbers of tasks with finite numbers of workers
diff --git a/devel/p5-POE-Component-JobQueue/pkg-descr b/devel/p5-POE-Component-JobQueue/pkg-descr
new file mode 100644
index 000000000000..0588f6f5f1ff
--- /dev/null
+++ b/devel/p5-POE-Component-JobQueue/pkg-descr
@@ -0,0 +1,9 @@
+POE::Component::JobQueue manages a finite pool of worker sessions as
+they handle an arbitrarily large number of tasks. It often is used as
+a form of flow control, preventing a large group of tasks from
+exhausting some sort of resource.
+
+WWW: http://search.cpan.org/search?dist=POE-Component-JobQueue
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/devel/p5-POE-Component-JobQueue/pkg-plist b/devel/p5-POE-Component-JobQueue/pkg-plist
new file mode 100644
index 000000000000..050b2a5750a7
--- /dev/null
+++ b/devel/p5-POE-Component-JobQueue/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/JobQueue/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/POE/Component/JobQueue.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/JobQueue
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true