aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-10-26 00:17:47 +0000
committerWen Heping <wen@FreeBSD.org>2009-10-26 00:17:47 +0000
commit225601ddec06b3f0a94a774891c8f62626b311e1 (patch)
tree0aa7c430a881c1d271729238e010a139e79c9361
parent0afc0b5d32dfb548b693797e2549b3acd9a59d3f (diff)
downloadports-225601ddec06b3f0a94a774891c8f62626b311e1.tar.gz
ports-225601ddec06b3f0a94a774891c8f62626b311e1.zip
Notes
-rw-r--r--mail/Makefile1
-rw-r--r--mail/mpop/Makefile60
-rw-r--r--mail/mpop/distinfo3
-rw-r--r--mail/mpop/files/patch-doc-mpop.123
-rw-r--r--mail/mpop/pkg-descr7
-rw-r--r--mail/mpop/pkg-plist3
6 files changed, 97 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 72df7afa8132..d68644b806ce 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -286,6 +286,7 @@
SUBDIR += mmr
SUBDIR += movemail
SUBDIR += moztraybiff
+ SUBDIR += mpop
SUBDIR += mreport
SUBDIR += msgconvert
SUBDIR += msmtp
diff --git a/mail/mpop/Makefile b/mail/mpop/Makefile
new file mode 100644
index 000000000000..0092de47d20d
--- /dev/null
+++ b/mail/mpop/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: mpop
+# Date created: 2009-10-24
+# Whom: Sylvio Cesar <scjamorim@bsd.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpop
+PORTVERSION= 1.0.19
+CATEGORIES= mail
+MASTER_SITES= SF
+
+MAINTAINER= scjamorim@bsd.com.br
+COMMENT= MPOP is a small and fast POP3 client
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAN1= mpop.1
+INFO= mpop
+
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+= --with-ssl=gnutls
+.elif defined(WITH_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-ssl=openssl
+.else
+CONFIGURE_ARGS+= --without-ssl
+.endif
+
+.if defined(WITH_GNUTLS) || defined(WITH_OPENSSL)
+RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+.endif
+
+.if defined(WITH_GSASL)
+LIB_DEPENDS+= gsasl.13:${PORTSDIR}/security/gsasl
+.else
+CONFIGURE_ARGS+= --without-gsasl
+.endif
+
+.if !defined(WITHOUT_IDN)
+LIB_DEPENDS+= idn.16:${PORTSDIR}/dns/libidn
+CONFIGURE_ARGS+= --with-libidn
+.else
+CONFIGURE_ARGS+= --without-libidn
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/mpop/distinfo b/mail/mpop/distinfo
new file mode 100644
index 000000000000..ec0a90e849e4
--- /dev/null
+++ b/mail/mpop/distinfo
@@ -0,0 +1,3 @@
+MD5 (mpop-1.0.19.tar.bz2) = 40a48d486121a15075faee944a7b8fb7
+SHA256 (mpop-1.0.19.tar.bz2) = 3151f3d0fb34f0f93bcd139ab87ec6c4ba23b3d0768a88c310fe0838c41b6d01
+SIZE (mpop-1.0.19.tar.bz2) = 839096
diff --git a/mail/mpop/files/patch-doc-mpop.1 b/mail/mpop/files/patch-doc-mpop.1
new file mode 100644
index 000000000000..02585e08d934
--- /dev/null
+++ b/mail/mpop/files/patch-doc-mpop.1
@@ -0,0 +1,23 @@
+--- doc/mpop.1.orig 2009-10-05 16:47:15.000000000 -0300
++++ doc/mpop.1 2009-10-24 12:18:19.000000000 -0200
+@@ -333,6 +333,11 @@
+ .br
+ On Debian based systems, you can install the \fBca\-certificates\fP package and
+ use the file \fB/etc/ssl/certs/ca\-certificates.crt\fP.
+++.br
++On FreeBSD based systems, you can install the \fBsecurity/ca_root_nss\fP port and
+++use the file \fB/usr/local/share/certs/ca-root-nss.crt\fP. Please note that if
+++you are installing mpop from ports with OpenSSL or gnutls support,
+++the \fBsecurity/ca_root_nss\fP port will be installed automaticly.
+ .br
+ An empty argument disables this feature.
+ .IP "tls_crl_file [\fIfile\fP]"
+@@ -457,7 +462,7 @@
+ .br
+ # Enable full TLS certificate checks.
+ .br
+-tls_trust_file /etc/ssl/certs/ca\-certificates.crt
++tls_trust_file /usr/local/share/certs/ca-root-nss.crt
+ .br
+ # Use the POP3-over-TLS variant instead of the STARTTLS variant.
+ .br
diff --git a/mail/mpop/pkg-descr b/mail/mpop/pkg-descr
new file mode 100644
index 000000000000..5d4ad83c579a
--- /dev/null
+++ b/mail/mpop/pkg-descr
@@ -0,0 +1,7 @@
+mpop is a small, fast, and portable POP3 client. Its features include
+header-based email filtering (filter junk mail before downloading it),
+delivery to mbox files, maildir folders, or a mail delivery agent,
+a very fast POP3 implementation, many authentication methods,
+and good support for TLS/SSL.
+
+WWW: http://mpop.sourceforge.net
diff --git a/mail/mpop/pkg-plist b/mail/mpop/pkg-plist
new file mode 100644
index 000000000000..0fe6b056415e
--- /dev/null
+++ b/mail/mpop/pkg-plist
@@ -0,0 +1,3 @@
+bin/mpop
+%%NLS%%share/locale/de/LC_MESSAGES/mpop.mo
+%%NLS%%share/locale/es/LC_MESSAGES/mpop.mo