aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-05-13 08:54:50 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-05-13 08:54:50 +0000
commit2867b58cfe14fe203edc2ec45778eeceee51f66d (patch)
tree8e08ee4dbcd42112ac1d224f8cd30575c318f3c5
parent151e9079d28fa0459f26ea063d995e293c85e10d (diff)
downloadports-2867b58cfe14fe203edc2ec45778eeceee51f66d.tar.gz
ports-2867b58cfe14fe203edc2ec45778eeceee51f66d.zip
Notes
-rw-r--r--devel/ruby-rbtree/Makefile8
-rw-r--r--multimedia/mkvtoolnix/Makefile4
-rw-r--r--net/ns/Makefile4
-rw-r--r--net/ns2/Makefile4
-rw-r--r--textproc/dictfmt/Makefile8
5 files changed, 26 insertions, 2 deletions
diff --git a/devel/ruby-rbtree/Makefile b/devel/ruby-rbtree/Makefile
index 68042a812a92..39a308093ed8 100644
--- a/devel/ruby-rbtree/Makefile
+++ b/devel/ruby-rbtree/Makefile
@@ -23,6 +23,12 @@ INSTALL_TARGET= site-install
# MIT license
DOCS= ChangeLog LICENSE README
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
@@ -31,4 +37,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/mkvtoolnix/Makefile b/multimedia/mkvtoolnix/Makefile
index d8e2c6e58f86..41e75886635d 100644
--- a/multimedia/mkvtoolnix/Makefile
+++ b/multimedia/mkvtoolnix/Makefile
@@ -37,6 +37,10 @@ post-patch:
.include <bsd.port.pre.mk>
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
# gcc 3.2 was available on 5.x before this OSVERSION
# do not build gcc 3.3 unless necessary
.if ${OSVERSION} < 501103
diff --git a/net/ns/Makefile b/net/ns/Makefile
index 7c843d92113a..cf87c535cfc3 100644
--- a/net/ns/Makefile
+++ b/net/ns/Makefile
@@ -33,6 +33,10 @@ ALL_TARGET=
BROKEN= "Does not compile on alpha 4.x"
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ns ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ns.1 ${PREFIX}/man/man1
diff --git a/net/ns2/Makefile b/net/ns2/Makefile
index 7c843d92113a..cf87c535cfc3 100644
--- a/net/ns2/Makefile
+++ b/net/ns2/Makefile
@@ -33,6 +33,10 @@ ALL_TARGET=
BROKEN= "Does not compile on alpha 4.x"
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ns ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ns.1 ${PREFIX}/man/man1
diff --git a/textproc/dictfmt/Makefile b/textproc/dictfmt/Makefile
index 188e12367190..8529e0f8205b 100644
--- a/textproc/dictfmt/Makefile
+++ b/textproc/dictfmt/Makefile
@@ -34,4 +34,10 @@ PLIST_FILES= bin/dictfmt bin/dictfmt_index2suffix bin/dictfmt_index2word \
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
+.include <bsd.port.post.mk>