aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-13 16:55:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-13 16:55:08 +0000
commit29775210b177b8a90694769ea86e051459e7978e (patch)
tree295339baed149188e2c57d1b344a54718cc4af87
parent4a2b67fa7260a5cc414fda64185edce6a66a9c73 (diff)
downloadports-29775210b177b8a90694769ea86e051459e7978e.tar.gz
ports-29775210b177b8a90694769ea86e051459e7978e.zip
Notes
-rw-r--r--MOVED2
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/alloywm/Makefile74
-rw-r--r--x11-wm/alloywm/distinfo3
-rw-r--r--x11-wm/alloywm/pkg-descr24
-rw-r--r--x11/9term/Makefile31
-rw-r--r--x11/9term/distinfo3
-rw-r--r--x11/9term/files/patch-aa44
-rw-r--r--x11/9term/files/patch-ac11
-rw-r--r--x11/9term/files/patch-ad66
-rw-r--r--x11/9term/files/patch-ae44
-rw-r--r--x11/9term/files/patch-af23
-rw-r--r--x11/9term/files/patch-ag23
-rw-r--r--x11/9term/files/patch-ah29
-rw-r--r--x11/9term/files/patch-ai78
-rw-r--r--x11/9term/pkg-descr12
-rw-r--r--x11/Makefile1
17 files changed, 2 insertions, 467 deletions
diff --git a/MOVED b/MOVED
index ad51e562a5ce..9efbdd3c4fcf 100644
--- a/MOVED
+++ b/MOVED
@@ -3704,3 +3704,5 @@ databases/py-tada||2008-12-13|Has expired: Has been broken for more than 6 month
databases/qdbm-java||2008-12-13|Has expired: Has been broken for more than 6 months
audio/shellac||2008-12-13|Has expired: Has been broken for more than 6 months
audio/snett||2008-12-13|Has expired: Has been broken for more than 6 months
+x11-wm/alloywm||2008-12-13|Has expired: Has been broken for more than 6 months
+x11/9term||2008-12-13|Has expired: depends on expired port
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 05725624684f..327dd5111eba 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -8,7 +8,6 @@
SUBDIR += afterstep-i18n
SUBDIR += afterstep-stable
SUBDIR += ahwm
- SUBDIR += alloywm
SUBDIR += amaterus
SUBDIR += amiwm
SUBDIR += awesome
diff --git a/x11-wm/alloywm/Makefile b/x11-wm/alloywm/Makefile
deleted file mode 100644
index 1ca1777f311a..000000000000
--- a/x11-wm/alloywm/Makefile
+++ /dev/null
@@ -1,74 +0,0 @@
-# New ports collection makefile for: alloywm
-# Date created: 2002-01-20
-# Whom: trevor
-#
-# $FreeBSD$
-#
-
-PORTNAME= alloywm
-PORTVERSION= 0.4.0
-PORTREVISION= 4
-CATEGORIES= x11-wm
-MASTER_SITES= http://www.phatboydesigns.net/devel/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Has title bars, shading, resizing, automatic placement, window list
-
-BROKEN= Checksum mismatch
-DEPRECATED= Has been broken for more than 6 months
-EXPIRATION_DATE=2008-09-19
-
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --xroot=${LOCALBASE}
-PLIST= ${WRKDIR}/pkg-plist
-USE_GMAKE= yes
-USE_XORG= x11
-WANT_GNOME= yes
-REINPLACE_ARGS= -i'' -E
-SCRIPTS= ${WRKSRC}/scriptdir
-
-pre-configure:
- ${FIND} ${WRKSRC} \( -name '*.in' -or -name configure \) -exec \
- ${REINPLACE_CMD} 's:bash:sh:g ; \
- s:gtk-config:${GTK_CONFIG}:g' {} \;
- ${RM} -f ${WRKSRC}/*/Makefile
- ${CHMOD} +x ${WRKSRC}/configure
-
-do-build:
- cd ${WRKSRC}/goodies && ${GMAKE}
-.for ii in client events main misc new screen widgets
- cd ${WRKSRC}/src && ${CC} -c ${CFLAGS} -I${LOCALBASE}/include \
- ${ii}.c
-.endfor
- cd ${WRKSRC}/src && ${CC} ${CFLAGS} -DSHAPE -o alloywm \
- -L${LOCALBASE}/lib -lXext -lX11 \
- client.o events.o main.o misc.o new.o screen.o widgets.o
-
-pre-install:
- cd ${WRKSRC} && ${FIND} * -type f -perm 755 | cut -f 2 -d / | \
- ${SED} "s:^:bin/:g" > ${PLIST}
- ${FIND} ${SCRIPTS} \! -name '*in' -type f | \
- ${SED} "s:^${SCRIPTS}:bin:g" >> ${PLIST}
-.if !defined(NOPORTDOCS)
-.for i in Changelog README
- ${ECHO_CMD} share/doc/alloywm/${i} >> ${PLIST}
-.endfor
- ${ECHO_CMD} @dirrm share/doc/alloywm >> ${PLIST}
-.endif
-
-do-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Changelog ${WRKSRC}/README ${DOCSDIR}
-.endif
- ${FIND} ${SCRIPTS} \! -name '*in' -type f -exec \
- ${INSTALL_SCRIPT} {} ${PREFIX}/bin \;
- ${FIND} ${WRKSRC} -type f -perm 755 \
- -exec ${INSTALL_PROGRAM} {} ${PREFIX}/bin \;
-
-.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgtk12}!=""
-USE_GNOME+= gtk12
-PKGNAMESUFFIX= -gtk
-.endif
-.include <bsd.port.post.mk>
diff --git a/x11-wm/alloywm/distinfo b/x11-wm/alloywm/distinfo
deleted file mode 100644
index 2b1d141838a7..000000000000
--- a/x11-wm/alloywm/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (alloywm-0.4.0.tar.gz) = 140d95dc19566ffbeafd7f8a5eb24008
-SHA256 (alloywm-0.4.0.tar.gz) = 702b6586f9fb69f7d99a9d2f75fa183879020da59aa8e33191cdca148edf31bb
-SIZE (alloywm-0.4.0.tar.gz) = 54617
diff --git a/x11-wm/alloywm/pkg-descr b/x11-wm/alloywm/pkg-descr
deleted file mode 100644
index e212d5917c47..000000000000
--- a/x11-wm/alloywm/pkg-descr
+++ /dev/null
@@ -1,24 +0,0 @@
-This window manager is yet another descendant of aewm. It has title bars,
-shading, a widget for resizing, automatic placement of windows (with the upper
-left corner at the current position of the mouse) as they open, and a list (by
-title) from which windows may be chosen for raising or un-iconizing. Some
-features are implemented in applets, not all of which work in this port.
-
-from the home page:
- It is somewhat ICCCM compliant (it knows what a transient window is,
- and catches client messages and knows the MIT-SHAPE). It does not try
- to look like any other known OS (though, some people tell me it looks
- like Mac OS, others say Amiga.) So, if you want a window manager that
- is sanely usable within the smallest constraints (and without you
- thinking you have an inept piece of software), then this is for you.
-
-from the README:
- As its name implies, alloywm is a quite exquisite, aesthetic little
- window manager for X11. The premise of this window manager is not to
- be over-bloated [...] to keep the interface out of a user's way [...]
-
- It is not very configurable [...]
-
- [...] you cannot click inside the window to give focus [...]
-
-WWW: http://www.phatboydesigns.net/alloywm/
diff --git a/x11/9term/Makefile b/x11/9term/Makefile
deleted file mode 100644
index db5da97df6a4..000000000000
--- a/x11/9term/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-# New ports collection makefile for: 9term
-# Date created: Sun Aug 13 12:36:14 CDT 1995
-# Whom: erich@rrnet.com
-#
-# $FreeBSD$
-#
-
-PORTNAME= 9term
-PORTVERSION= 1.6.3
-PORTREVISION= 2
-CATEGORIES= x11 plan9
-MASTER_SITES= ftp://ftp.cs.usyd.edu.au/matty/unicode/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An X11 program which emulates a plan9 window
-
-# needs library and private header, but not during runtime
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/editors/sam:build
-
-DEPRECATED= depends on expired port
-EXPIRATION_DATE=2008-07-18
-BROKEN= Unfetchable
-
-NO_WRKSUBDIR= yes
-USE_XORG= x11
-MAKE_ENV= SAMDIR=${WRKDIRPREFIX}${.CURDIR}/../../editors/sam/work
-MAN1= 9term.1
-PLIST_FILES= bin/9term
-
-.include <bsd.port.mk>
diff --git a/x11/9term/distinfo b/x11/9term/distinfo
deleted file mode 100644
index f90267466f29..000000000000
--- a/x11/9term/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (9term.1.6.3.tar.gz) = 064a4428aba417a7793d3252423faf0b
-SHA256 (9term.1.6.3.tar.gz) = e8b15469eeb6460c0b6198afaa55605fbee32c1ad39a59fd5b4e1e3eac6bb39f
-SIZE (9term.1.6.3.tar.gz) = 135169
diff --git a/x11/9term/files/patch-aa b/x11/9term/files/patch-aa
deleted file mode 100644
index 5b8594ec3b16..000000000000
--- a/x11/9term/files/patch-aa
+++ /dev/null
@@ -1,44 +0,0 @@
-*** libtext/Makefile.orig Wed Jun 1 21:01:19 1994
---- libtext/Makefile Mon Jul 31 11:34:06 1995
-***************
-*** 5,18 ****
- #
- # Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
- # if your compiler supports posix-compatible compilation
-! OS=-DSOLARIS
-
- # add -Iincludedir for any include directories that need to be searched
- # for posix header files
-! INCS=-I. -I../include
-
- # add name of library orderer - use ":" if none exists
-! RANLIB=:
-
- # add name of library
- AR=ar
---- 5,18 ----
- #
- # Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
- # if your compiler supports posix-compatible compilation
-! OS=-DSUNOS -O2
-
- # add -Iincludedir for any include directories that need to be searched
- # for posix header files
-! INCS=-I. -I$(SAMDIR)/include
-
- # add name of library orderer - use ":" if none exists
-! RANLIB=ranlib
-
- # add name of library
- AR=ar
-***************
-*** 38,41 ****
-
- install: $(LIB)
-
-! $(OBJ): ../include/u.h ../include/libc.h ../include/libg.h ../include/frame.h ../include/text.h
---- 39,42 ----
-
- install: $(LIB)
-
-! $(OBJ): $(SAMDIR)/include/u.h $(SAMDIR)/include/libc.h $(SAMDIR)/include/libg.h $(SAMDIR)/include/frame.h text.h
diff --git a/x11/9term/files/patch-ac b/x11/9term/files/patch-ac
deleted file mode 100644
index 7b83164d63b0..000000000000
--- a/x11/9term/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
-*** Makefile.orig Fri Feb 11 10:13:45 2000
---- Makefile Fri Feb 11 10:16:11 2000
-***************
-*** 0 ****
---- 1,6 ----
-+ all:
-+ (cd libtext; ${MAKE})
-+ (cd 9term; ${MAKE})
-+ install:
-+ ${BSD_INSTALL_PROGRAM} 9term/9term $(PREFIX)/bin
-+ ${BSD_INSTALL_MAN} 9term/9term.1 $(PREFIX)/man/man1
diff --git a/x11/9term/files/patch-ad b/x11/9term/files/patch-ad
deleted file mode 100644
index 46e5a7b8bf66..000000000000
--- a/x11/9term/files/patch-ad
+++ /dev/null
@@ -1,66 +0,0 @@
---- 9term/Makefile.orig Mon Mar 14 13:50:54 1994
-+++ 9term/Makefile Fri Feb 11 10:18:21 2000
-@@ -11,27 +11,29 @@
- # Define RISCOS for Mips RISC/os
- # Define BSDPTYS for BSD-style pty support
- # Define POSIXPTYS for POSIX ptys
--OS=-DSOLARIS
-
--# where we'll install it
--BINDIR=/usr/pgrad/matty/bin/$(cputype)
-+OS= -D_LIBXG_EXTENSION -DSUNOS
-+
-+SAMPATH=${SAMDIR}
-+
-+BINDIR=. # where we'll install it
-
- HEADERFILE=9term.h
- TARGET=9term
--INCLUDES=-I. -I../include -I/usr/openwin/include
--CFLAGS=-g $(OS) $(INCLUDES) -fno-builtin -D_LIBXG_EXTENSION
--LDFLAGS=-g -R/usr/openwin/lib -L/usr/openwin/lib -R/usr/ucblib -L/usr/ucblib
--CC=gcc
-+INCLUDES=-I. -I../libtext -I$(SAMPATH)/include -I${LOCALBASE}/include
-+CFLAGS+= $(OS) $(INCLUDES)
-+LDFLAGS=
-+CC?=gcc
-
- # change this if your X11 libraries are in different places
- # or if you need extra libraries to load with X11 applications
--LIBS=../libtext/libtext.a ../libframe/libframe.a ../libXg/libXg.a
--XLIBS=-lXt -lX11
--
-+LIBS=../libtext/libtext.a $(SAMPATH)/libframe/libframe.a $(SAMPATH)/libXg/libXg.a
-+XLIBS= -lXt -lX11 -L${LOCALBASE}/lib
-+XLIBS+=-Wl,-rpath,$(LOCALBASE)/lib
- OBJECTS=9term.o command.o display.o pty.o
-
- $(TARGET): $(OBJECTS)
-- $(CC) $(LDFLAGS) -o $(TARGET) $(OBJECTS) $(LIBS) $(XLIBS) -lm -lucb
-+ $(CC) $(LDFLAGS) -o $(TARGET) $(OBJECTS) $(LIBS) $(XLIBS) -lm
-
- wloc: wloc.o
- $(CC) $(LDFLAGS) -o wloc wloc.o $(LIBS) $(XLIBS) -lm
-@@ -39,21 +43,17 @@
- label: wloc
- ln wloc label
-
--unicode: unicode.o
-- $(CC) $(LDFLAGS) -o unicode unicode.o $(LIBS) $(XLIBS) -lm
--
- install: $(TARGET) wloc label
- cp $(TARGET) $(BINDIR)
- chown root $(BINDIR)/$(TARGET)
- chmod 04755 $(BINDIR)/$(TARGET)
- mv wloc $(BINDIR)
- mv label $(BINDIR)
-- mv unicode $(BINDIR)
-
- clean:
- rm -f *.o core
-
- nuke: clean
-- rm -f $(TARGET) wloc label unicode
-+ rm -f $(TARGET) wloc label
-
- $(OBJECTS): 9term.h
diff --git a/x11/9term/files/patch-ae b/x11/9term/files/patch-ae
deleted file mode 100644
index c946588a8656..000000000000
--- a/x11/9term/files/patch-ae
+++ /dev/null
@@ -1,44 +0,0 @@
---- 9term/9term.c.orig Fri Jun 3 17:35:39 1994
-+++ 9term/9term.c Fri Feb 11 10:08:04 2000
-@@ -10,7 +10,11 @@
- #include <frame.h>
- #include <text.h>
-
-+#ifdef __FreeBSD__
-+#include <sys/termios.h>
-+#else
- #include <sys/termio.h>
-+#endif
- #include <signal.h>
- #include <sys/stat.h>
-
-@@ -153,9 +157,9 @@
- }
- }
-
-- setenv("TERM", "9term", 1);
-+ O_setenv("TERM", "9term", 1);
- /* Cope with BSD-oid systems. - cks */
-- setenv("TERMCAP", "9term: :am:bl=^G:do=^J:nl=^J:", 1);
-+ O_setenv("TERMCAP", "9term: :am:bl=^G:do=^J:nl=^J:", 1);
- signal(SIGINT, SIG_IGN);
-
- init_display(&argc, argv, cmd, resource);
-@@ -718,7 +722,7 @@
- texthighlight(t, t->length, t->length, F&~D);
- #ifdef REMOTE
- flushstream();
-- killpg(r == quitchar ? SIGQUIT : SIGINT);
-+ O_killpg(r == quitchar ? SIGQUIT : SIGINT);
- #else
- sendrunes(&r, 1);
- #endif
-@@ -804,7 +808,7 @@
- * export a name-value pair to environment
- */
- int
--setenv(char *name, char *value, int overwrite)
-+O_setenv(char *name, char *value, int overwrite)
- {
- char *p;
-
diff --git a/x11/9term/files/patch-af b/x11/9term/files/patch-af
deleted file mode 100644
index f5ce232a1928..000000000000
--- a/x11/9term/files/patch-af
+++ /dev/null
@@ -1,23 +0,0 @@
---- 9term/9term.h.orig Thu Dec 15 23:49:15 1994
-+++ 9term/9term.h Fri Feb 11 10:08:04 2000
-@@ -31,7 +31,7 @@
- extern int isig;
-
- extern void specialchars(int);
--extern int setenv(char *, char *, int);
-+extern int O_setenv(char *, char *, int);
- extern void init_display(int *, char **, char**, char*);
- #ifdef NEEDVARARG
- extern void error();
-@@ -65,6 +65,11 @@
- #endif
-
- #ifdef SUNOS
-+#define POSIXPTYS
-+#define BSDPTYS
-+#endif
-+
-+#ifdef __FreeBSD__
- #define POSIXPTYS
- #define BSDPTYS
- #endif
diff --git a/x11/9term/files/patch-ag b/x11/9term/files/patch-ag
deleted file mode 100644
index eb293180ecdd..000000000000
--- a/x11/9term/files/patch-ag
+++ /dev/null
@@ -1,23 +0,0 @@
---- 9term/command.c.orig Mon Mar 7 10:50:51 1994
-+++ 9term/command.c Fri Feb 11 10:08:04 2000
-@@ -13,7 +13,11 @@
- #include <sys/wait.h>
- #include <signal.h>
- #include <grp.h>
-+#ifdef __FreeBSD__
-+#include <termios.h>
-+#else
- #include <termio.h>
-+#endif
- #ifdef SOLARIS
- #include <sys/stropts.h>
- #endif
-@@ -204,7 +208,7 @@
- */
-
- void
--killpg(int sig)
-+O_killpg(int sig)
- {
- if (comm_pid)
- kill(-comm_pid, sig);
diff --git a/x11/9term/files/patch-ah b/x11/9term/files/patch-ah
deleted file mode 100644
index 634575389bb7..000000000000
--- a/x11/9term/files/patch-ah
+++ /dev/null
@@ -1,29 +0,0 @@
---- 9term/display.c.orig Thu Dec 15 23:48:28 1994
-+++ 9term/display.c Fri Feb 11 10:08:04 2000
-@@ -114,7 +114,7 @@
- delwin(Widget w, XEvent *event, String *params, Cardinal *n)
- {
- if (w == _toplevel)
-- killpg(SIGHUP);
-+ O_killpg(SIGHUP);
- }
-
- /*
-@@ -185,7 +185,7 @@
- else if (!strcasecmp(s, "plan9"))
- kbdmode = PLAN9;
- if (s = get_resource(resource, class, "p9font", "P9font"))
-- setenv("font", s, 1);
-+ O_setenv("font", s, 1);
- if (s = get_resource(resource, class, "highwater", "Highwater"))
- highwater = atoi(s);
- if (s = get_resource(resource, class, "lowwater", "Lowwater"))
-@@ -230,7 +230,7 @@
- #endif
- /* export window id to environment */
- sprintf(id, "%d", XtWindow(_toplevel));
-- setenv("WINDOWID", id, 1);
-+ O_setenv("WINDOWID", id, 1);
-
- /* register mouse and keyboard events */
- einit(Ekeyboard | Emouse);
diff --git a/x11/9term/files/patch-ai b/x11/9term/files/patch-ai
deleted file mode 100644
index fa7fb9f7c014..000000000000
--- a/x11/9term/files/patch-ai
+++ /dev/null
@@ -1,78 +0,0 @@
---- 9term/pty.c.orig Sat Jul 23 00:47:29 1994
-+++ 9term/pty.c Fri Feb 11 10:08:05 2000
-@@ -12,7 +12,16 @@
-
- #include <utmp.h>
- #include <errno.h>
--#ifdef SUNOS
-+
-+#ifdef __FreeBSD__
-+# include <termios.h>
-+
-+/* # include <stropts.h> */
-+ /* Isn't POSIX and portability so much fun? */
-+# define VRPRNT VREPRINT
-+#endif
-+
-+#if defined(SUNOS) && !defined(__FreeBSD__)
- # undef _POSIX_SOURCE
- # include <sys/termio.h>
- # include <stropts.h>
-@@ -41,7 +50,7 @@
- # define VEOL2 _VEOL2
- #endif
-
--#ifdef RISCOS
-+#ifdef RISCOS
- # include <sys/stat.h>
- # include </usr/include/ctype.h> /* to defeat posix version */
- # define VLNEXT V_LNEXT
-@@ -49,10 +58,12 @@
- # define VRPRNT V_RPRNT
- # define VWERASE V_WERAS
- #else
-+#ifndef __FreeBSD__
- # include <ctype.h>
- #endif
-+#endif
-
--#ifdef OSF1
-+#if defined(OSF1)
- # define V_START VSTART
- # define V_STOP VSTOP
- # define V_SUSP VSUSP
-@@ -115,7 +126,7 @@
- char udef, p9def;
- };
-
--#if defined(SUNOS) || defined(IRIX) || defined(SOLARIS)
-+#if defined(SUNOS) || defined(IRIX) || defined(SOLARIS) || defined(__FreeBSD__)
- # define V_START VSTART
- # define V_STOP VSTOP
- # define V_SUSP VSUSP
-@@ -139,7 +150,7 @@
- #ifndef _POSIX_SOURCE
- { "eol2", 4, VEOL2, 0, 0 },
- #endif
--#if !defined(_OSF_SOURCE) && !defined(_POSIX_SOURCE)
-+#if !defined(_OSF_SOURCE) && !defined(_POSIX_SOURCE) && !defined(__FreeBSD__)
- { "swtch", 5, VSWTCH, 0, 0 },
- #endif
- { "start", 5, V_START, ctrl('q'), ctrl('q') },
-@@ -292,10 +303,16 @@
- /* Insure some sanity. */
- ttmode.c_lflag |= ECHO;
- ttmode.c_oflag &= ~(ONLCR);
-+#ifndef __FreeBSD__
- ttmode.c_oflag |= ONLRET;
-+#endif
- } else {
- ttmode.c_iflag = BRKINT | IGNPAR | ICRNL | IXON;
-+#ifdef __FreeBSD__
-+ ttmode.c_oflag = OPOST;
-+#else
- ttmode.c_oflag = OPOST | ONLRET;
-+#endif
- ttmode.c_cflag = B9600 | PARENB | CS8 | CREAD;
- ttmode.c_lflag = ISIG | ICANON | ECHO | ECHOK;
- #ifdef __ultrix
diff --git a/x11/9term/pkg-descr b/x11/9term/pkg-descr
deleted file mode 100644
index 3c3dfd6f094a..000000000000
--- a/x11/9term/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-9term is a terminal emulator which emulates an 8 1/2 window.
-this version supports unicode. To see this support, cat one of
-the utf files in an 8 1/2 window. Your Xserver must be able to
-find the required fonts, and the `*p9font' x-resource must be
-set to point to the fonts, maybe `/usr/X11R6/lib/X11/fonts/Xg/unicode.9.font'.
-
-This port needs work, it is functional enough to get the feel
-for 9term, but some of the features don't work with FreeBSD.
-
-eric.
-
-WWW: http://www.cs.su.oz.au/~matty/9term/
diff --git a/x11/Makefile b/x11/Makefile
index 4188071fb5b2..38e12979d313 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -6,7 +6,6 @@
SUBDIR += 3ddesktop
SUBDIR += 9box
SUBDIR += 9menu
- SUBDIR += 9term
SUBDIR += Terminal
SUBDIR += accessx
SUBDIR += alltray