aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2017-08-18 16:23:33 +0000
committerMark Felder <feld@FreeBSD.org>2017-08-18 16:23:33 +0000
commit48f6bd0e20c20abff0f1b4e8ef3e749503c82a99 (patch)
tree7ef62f4cf25fdb81e800110e330d8973754d00a0
parentc4328ddcc41c119aeccbbf5ebabcc1bc93e50522 (diff)
downloadports-48f6bd0e20c20abff0f1b4e8ef3e749503c82a99.tar.gz
ports-48f6bd0e20c20abff0f1b4e8ef3e749503c82a99.zip
MFH: r448255
www/swish-e: Fix building on FreeBSD 11.1 and HEAD Newer zlib has its own uncompress2 function, so hot-patch the source to rename uncompress2 to swishe_uncompress2. I could not devise a better way to do this at the moment. Cleaner patch would be welcomed. Approved by: portmgr (with hat)
Notes
Notes: svn path=/branches/2017Q3/; revision=448256
-rw-r--r--www/swish-e/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/www/swish-e/Makefile b/www/swish-e/Makefile
index ec661ac53945..9d175680ac68 100644
--- a/www/swish-e/Makefile
+++ b/www/swish-e/Makefile
@@ -10,11 +10,9 @@ MASTER_SITES= http://swish-e.org/distribution/
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple web indexing for humans - enhanced
-BROKEN_FreeBSD_12= fails to compile: zlib.h: conflicting types for 'uncompress2'
-
+USES= gmake libtool perl5 shebangfix
USE_LDCONFIG= yes
USE_GNOME= libxml2
-USES= gmake libtool perl5 shebangfix
SHEBANG_FILES= src/swishspider
GNU_CONFIGURE= yes
MAKE_ARGS+= pkgconfigdir="${PREFIX}/libdata/pkgconfig" \
@@ -36,5 +34,8 @@ post-patch:
${WRKSRC}/${p}/Makefile.in
.endfor
.endif
+ # Rename uncompress2 to swishe_uncompress2 to fix building with newer zlib which exports
+ # its own uncompress2
+ ${FIND} ${WRKSRC}/src -type f -exec ${REINPLACE_CMD} 's,uncompress2,swishe_uncompress2,g' {} \+
.include <bsd.port.mk>