aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-29 22:44:10 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-29 22:44:10 +0000
commit5ebed607cc00d6fbe8105bf8cd8d84d15dbd18f6 (patch)
treec869a0114a90ef3f64176b2d479cb822b6afd8c3
parentaf65230fd3f5ad84efd7c476e73c5ad38302caae (diff)
downloadports-5ebed607cc00d6fbe8105bf8cd8d84d15dbd18f6.tar.gz
ports-5ebed607cc00d6fbe8105bf8cd8d84d15dbd18f6.zip
Notes
-rw-r--r--math/foma/Makefile8
-rw-r--r--math/lambda/Makefile2
-rw-r--r--math/sfst/Makefile2
3 files changed, 6 insertions, 6 deletions
diff --git a/math/foma/Makefile b/math/foma/Makefile
index 516215b2993d..4da3c91753fd 100644
--- a/math/foma/Makefile
+++ b/math/foma/Makefile
@@ -11,14 +11,14 @@ COMMENT= Toolkit for constructing finite-state automata and transducers
LICENSE= GPLv2
-USES= bison gmake
+USES= bison gmake readline
USE_LDCONFIG= yes
do-install:
- cd ${WRKSRC} && ${INSTALL_DATA} fomalib.h fomalibconf.h ${STAGEDIR}${PREFIX}/include/
- cd ${WRKSRC} && ${INSTALL_PROGRAM} foma flookup cgflookup ${STAGEDIR}${PREFIX}/bin/
+ (cd ${WRKSRC} && ${INSTALL_DATA} fomalib.h fomalibconf.h ${STAGEDIR}${PREFIX}/include/)
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} foma flookup cgflookup ${STAGEDIR}${PREFIX}/bin/)
${INSTALL_LIB} ${WRKSRC}/libfoma.a ${STAGEDIR}${PREFIX}/lib/
${INSTALL_LIB} ${WRKSRC}/libfoma.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libfoma.so.0
- cd ${STAGEDIR}${PREFIX}/lib && ${LN} -s libfoma.so.0 libfoma.so
+ (cd ${STAGEDIR}${PREFIX}/lib && ${LN} -s libfoma.so.0 libfoma.so)
.include <bsd.port.mk>
diff --git a/math/lambda/Makefile b/math/lambda/Makefile
index 0662e88a48bb..31048e9f5900 100644
--- a/math/lambda/Makefile
+++ b/math/lambda/Makefile
@@ -11,7 +11,7 @@ COMMENT= Lambda calculus interpreter
LICENSE= GPLv2
-USES= perl5
+USES= perl5 readline
USE_PERL5= build
GNU_CONFIGURE= yes
diff --git a/math/sfst/Makefile b/math/sfst/Makefile
index 1b7a15928efb..af7d1bf63935 100644
--- a/math/sfst/Makefile
+++ b/math/sfst/Makefile
@@ -12,7 +12,7 @@ COMMENT= A toolbox for the implementation of morphological analysers
WRKSRC= ${WRKDIR}/${PORTNAME:tu}/src
INSTALL_TARGET= install maninstall libinstall
-USES= gmake
+USES= gmake readline
USE_LDCONFIG= yes
.include <bsd.port.mk>