aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-11-12 15:59:47 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-11-12 15:59:47 +0000
commit605c98a482cbcd33e22f376fab159d8f20caff2c (patch)
tree6a527c95a79d232ebcb50746ac258d2c487b5fd1
parente3608906ab5180d386cda5c9566e5fcd7148505f (diff)
downloadports-605c98a482cbcd33e22f376fab159d8f20caff2c.tar.gz
ports-605c98a482cbcd33e22f376fab159d8f20caff2c.zip
Notes
-rw-r--r--audio/penguinsap/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/audio/penguinsap/Makefile b/audio/penguinsap/Makefile
index 507b4e09adc2..9501067e07cc 100644
--- a/audio/penguinsap/Makefile
+++ b/audio/penguinsap/Makefile
@@ -9,6 +9,7 @@ MASTER_SITES= CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Command-line Atari(TM) .sap player
+USES= compiler
USE_DOS2UNIX= yes
SOURCES= sapPokey pokey1 sapCpu sapEngine main pokey0
@@ -22,11 +23,8 @@ PLIST_FILES= bin/sap
.include <bsd.port.pre.mk>
-_CLANG!= ${CXX} --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
-ISCLANG= ${_CLANG:M[34][0-9]}
-
# clang can build this without -fno-exceptions
-.if empty(ISCLANG)
+.if ${COMPILER_TYPE} == "gcc"
CXXFLAGS+= -fno-exceptions
.endif
@@ -46,7 +44,4 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sap ${STAGEDIR}${PREFIX}/bin
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>