aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-08 23:15:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-08 23:15:33 +0000
commit6d56f7f42e0dbc48a674b1bde4eb648cf786ba51 (patch)
tree94f1e5959e9ed37965f1bc8c73682f0f7a7b156d
parent62b2e2e5a2c6b211fd99356b0ee732aae7d6324b (diff)
downloadports-6d56f7f42e0dbc48a674b1bde4eb648cf786ba51.tar.gz
ports-6d56f7f42e0dbc48a674b1bde4eb648cf786ba51.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/py-postmarkup/Makefile20
-rw-r--r--www/py-postmarkup/distinfo3
-rw-r--r--www/py-postmarkup/pkg-descr3
-rw-r--r--www/py-postmarkup/pkg-plist3
5 files changed, 30 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2cc3e025ea9b..8e7a0b9f56e9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1013,6 +1013,7 @@
SUBDIR += py-paste
SUBDIR += py-pastedeploy
SUBDIR += py-pastescript
+ SUBDIR += py-postmarkup
SUBDIR += py-prewikka
SUBDIR += py-pullparser
SUBDIR += py-pysearch
diff --git a/www/py-postmarkup/Makefile b/www/py-postmarkup/Makefile
new file mode 100644
index 000000000000..0d2bdb164a4a
--- /dev/null
+++ b/www/py-postmarkup/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: py-postmarkup
+# Date created: June 7, 2007
+# Whom: Chao Shin <quakelee@cn.freebsd.org>
+#
+# $FreeBSD$
+
+PORTNAME= postmarkup
+PORTVERSION= 1.0.4
+CATEGORIES= www python
+MASTER_SITES= http://postmarkup.googlecode.com/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= quakelee@cn.freebsd.org
+COMMENT= A library to parse the BBcode written in Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_ZIP= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-postmarkup/distinfo b/www/py-postmarkup/distinfo
new file mode 100644
index 000000000000..fe49af5936f1
--- /dev/null
+++ b/www/py-postmarkup/distinfo
@@ -0,0 +1,3 @@
+MD5 (postmarkup-1.0.4.zip) = c0a25426783783ed76aec3149c80e737
+SHA256 (postmarkup-1.0.4.zip) = f0588e3b3e2ed39833f79d466e41c25215c36cbd9e9f12f470b9627b04f5e0a2
+SIZE (postmarkup-1.0.4.zip) = 7219
diff --git a/www/py-postmarkup/pkg-descr b/www/py-postmarkup/pkg-descr
new file mode 100644
index 000000000000..466ce0a63490
--- /dev/null
+++ b/www/py-postmarkup/pkg-descr
@@ -0,0 +1,3 @@
+Generates XHTML snippets from BBCode.
+
+WWW: http://code.google.com/p/postmarkup/
diff --git a/www/py-postmarkup/pkg-plist b/www/py-postmarkup/pkg-plist
new file mode 100644
index 000000000000..0bb1152e53e2
--- /dev/null
+++ b/www/py-postmarkup/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/postmarkup.py
+%%PYTHON_SITELIBDIR%%/postmarkup.pyc
+%%PYTHON_SITELIBDIR%%/postmarkup.pyo