aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 07:33:46 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 07:33:46 +0000
commit8a44bfc3552b81f63284731a76ac04b170bc9466 (patch)
tree149967103da3d86772bf0e1e29c2df45b1bd8bac
parentdd537b1721613df32f8f64621934372d3a238dd2 (diff)
downloadports-8a44bfc3552b81f63284731a76ac04b170bc9466.tar.gz
ports-8a44bfc3552b81f63284731a76ac04b170bc9466.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/bfbtester/Makefile19
-rw-r--r--security/bfbtester/distinfo1
-rw-r--r--security/bfbtester/files/patch-src::bfbt::exec.c17
-rw-r--r--security/bfbtester/pkg-comment1
-rw-r--r--security/bfbtester/pkg-descr9
-rw-r--r--security/bfbtester/pkg-plist1
7 files changed, 49 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 17a6db37871c..3dc792c4feca 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -8,6 +8,7 @@
SUBDIR += amavis-perl
SUBDIR += apg
SUBDIR += beecrypt
+ SUBDIR += bfbtester
SUBDIR += bjorb
SUBDIR += bro
SUBDIR += bugs
diff --git a/security/bfbtester/Makefile b/security/bfbtester/Makefile
new file mode 100644
index 000000000000..b744f0769c88
--- /dev/null
+++ b/security/bfbtester/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: bfbtester
+# Date created: 31 January 2001
+# Whom: Mike Heffner <mheffner@vt.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bfbtester
+PORTVERSION= 2.0
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= bfbtester
+
+MAINTAINER= mheffner@vt.edu
+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/security/bfbtester/distinfo b/security/bfbtester/distinfo
new file mode 100644
index 000000000000..d7b9a55b5743
--- /dev/null
+++ b/security/bfbtester/distinfo
@@ -0,0 +1 @@
+MD5 (bfbtester-2.0.tar.gz) = 73f41bfe1b8498b7bb2967fe7339e8bd
diff --git a/security/bfbtester/files/patch-src::bfbt::exec.c b/security/bfbtester/files/patch-src::bfbt::exec.c
new file mode 100644
index 000000000000..de43066f9b9a
--- /dev/null
+++ b/security/bfbtester/files/patch-src::bfbt::exec.c
@@ -0,0 +1,17 @@
+Index: src/bfbt/exec.c
+===================================================================
+RCS file: /cvsroot/bfbtester/bfbtester/src/bfbt/exec.c,v
+retrieving revision 1.5
+diff -u -r1.5 exec.c
+--- src/bfbt/exec.c 2001/01/25 06:24:49 1.5
++++ src/bfbt/exec.c 2001/02/01 03:35:37
+@@ -144,7 +144,8 @@
+ else if( WIFSIGNALED(entry->status) ){
+ /* we ignore SIGKILL and SIGPIPE */
+ if( WTERMSIG(entry->status) == SIGKILL
+- || WTERMSIG(entry->status) == SIGPIPE){
++ || WTERMSIG(entry->status) == SIGPIPE
++ || WTERMSIG(entry->status) == SIGPROF){
+ return;
+ }
+ {
diff --git a/security/bfbtester/pkg-comment b/security/bfbtester/pkg-comment
new file mode 100644
index 000000000000..166e9d930703
--- /dev/null
+++ b/security/bfbtester/pkg-comment
@@ -0,0 +1 @@
+A security tool for testing binaries for overflows
diff --git a/security/bfbtester/pkg-descr b/security/bfbtester/pkg-descr
new file mode 100644
index 000000000000..eb29122cc7a5
--- /dev/null
+++ b/security/bfbtester/pkg-descr
@@ -0,0 +1,9 @@
+BFBTester will perform checks of single and multiple argument command
+line overflows and environment variable overflows. BFBTester will also
+watch for tempfile creation activity to alert the user of any programs
+using unsafe tempfile names.
+
+WWW: http://bfbtester.sourceforge.net
+
+- Mike Heffner
+mheffner@vt.edu
diff --git a/security/bfbtester/pkg-plist b/security/bfbtester/pkg-plist
new file mode 100644
index 000000000000..5e8edda50928
--- /dev/null
+++ b/security/bfbtester/pkg-plist
@@ -0,0 +1 @@
+bin/bfbtester