aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2007-07-05 09:15:41 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2007-07-05 09:15:41 +0000
commit8ffbeff52994c88d4a2c9e5be967ff915f1f4cc6 (patch)
tree2d7d331b956c45afb8b7ba6744d71ea2b54a3c4c
parent7f2acdc743f6a675d717a1c7169e59fe96aea89d (diff)
downloadports-8ffbeff52994c88d4a2c9e5be967ff915f1f4cc6.tar.gz
ports-8ffbeff52994c88d4a2c9e5be967ff915f1f4cc6.zip
Notes
-rw-r--r--www/links/Makefile5
-rw-r--r--www/links/distinfo6
-rw-r--r--www/links/files/patch-types.c12
3 files changed, 11 insertions, 12 deletions
diff --git a/www/links/Makefile b/www/links/Makefile
index 4f7d02e3614b..1ef8f162a182 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= links
-PORTVERSION= 2.1.p21
-PORTREVISION= 1
+PORTVERSION= 2.1.p28
PORTEPOCH= 1
CATEGORIES?= www
MASTER_SITES= http://links.twibright.com/download/
-DISTNAME= ${PORTNAME}-2.1pre21
+DISTNAME= ${PORTNAME}-2.1pre28
MAINTAINER?= demon@FreeBSD.org
COMMENT= Lynx-like text WWW browser
diff --git a/www/links/distinfo b/www/links/distinfo
index 6ec4a0b3d76b..1645f0ca92c9 100644
--- a/www/links/distinfo
+++ b/www/links/distinfo
@@ -1,3 +1,3 @@
-MD5 (links-2.1pre21.tar.bz2) = 7687e2c32e337e11c6e9d8cd8c5202c9
-SHA256 (links-2.1pre21.tar.bz2) = 0ad03eff9b4ff3de552906b8adb6a459da019cb78a1d509343f4c73d7529667a
-SIZE (links-2.1pre21.tar.bz2) = 3869781
+MD5 (links-2.1pre28.tar.bz2) = 815afe558dd548258eeb03b01cce01ce
+SHA256 (links-2.1pre28.tar.bz2) = 203531be7c84ebe3a5d53c6d6cda4f4a27626dec620ec5aa8926414d0bee5995
+SIZE (links-2.1pre28.tar.bz2) = 3915943
diff --git a/www/links/files/patch-types.c b/www/links/files/patch-types.c
index b0feba5dcce9..e68d4a8041db 100644
--- a/www/links/files/patch-types.c
+++ b/www/links/files/patch-types.c
@@ -1,9 +1,9 @@
---- types.c.orig Thu Mar 24 10:36:47 2005
-+++ types.c Thu Mar 24 10:38:12 2005
-@@ -796,7 +796,8 @@
- if (*ct == '.') ext = ct + 1;
- else if (dir_sep(*ct)) ext = NULL;
- if (ext) while (ext[extl] && !dir_sep(ext[extl]) && !end_of_dir(url, ext[extl])) extl++;
+--- types.c.orig Thu Jul 5 13:10:37 2007
++++ types.c Thu Jul 5 13:12:07 2007
+@@ -807,7 +807,8 @@
+ ext = NULL;
+ }
+ if (ext) while (ext[extl] && ext[extl] != '.' && !dir_sep(ext[extl]) && !end_of_dir(url, ext[extl])) extl++;
- if ((extl == 3 && !casecmp(ext, "htm", 3)) ||
+ if (force_html ||
+ (extl == 3 && !casecmp(ext, "htm", 3)) ||