aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-07 17:22:09 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-07 17:22:09 +0000
commit9f2715387f7d19ba5428e72f4d9c11aa8bc5524f (patch)
tree7729f36df754a988b26f5da5d1ed984b70ff0277
parentba86f4f4535f940b5c785cd1a4a6adb9cce1fe49 (diff)
downloadports-9f2715387f7d19ba5428e72f4d9c11aa8bc5524f.tar.gz
ports-9f2715387f7d19ba5428e72f4d9c11aa8bc5524f.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pho/Makefile26
-rw-r--r--graphics/pho/distinfo1
-rw-r--r--graphics/pho/files/patch-Makefile11
-rw-r--r--graphics/pho/pkg-descr6
-rw-r--r--graphics/pho/pkg-plist1
6 files changed, 46 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 9386f3b387b0..6ec0e1015cdf 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -272,6 +272,7 @@
SUBDIR += peps
SUBDIR += pgperl
SUBDIR += pgplot
+ SUBDIR += pho
SUBDIR += photopc
SUBDIR += phplot
SUBDIR += picturebook
diff --git a/graphics/pho/Makefile b/graphics/pho/Makefile
new file mode 100644
index 000000000000..156e9a163a7e
--- /dev/null
+++ b/graphics/pho/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pho
+# Date created: 10 April 2003
+# Whom: Roland Jesse <roland.jesse@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pho
+PORTVERSION= 0.9.1
+CATEGORIES= graphics
+MASTER_SITES= http://shallowsky.com/software/pho/
+
+MAINTAINER= roland.jesse@gmx.net
+COMMENT= A lightweight image viewer
+
+USE_GMAKE= yes
+USE_GNOME= gdkpixbuf gtk12
+USE_REINPLACE= yes
+
+MAN1= pho.1
+
+do-configure:
+ @(cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|make|gmake|g' Makefile)
+ @(cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|install -D|install|g' Makefile)
+
+.include <bsd.port.mk>
diff --git a/graphics/pho/distinfo b/graphics/pho/distinfo
new file mode 100644
index 000000000000..763996ae825e
--- /dev/null
+++ b/graphics/pho/distinfo
@@ -0,0 +1 @@
+MD5 (pho-0.9.1.tar.gz) = 8fab6d3eb1ff1c959f702d52e2aa7cdb
diff --git a/graphics/pho/files/patch-Makefile b/graphics/pho/files/patch-Makefile
new file mode 100644
index 000000000000..265532e1fb7d
--- /dev/null
+++ b/graphics/pho/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Tue Oct 7 10:19:24 2003
++++ Makefile Tue Oct 7 10:19:39 2003
+@@ -14,7 +14,7 @@
+
+ INSTALL = /usr/bin/install -D
+
+-INSTALLPREFIX = ${DESTDIR}/usr/local
++INSTALLPREFIX = ${DESTDIR}${PREFIX}
+
+ TARFILE = pho-$(VERSION).tar.gz
+
diff --git a/graphics/pho/pkg-descr b/graphics/pho/pkg-descr
new file mode 100644
index 000000000000..8c65160fe3da
--- /dev/null
+++ b/graphics/pho/pkg-descr
@@ -0,0 +1,6 @@
+Pho is a lightweight utility for viewing, rotating, or deleting large
+numbers of images quickly, and making notes about what to do with each
+of them. It is particularly useful for processing hundreds of images
+after uploading them from a digital camera.
+
+WWW: http://shallowsky.com/software/pho/
diff --git a/graphics/pho/pkg-plist b/graphics/pho/pkg-plist
new file mode 100644
index 000000000000..1a4ac8f277cb
--- /dev/null
+++ b/graphics/pho/pkg-plist
@@ -0,0 +1 @@
+bin/pho