aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2006-10-09 14:27:26 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2006-10-09 14:27:26 +0000
commita109e33441e4540e21473b7b27b9c549e09d3c0e (patch)
treefefa02fee8d38f32467b2708d62f2e2787eb34b5
parent9e0ef82bb228a470c73f416319ac412bd868898d (diff)
downloadports-a109e33441e4540e21473b7b27b9c549e09d3c0e.tar.gz
ports-a109e33441e4540e21473b7b27b9c549e09d3c0e.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--Mk/bsd.python.mk23
-rw-r--r--UPDATING10
3 files changed, 19 insertions, 15 deletions
diff --git a/MOVED b/MOVED
index 584895883288..d4e5aa245505 100644
--- a/MOVED
+++ b/MOVED
@@ -2490,3 +2490,4 @@ sysutils/gnomesu|security/libgnomesu|2006-10-08|Was broken, similar functionalit
databases/java-db||2006-10-08|Duplicate with java/berkeley-db
devel/cscout-devel||2006-10-09|Has expired: The (long overdue) release of 2.2 has made this port obsolete. Use devel/cscout
sysutils/cfengine2|sysutils/cfengine|2006-10-09|moved to systuils/cfengine
+lang/python-devel|lang/python25|2006-10-09|moved to lang/python25
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 4fea6cdc0619..bc3a188183eb 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -7,7 +7,7 @@
.if !defined(_POSTMKINCLUDED) && !defined(Python_Pre_Include)
Python_Pre_Include= bsd.python.mk
-Python_Include_MAINTAINER= perky@FreeBSD.org
+Python_Include_MAINTAINER= python@FreeBSD.org
# This file contains some variable definitions that are supposed to
# make your life easier when dealing with ports related to the Python
@@ -159,8 +159,8 @@ Python_Include_MAINTAINER= perky@FreeBSD.org
# specific version of zope.
#
-_PYTHON_PORTBRANCH= 2.4
-_PYTHON_ALLBRANCHES= 2.4 2.3 2.2 2.1 2.5 # preferred first
+_PYTHON_PORTBRANCH= 2.5
+_PYTHON_ALLBRANCHES= 2.5 2.4 2.3 2.2 2.1 # preferred first
_ZOPE_PORTBRANCH= 2.7
_ZOPE_ALLBRANCHES= 2.7 2.8 2.9 3.2
@@ -309,15 +309,15 @@ PYTHON_PORTVERSION= ${_PYTHON_PORTVERSION}
# Python-2.5
.if ${PYTHON_VERSION} == "python2.5"
-PYTHON_PORTVERSION?=2.5.c2
-PYTHON_PORTSDIR= ${PORTSDIR}/lang/python-devel
+PYTHON_PORTVERSION?=2.5
+PYTHON_PORTSDIR= ${PORTSDIR}/lang/python25
PYTHON_REL= 250
PYTHON_SUFFIX= 25
# Python-2.4
.elif ${PYTHON_VERSION} == "python2.4"
PYTHON_PORTVERSION?=2.4.3
-PYTHON_PORTSDIR= ${PORTSDIR}/lang/python
+PYTHON_PORTSDIR= ${PORTSDIR}/lang/python24
PYTHON_REL= 243
PYTHON_SUFFIX= 24
@@ -358,22 +358,15 @@ check-makevars::
@${ECHO} " python2.1"
@${ECHO} " python2.2"
@${ECHO} " python2.3"
- @${ECHO} " python2.4 (default)"
- @${ECHO} " python2.5"
+ @${ECHO} " python2.4"
+ @${ECHO} " python2.5 (default)"
@${FALSE}
.endif
-.if defined(PYTHON_REL) && ${PYTHON_REL} == 250
-PYTHON_MASTER_SITES= ${MASTER_SITE_PYTHON}
-PYTHON_MASTER_SITE_SUBDIR= ftp/python/2.5
-PYTHON_DISTFILE= Python-${PYTHON_PORTVERSION:S/5.c/5c/}.tgz
-PYTHON_WRKSRC= ${WRKDIR}/Python-${PYTHON_PORTVERSION:S/5.c/5c/}
-.else
PYTHON_MASTER_SITES= ${MASTER_SITE_PYTHON}
PYTHON_MASTER_SITE_SUBDIR= ftp/python/${PYTHON_PORTVERSION}
PYTHON_DISTFILE= Python-${PYTHON_PORTVERSION}.tgz
PYTHON_WRKSRC= ${WRKDIR}/Python-${PYTHON_PORTVERSION}
-.endif # defined(PYTHON_REL) && ${PYTHON_REL} == 250
PYTHON_INCLUDEDIR= ${PYTHONBASE}/include/${PYTHON_VERSION}
PYTHON_LIBDIR= ${PYTHONBASE}/lib/${PYTHON_VERSION}
diff --git a/UPDATING b/UPDATING
index d3daeae5bfac..84d6aa1c2ae1 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,16 @@ You should get into the habit of checking this file for changes each
time you update your ports collection, before attempting any port
upgrades.
+20041202:
+ AFFECTS: users of any ports using Python
+ AUTHOR: perky@FreeBSD.org
+
+ After upgrading of lang/python, you must rebuild all its consumer
+ ports to make them get ready to Python 2.5.
+
+ To do this, you will need to:
+ pkgdb -uf && cd /usr/ports/lang/python && make upgrade-site-packages
+
20061007:
AFFECTS: users of security/p5-openxpki
AUTHOR: svysh@cryptocom.ru