aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 08:59:55 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 08:59:55 +0000
commitae5c06adc437383034e8eaa5627af21d97b09be5 (patch)
tree6ec4c07f0d5e706ea6a7a7e178aa47e59b1e8dd8
parentdb21006b8271a1d0ebd0253921784709b8aa23da (diff)
downloadports-ae5c06adc437383034e8eaa5627af21d97b09be5.tar.gz
ports-ae5c06adc437383034e8eaa5627af21d97b09be5.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/bubblegum/Makefile24
-rw-r--r--security/bubblegum/distinfo1
-rw-r--r--security/bubblegum/files/patch-doc-Makefile.in11
-rw-r--r--security/bubblegum/pkg-comment1
-rw-r--r--security/bubblegum/pkg-descr5
-rw-r--r--security/bubblegum/pkg-plist1
7 files changed, 44 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a2e5154a3598..6824867cb022 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -21,6 +21,7 @@
SUBDIR += borzoi
SUBDIR += botan
SUBDIR += bro
+ SUBDIR += bubblegum
SUBDIR += bugs
SUBDIR += ca-roots
SUBDIR += calife
diff --git a/security/bubblegum/Makefile b/security/bubblegum/Makefile
new file mode 100644
index 000000000000..9f4e85556872
--- /dev/null
+++ b/security/bubblegum/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: bubblegum
+# Date created: 5 November 2002
+# Whom: Ben Kibbey <bjk@arbornet.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bubblegum
+PORTVERSION= 1.12
+CATEGORIES= security
+MASTER_SITES= http://arbornet.org/~bjk/bubblegum/
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= bubblegum.1
+MANCOMPRESSED= no
+
+pre-build:
+ ${CP} ${WRKSRC}/doc/bubblegum.man ${WRKSRC}/doc/bubblegum.1
+
+.include <bsd.port.mk>
diff --git a/security/bubblegum/distinfo b/security/bubblegum/distinfo
new file mode 100644
index 000000000000..98d0991d444f
--- /dev/null
+++ b/security/bubblegum/distinfo
@@ -0,0 +1 @@
+MD5 (bubblegum-1.12.tar.gz) = b0cea809735aa3ab85cbc3a577ef8aeb
diff --git a/security/bubblegum/files/patch-doc-Makefile.in b/security/bubblegum/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..139ae2830e6a
--- /dev/null
+++ b/security/bubblegum/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Tue Oct 8 09:51:06 2002
++++ doc/Makefile.in Tue Nov 5 16:59:24 2002
+@@ -114,7 +114,7 @@
+ target_cpu = @target_cpu@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
+-dist_man1_MANS = bubblegum.man
++dist_man1_MANS = bubblegum.1
+ subdir = doc
+ mkinstalldirs = $(SHELL) $(top_srcdir)/build/mkinstalldirs
+ CONFIG_HEADER = $(top_builddir)/config.h
diff --git a/security/bubblegum/pkg-comment b/security/bubblegum/pkg-comment
new file mode 100644
index 000000000000..8361f4e5ec6d
--- /dev/null
+++ b/security/bubblegum/pkg-comment
@@ -0,0 +1 @@
+Watch a file for changes
diff --git a/security/bubblegum/pkg-descr b/security/bubblegum/pkg-descr
new file mode 100644
index 000000000000..d13a91a62a83
--- /dev/null
+++ b/security/bubblegum/pkg-descr
@@ -0,0 +1,5 @@
+Bubblegum is a daemon which watches a file for changes in access, modification
+and inode change times and MD5 checksums. It can run a command upon a change
+a specified number of times, read from a file list and more.
+
+WWW: http://arbornet.org/~bjk/bubblegum/
diff --git a/security/bubblegum/pkg-plist b/security/bubblegum/pkg-plist
new file mode 100644
index 000000000000..bc0bd784da04
--- /dev/null
+++ b/security/bubblegum/pkg-plist
@@ -0,0 +1 @@
+bin/bubblegum