aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2017-09-19 12:30:39 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2017-09-19 12:30:39 +0000
commitb7324e218426eafd17bd13a4d09a132c7b925d55 (patch)
tree1c87e861bd60a153995defb2ca9ae52f7728a532
parente0540bb8b4ca7f682d70b8fb342986759bdb73f8 (diff)
downloadports-b7324e218426eafd17bd13a4d09a132c7b925d55.tar.gz
ports-b7324e218426eafd17bd13a4d09a132c7b925d55.zip
MFH: r450118
- Add backport of patch for CVE-2017-9798 - Bump PORTREVISION Approved by: ports-secteam (with hat) Security: 76b085e2-9d33-11e7-9260-000c292ee6b8
Notes
Notes: svn path=/branches/2017Q3/; revision=450119
-rw-r--r--www/apache22/Makefile2
-rw-r--r--www/apache22/files/patch-CVE-2017-979821
2 files changed, 22 insertions, 1 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index b31782474965..dc02e108a662 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -2,7 +2,7 @@
PORTNAME= apache22
PORTVERSION= 2.2.34
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= www ipv6
MASTER_SITES= APACHE_HTTPD
DISTNAME= httpd-${PORTVERSION}
diff --git a/www/apache22/files/patch-CVE-2017-9798 b/www/apache22/files/patch-CVE-2017-9798
new file mode 100644
index 000000000000..c2f9198e8acf
--- /dev/null
+++ b/www/apache22/files/patch-CVE-2017-9798
@@ -0,0 +1,21 @@
+CVE-2017-9798
+
+Backport from https://svn.apache.org/viewvc?view=revision&revision=1807655
+
+diff --git a/server/core.c b/server/core.c
+index f61699e..d24542e 100644
+--- server/core.c
++++ server/core.c
+@@ -1809,6 +1809,12 @@ AP_CORE_DECLARE_NONSTD(const char *) ap_limit_section(cmd_parms *cmd,
+ /* method has not been registered yet, but resorce restriction
+ * is always checked before method handling, so register it.
+ */
++ if (cmd->pool == cmd->temp_pool) {
++ /* In .htaccess, we can't globally register new methods. */
++ return apr_psprintf(cmd->pool, "Could not register method '%s' "
++ "for %s from .htaccess configuration",
++ method, cmd->cmd->name);
++ }
+ methnum = ap_method_register(cmd->pool, method);
+ }
+