aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-07 17:15:06 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-07 17:15:06 +0000
commitcd1d50eb08fefd091401ac45d81c225ac24920fc (patch)
treef5195afcb927cef5e3ed6aec9dd6e655c101af1e
parentc8b2a40e7936d06271e36a2b20c453a478fe308e (diff)
downloadports-cd1d50eb08fefd091401ac45d81c225ac24920fc.tar.gz
ports-cd1d50eb08fefd091401ac45d81c225ac24920fc.zip
Notes
-rw-r--r--devel/ruby-amstd/Makefile66
-rw-r--r--devel/ruby-amstd/distinfo1
-rw-r--r--devel/ruby-amstd/pkg-comment1
-rw-r--r--devel/ruby-amstd/pkg-descr17
-rw-r--r--devel/ruby-amstd/pkg-plist26
-rw-r--r--devel/ruby-date2/Makefile56
-rw-r--r--devel/ruby-date2/distinfo1
-rw-r--r--devel/ruby-date2/pkg-comment1
-rw-r--r--devel/ruby-date2/pkg-descr8
-rw-r--r--devel/ruby-date2/pkg-plist23
-rw-r--r--devel/ruby-strscan/Makefile58
-rw-r--r--devel/ruby-strscan/distinfo1
-rw-r--r--devel/ruby-strscan/pkg-comment1
-rw-r--r--devel/ruby-strscan/pkg-descr4
-rw-r--r--devel/ruby-strscan/pkg-plist14
15 files changed, 278 insertions, 0 deletions
diff --git a/devel/ruby-amstd/Makefile b/devel/ruby-amstd/Makefile
new file mode 100644
index 000000000000..b0ab5d003c2f
--- /dev/null
+++ b/devel/ruby-amstd/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: Ruby-amstd
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= amstd
+PORTVERSION= 1.9.3
+CATEGORIES= devel # ruby
+MASTER_SITES= http://www1.u-netsurf.ne.jp/~brew/mine/soft/
+PKGNAMEPREFIX= ruby-
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_BUILD= yes
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+DOCS_EN= README.en
+DOCS_JA= README.ja
+MODULES= bench.rb \
+ bug.rb \
+ collfrom.rb \
+ dispatch.rb \
+ errutil.rb \
+ extmod.rb \
+ fileutils.rb \
+ futils.rb \
+ gconst.rb \
+ getdep.rb \
+ info.rb \
+ must.rb \
+ pipeline.rb \
+ rbparams.rb \
+ recycle.rb \
+ rubyemu.rb \
+ strquote.rb \
+ symbol.rb \
+ timer.rb \
+ to_s.rb \
+ version.rb
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/amstd
+.for f in ${MODULES}
+ ${INSTALL_DATA} ${WRKSRC}/lib/amstd/${f} \
+ ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/amstd/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/amstd/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/amstd/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/amstd/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-amstd/distinfo b/devel/ruby-amstd/distinfo
new file mode 100644
index 000000000000..a6e9a38b536d
--- /dev/null
+++ b/devel/ruby-amstd/distinfo
@@ -0,0 +1 @@
+MD5 (amstd-1.9.3.tar.gz) = 7a7bb9606d848a16e2f1ddc8a3364216
diff --git a/devel/ruby-amstd/pkg-comment b/devel/ruby-amstd/pkg-comment
new file mode 100644
index 000000000000..5af1e7c61a06
--- /dev/null
+++ b/devel/ruby-amstd/pkg-comment
@@ -0,0 +1 @@
+A collection of miscellaneous Ruby modules
diff --git a/devel/ruby-amstd/pkg-descr b/devel/ruby-amstd/pkg-descr
new file mode 100644
index 000000000000..b521016fc69b
--- /dev/null
+++ b/devel/ruby-amstd/pkg-descr
@@ -0,0 +1,17 @@
+This is the AMbicious STanDard library, available under GPL2.
+
+It is a collection of miscellaneous Ruby modules by Minero Aoki.
+Several modules of his are using those modules.
+
+bench.rb: very simple benchmark packing.rb: makes package (.tar.gz)
+bug.rb: 'bug!' method pipeline.rb: filter file
+dispatch.rb: "event handler" method rbparams.rb: parameters related ruby
+errutil.rb: protects exception recycle.rb: recycles objects
+extmod.rb: abstract/property methods rubyemu.rb: ruby emuration
+futils.rb: file utilities strquote.rb: String#quoted
+gconst.rb: defines global constant timer.rb: timer class
+getdep.rb: gets file dependency to_s.rb: _name2str, _type2str
+inst.rb: helps installation version.rb: VersionNumber class
+must.rb: must/must_have/must_be methods
+
+WWW: http://www1.u-netsurf.ne.jp/~brew/mine/en/index.html
diff --git a/devel/ruby-amstd/pkg-plist b/devel/ruby-amstd/pkg-plist
new file mode 100644
index 000000000000..3c401737d6ae
--- /dev/null
+++ b/devel/ruby-amstd/pkg-plist
@@ -0,0 +1,26 @@
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/bench.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/bug.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/collfrom.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/dispatch.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/errutil.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/extmod.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/fileutils.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/futils.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/gconst.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/getdep.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/info.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/must.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/pipeline.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/rbparams.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/recycle.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/rubyemu.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/strquote.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/symbol.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/timer.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/to_s.rb
+lib/ruby/site_ruby/%%RUBY_VER%%/amstd/version.rb
+@dirrm lib/ruby/site_ruby/%%RUBY_VER%%/amstd
+share/doc/ruby/amstd/README.en
+share/doc/ruby/amstd/ja/README.ja
+@dirrm share/doc/ruby/amstd/ja
+@dirrm share/doc/ruby/amstd
diff --git a/devel/ruby-date2/Makefile b/devel/ruby-date2/Makefile
new file mode 100644
index 000000000000..24fba534182c
--- /dev/null
+++ b/devel/ruby-date2/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: Ruby-date2
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= date2
+PORTVERSION= 2
+CATEGORIES= devel # ruby
+MASTER_SITES= http://www.kt.rim.or.jp/~tadf/
+PKGNAMEPREFIX= ruby-
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_BUILD= yes
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+MODULES= date2.rb date3.rb holiday.rb odate.rb \
+ parsedate2.rb parsedate2.ry parsedate3.rb \
+ qholiday.rb strftime.rb strptime.rb
+
+DOCS_EN= CHANGES.en MANUAL.en README.en
+DOCS_JA= MANUAL README
+EXAMPLES_EN= cal.rb daylight.rb goodfriday.rb
+EXAMPLES_JA= ncal.rb
+
+do-install:
+.for f in ${MODULES}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${PREFIX}/lib/ruby/site_ruby/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/date2/examples/ja
+ ${MKDIR} ${PREFIX}/share/doc/ruby/date2/ja
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${PREFIX}/share/doc/ruby/date2/examples/
+.endfor
+.for f in ${EXAMPLES_JA}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${PREFIX}/share/doc/ruby/date2/examples/ja/
+.endfor
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/date2/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/date2/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-date2/distinfo b/devel/ruby-date2/distinfo
new file mode 100644
index 000000000000..dad6856030c2
--- /dev/null
+++ b/devel/ruby-date2/distinfo
@@ -0,0 +1 @@
+MD5 (date2-2.tar.gz) = 6180117536bab3d3e8fcbbd47efff841
diff --git a/devel/ruby-date2/pkg-comment b/devel/ruby-date2/pkg-comment
new file mode 100644
index 000000000000..f54f0d0121e0
--- /dev/null
+++ b/devel/ruby-date2/pkg-comment
@@ -0,0 +1 @@
+An alternative date class for Ruby
diff --git a/devel/ruby-date2/pkg-descr b/devel/ruby-date2/pkg-descr
new file mode 100644
index 000000000000..796bfd9b15db
--- /dev/null
+++ b/devel/ruby-date2/pkg-descr
@@ -0,0 +1,8 @@
+date2 is an alternative date class for Ruby.
+
+This class handles calculations about dates. The day of reform can be
+specified freely in this class. The procedures about holiday
+(holiday.rb) and date format (parsedate2.rb, strftime.rb and
+strptime.rb) are also available.
+
+WWW: http://www.kt.rim.or.jp/~tadf/ruby-en.html#date2
diff --git a/devel/ruby-date2/pkg-plist b/devel/ruby-date2/pkg-plist
new file mode 100644
index 000000000000..d5d3928d247e
--- /dev/null
+++ b/devel/ruby-date2/pkg-plist
@@ -0,0 +1,23 @@
+lib/ruby/site_ruby/date2.rb
+lib/ruby/site_ruby/date3.rb
+lib/ruby/site_ruby/holiday.rb
+lib/ruby/site_ruby/odate.rb
+lib/ruby/site_ruby/parsedate2.rb
+lib/ruby/site_ruby/parsedate2.ry
+lib/ruby/site_ruby/parsedate3.rb
+lib/ruby/site_ruby/qholiday.rb
+lib/ruby/site_ruby/strftime.rb
+lib/ruby/site_ruby/strptime.rb
+share/doc/ruby/date2/CHANGES.en
+share/doc/ruby/date2/MANUAL.en
+share/doc/ruby/date2/README.en
+share/doc/ruby/date2/examples/cal.rb
+share/doc/ruby/date2/examples/daylight.rb
+share/doc/ruby/date2/examples/goodfriday.rb
+share/doc/ruby/date2/examples/ja/ncal.rb
+share/doc/ruby/date2/ja/MANUAL
+share/doc/ruby/date2/ja/README
+@dirrm share/doc/ruby/date2/examples/ja
+@dirrm share/doc/ruby/date2/examples
+@dirrm share/doc/ruby/date2/ja
+@dirrm share/doc/ruby/date2
diff --git a/devel/ruby-strscan/Makefile b/devel/ruby-strscan/Makefile
new file mode 100644
index 000000000000..2058c7c22089
--- /dev/null
+++ b/devel/ruby-strscan/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: Ruby-strscan
+# Date created: 7 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= strscan
+PORTVERSION= 0.5.8
+CATEGORIES= devel # ruby
+MASTER_SITES= http://www1.u-netsurf.ne.jp/~brew/mine/soft/
+PKGNAMEPREFIX= ruby-
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby \
+ ${LOCALBASE}/lib/ruby/site_ruby/${RUBY_VER}/amstd/info.rb:${PORTSDIR}/devel/ruby-amstd
+
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+DOCS_EN= README.en \
+ doc.en/changes.html doc.en/index.html \
+ doc.en/reference.html doc.en/usage.html
+DOCS_JA= doc.ja/changes.html doc.ja/index.html \
+ doc.ja/reference.html doc.ja/usage.html
+EXAMPLES= lib/strscan/scanner.rb
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${CONFIGURE_ENV} ${RUBY} setup.rb config
+
+do-build:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${RUBY} setup.rb setup
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/ext/strscanso/strscan.so \
+ ${PREFIX}/lib/ruby/site_ruby/${RUBY_VER}/${RUBY_ARCH}/
+ ${MKDIR} ${PREFIX}/share/examples/ruby/strscan
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/examples/ruby/strscan/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/strscan/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/strscan/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/ruby/strscan/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-strscan/distinfo b/devel/ruby-strscan/distinfo
new file mode 100644
index 000000000000..8c9a7fce20d8
--- /dev/null
+++ b/devel/ruby-strscan/distinfo
@@ -0,0 +1 @@
+MD5 (strscan-0.5.8.tar.gz) = 91afc597b8210b79a788163f0c01d429
diff --git a/devel/ruby-strscan/pkg-comment b/devel/ruby-strscan/pkg-comment
new file mode 100644
index 000000000000..7925263c45cc
--- /dev/null
+++ b/devel/ruby-strscan/pkg-comment
@@ -0,0 +1 @@
+Fast string scanner class for Ruby
diff --git a/devel/ruby-strscan/pkg-descr b/devel/ruby-strscan/pkg-descr
new file mode 100644
index 000000000000..3da7d48746c5
--- /dev/null
+++ b/devel/ruby-strscan/pkg-descr
@@ -0,0 +1,4 @@
+StrScanner is a fast string scanner class for Ruby. It is very useful
+in writing a parser.
+
+WWW: http://www1.u-netsurf.ne.jp/~brew/mine/en/index.html
diff --git a/devel/ruby-strscan/pkg-plist b/devel/ruby-strscan/pkg-plist
new file mode 100644
index 000000000000..ff0bb8f5acdd
--- /dev/null
+++ b/devel/ruby-strscan/pkg-plist
@@ -0,0 +1,14 @@
+lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/strscan.so
+share/examples/ruby/strscan/scanner.rb
+@dirrm share/examples/ruby/strscan
+share/doc/ruby/strscan/README.en
+share/doc/ruby/strscan/changes.html
+share/doc/ruby/strscan/index.html
+share/doc/ruby/strscan/reference.html
+share/doc/ruby/strscan/usage.html
+share/doc/ruby/strscan/ja/changes.html
+share/doc/ruby/strscan/ja/index.html
+share/doc/ruby/strscan/ja/reference.html
+share/doc/ruby/strscan/ja/usage.html
+@dirrm share/doc/ruby/strscan/ja
+@dirrm share/doc/ruby/strscan