aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2012-09-13 06:19:26 +0000
committerWen Heping <wen@FreeBSD.org>2012-09-13 06:19:26 +0000
commite9d9c57472ff259e211bcb907b8b7c6ed95e21c3 (patch)
tree7101ab89873fff4261cc4bf2cc2b5116dac85bd2
parent11a3bd1312913ed774a67c666bd844e385f2c1d8 (diff)
downloadports-e9d9c57472ff259e211bcb907b8b7c6ed95e21c3.tar.gz
ports-e9d9c57472ff259e211bcb907b8b7c6ed95e21c3.zip
Notes
-rw-r--r--graphics/mapserver/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 9f34312bc98d..962cce665759 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -85,14 +85,16 @@ CONFIGURE_ARGS+= --with-pdf=${LOCALBASE} --with-tiff=${LOCALBASE} --with-png=${L
.endif
.if ${PORT_OPTIONS:MWMS}
-WITH_CURL= yes
-CONFIGURE_ARGS+= --with-wms --with-wmsclient
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --with-curl=${LOCALBASE} --with-wms --with-wmsclient
.endif
.if ${PORT_OPTIONS:MWFS}
-WITH_CURL= yes
-WITH_GDAL= yes
-CONFIGURE_ARGS+= --with-wfs --with-wfsclient
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl \
+ gdal:${PORTSDIR}/graphics/gdal
+CONFIGURE_ARGS+= --with-wfs --with-wfsclient --with-curl=${LOCALBASE} \
+ --with-gdal=${LOCALBASE}/bin/gdal-config \
+ --with-ogr=${LOCALBASE}/bin/gdal-config
.endif
.if ${PORT_OPTIONS:MGDAL}