aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-06 07:00:15 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-06 07:00:15 +0000
commitee79f6d785df6f3cd95e310217b654e7ddbf984a (patch)
treee056c71dcec2891a27063c3d2ff95b45626ce6d4
parentd8771481e0d9feb41858258fb28adbfe2dc62f66 (diff)
downloadports-ee79f6d785df6f3cd95e310217b654e7ddbf984a.tar.gz
ports-ee79f6d785df6f3cd95e310217b654e7ddbf984a.zip
Notes
-rw-r--r--net/libproxy-perl/Makefile2
-rw-r--r--net/p5-IP-Anonymous/Makefile3
-rw-r--r--net/p5-Net-Amazon-Signature/Makefile3
-rw-r--r--net/p5-Net-Analysis/Makefile3
-rw-r--r--net/p5-Net-EPP/Makefile3
-rw-r--r--net/p5-Net-FS-Gmail/Makefile3
-rw-r--r--net/p5-Net-Frame-Layer-ICMPv6/Makefile3
-rw-r--r--net/p5-Net-INET6Glue/Makefile3
-rw-r--r--net/p5-Net-Jaiku/Makefile3
-rw-r--r--net/p5-Net-Ping-External/Makefile3
-rw-r--r--net/p5-Net-PubSubHubbub-Publisher/Makefile3
-rw-r--r--net/p5-Net-SMS-PChome/Makefile3
-rw-r--r--net/p5-Net-Traceroute/Makefile3
-rw-r--r--net/p5-Net-Whois/Makefile3
-rw-r--r--net/p5-Phone-Info/Makefile3
-rw-r--r--net/p5-Test-URI/Makefile3
-rw-r--r--net/p5-URI-FromHash/Makefile3
-rw-r--r--net/ripe-whois/Makefile3
-rw-r--r--net/xbone/Makefile2
19 files changed, 36 insertions, 19 deletions
diff --git a/net/libproxy-perl/Makefile b/net/libproxy-perl/Makefile
index c6b0db8d044d..b8ecb2162bd1 100644
--- a/net/libproxy-perl/Makefile
+++ b/net/libproxy-perl/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= proxy.1:${PORTSDIR}/net/libproxy
MASTERDIR= ${.CURDIR}/../libproxy
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
-USE_PERL5= yes
+USES= perl5
LIBPROXY_SLAVE= perl
diff --git a/net/p5-IP-Anonymous/Makefile b/net/p5-IP-Anonymous/Makefile
index b35d8b5a3ae5..72e2cae96a57 100644
--- a/net/p5-IP-Anonymous/Makefile
+++ b/net/p5-IP-Anonymous/Makefile
@@ -16,7 +16,8 @@ COMMENT= Perl extension to provide anonymous IP addresses
RUN_DEPENDS= p5-Crypt-Rijndael>=0:${PORTSDIR}/security/p5-Crypt-Rijndael
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IP::Anonymous.3
diff --git a/net/p5-Net-Amazon-Signature/Makefile b/net/p5-Net-Amazon-Signature/Makefile
index 2357b2313abc..af9e4195a4db 100644
--- a/net/p5-Net-Amazon-Signature/Makefile
+++ b/net/p5-Net-Amazon-Signature/Makefile
@@ -19,7 +19,8 @@ TEST_DEPENDS= p5-Spiffy>=0:${PORTSDIR}/devel/p5-Spiffy \
p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Amazon::Signature.3
diff --git a/net/p5-Net-Analysis/Makefile b/net/p5-Net-Analysis/Makefile
index 329b6e6a4f74..b5acc454e1e4 100644
--- a/net/p5-Net-Analysis/Makefile
+++ b/net/p5-Net-Analysis/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= p5-Net-Pcap>=0:${PORTSDIR}/net/p5-Net-Pcap \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Analysis.3 \
Net::Analysis::Constants.3 \
diff --git a/net/p5-Net-EPP/Makefile b/net/p5-Net-EPP/Makefile
index de3a4af8f957..d978bb816c13 100644
--- a/net/p5-Net-EPP/Makefile
+++ b/net/p5-Net-EPP/Makefile
@@ -63,6 +63,7 @@ MAN3= Net::EPP.3 \
Net::EPP::Frame::Command::Transfer::Contact.3 \
Net::EPP::Frame::Command::Poll::Ack.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/net/p5-Net-FS-Gmail/Makefile b/net/p5-Net-FS-Gmail/Makefile
index 20697777ef1f..6b3aa6870544 100644
--- a/net/p5-Net-FS-Gmail/Makefile
+++ b/net/p5-Net-FS-Gmail/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Mail-Webmail-Gmail>=0:${PORTSDIR}/mail/p5-Mail-Webmail-Gmail \
p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= gmailfs.1
MAN3= Net::FS::Gmail.3
diff --git a/net/p5-Net-Frame-Layer-ICMPv6/Makefile b/net/p5-Net-Frame-Layer-ICMPv6/Makefile
index e36f102f7047..cad8e59d7e00 100644
--- a/net/p5-Net-Frame-Layer-ICMPv6/Makefile
+++ b/net/p5-Net-Frame-Layer-ICMPv6/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector \
p5-Class-Gomor>=1.00:${PORTSDIR}/devel/p5-Class-Gomor
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Frame::Layer::ICMPv6.3 \
Net::Frame::Layer::ICMPv6::DestUnreach.3 \
diff --git a/net/p5-Net-INET6Glue/Makefile b/net/p5-Net-INET6Glue/Makefile
index 942de3cd7283..c65e87bdeb0d 100644
--- a/net/p5-Net-INET6Glue/Makefile
+++ b/net/p5-Net-INET6Glue/Makefile
@@ -18,7 +18,8 @@ COMMENT= Make common modules IPv6 ready by hotpatching
BUILD_DEPENDS= p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::INET6Glue.3 \
Net::INET6Glue::FTP.3 \
diff --git a/net/p5-Net-Jaiku/Makefile b/net/p5-Net-Jaiku/Makefile
index 18fc32a0ebb4..cc6cd36cd3b4 100644
--- a/net/p5-Net-Jaiku/Makefile
+++ b/net/p5-Net-Jaiku/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
p5-JSON-Any>0:${PORTSDIR}/converters/p5-JSON-Any \
p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Jaiku.3
diff --git a/net/p5-Net-Ping-External/Makefile b/net/p5-Net-Ping-External/Makefile
index 145502faab66..f85501669ac5 100644
--- a/net/p5-Net-Ping-External/Makefile
+++ b/net/p5-Net-Ping-External/Makefile
@@ -18,7 +18,8 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
USE_ZIP= yes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Ping::External.3
diff --git a/net/p5-Net-PubSubHubbub-Publisher/Makefile b/net/p5-Net-PubSubHubbub-Publisher/Makefile
index 4b118075a1d9..5dc2523af706 100644
--- a/net/p5-Net-PubSubHubbub-Publisher/Makefile
+++ b/net/p5-Net-PubSubHubbub-Publisher/Makefile
@@ -16,7 +16,8 @@ COMMENT= Client library to ping a PubSubHubbub hub
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::PubSubHubbub::Publisher.3
diff --git a/net/p5-Net-SMS-PChome/Makefile b/net/p5-Net-SMS-PChome/Makefile
index d66e47d7f248..8e947949a56e 100644
--- a/net/p5-Net-SMS-PChome/Makefile
+++ b/net/p5-Net-SMS-PChome/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::SMS::PChome.3
diff --git a/net/p5-Net-Traceroute/Makefile b/net/p5-Net-Traceroute/Makefile
index 616aefcd4c43..9d069f4c0a4b 100644
--- a/net/p5-Net-Traceroute/Makefile
+++ b/net/p5-Net-Traceroute/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl module to parse traceroute(8)
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Traceroute.3
diff --git a/net/p5-Net-Whois/Makefile b/net/p5-Net-Whois/Makefile
index 706b9640a251..738ed26b7ee2 100644
--- a/net/p5-Net-Whois/Makefile
+++ b/net/p5-Net-Whois/Makefile
@@ -16,7 +16,8 @@ COMMENT= A perl5 module to get information using the Whois protocol
RUN_DEPENDS= p5-Locale-Codes>=0:${PORTSDIR}/misc/p5-Locale-Codes
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Whois.3
diff --git a/net/p5-Phone-Info/Makefile b/net/p5-Phone-Info/Makefile
index 15a3c5dbb001..a56bd4431af3 100644
--- a/net/p5-Phone-Info/Makefile
+++ b/net/p5-Phone-Info/Makefile
@@ -17,7 +17,8 @@ COMMENT= Provides a nicer CLI interface to Net::WhitePages
RUN_DEPENDS= p5-Net-WhitePages>=0:${PORTSDIR}/net/p5-Net-WhitePages
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Phone::Info.3
diff --git a/net/p5-Test-URI/Makefile b/net/p5-Test-URI/Makefile
index e5500b37090d..894b55f42efd 100644
--- a/net/p5-Test-URI/Makefile
+++ b/net/p5-Test-URI/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::URI.3
diff --git a/net/p5-URI-FromHash/Makefile b/net/p5-URI-FromHash/Makefile
index e1875ba84bdd..9968473ef6e5 100644
--- a/net/p5-URI-FromHash/Makefile
+++ b/net/p5-URI-FromHash/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
p5-URI>=1.22:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= URI::FromHash.3
diff --git a/net/ripe-whois/Makefile b/net/ripe-whois/Makefile
index df5ee30e6e43..78bd8dc187fc 100644
--- a/net/ripe-whois/Makefile
+++ b/net/ripe-whois/Makefile
@@ -14,7 +14,8 @@ DISTNAME= whois3-${PORTVERSION}
MAINTAINER= lerik@nolink.net
COMMENT= The RIPE whois client version 3
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
diff --git a/net/xbone/Makefile b/net/xbone/Makefile
index 6068dbba2762..147216e34d8c 100644
--- a/net/xbone/Makefile
+++ b/net/xbone/Makefile
@@ -42,7 +42,7 @@ BUILD_DEPENDS= p5-AppConfig>=0:${PORTSDIR}/devel/p5-AppConfig \
USE_GMAKE= yes
#IS_INTERACTIVE= yes
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
USE_OPENLDAP= yes
INSTALL_TARGET= node