aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-08-30 23:09:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-08-30 23:09:24 +0000
commitf811bf8ec54bdf5c145f71aa36f4abe1eec95678 (patch)
treeda7b3e5b0d7d95967eb096484d74d48d57ebcf02
parent5163781803124a083a6fdae72fd2235faf64ac0c (diff)
downloadports-f811bf8ec54bdf5c145f71aa36f4abe1eec95678.tar.gz
ports-f811bf8ec54bdf5c145f71aa36f4abe1eec95678.zip
Notes
-rw-r--r--benchmarks/autobench/Makefile3
-rw-r--r--benchmarks/fio/Makefile2
-rw-r--r--benchmarks/gtkperf/Makefile22
-rw-r--r--benchmarks/httperf/Makefile8
-rw-r--r--benchmarks/imb/Makefile8
-rw-r--r--benchmarks/libmicro/Makefile2
-rw-r--r--benchmarks/lmbench/Makefile8
-rw-r--r--benchmarks/netio/Makefile7
-rw-r--r--benchmarks/netperfmeter/Makefile2
-rw-r--r--benchmarks/nttcp/Makefile8
-rw-r--r--benchmarks/pathload/Makefile8
-rw-r--r--benchmarks/pathrate/Makefile8
-rw-r--r--benchmarks/pnetmark/Makefile8
-rw-r--r--benchmarks/postal/Makefile9
-rw-r--r--benchmarks/randomio/Makefile8
-rw-r--r--benchmarks/sipp/Makefile2
-rw-r--r--benchmarks/thrulay/Makefile7
-rw-r--r--benchmarks/tsung/Makefile4
-rw-r--r--benchmarks/wrk/Makefile2
19 files changed, 41 insertions, 85 deletions
diff --git a/benchmarks/autobench/Makefile b/benchmarks/autobench/Makefile
index b8f0d5617418..a59b260480d9 100644
--- a/benchmarks/autobench/Makefile
+++ b/benchmarks/autobench/Makefile
@@ -17,8 +17,7 @@ RUN_DEPENDS= httperf:${PORTSDIR}/benchmarks/httperf \
LICENSE= GPLv2
-USE_PERL5= yes
-USE_GMAKE= yes
+USES= gmake perl5
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" DEBUG_FLAGS= \
PREFIX=${PREFIX}
diff --git a/benchmarks/fio/Makefile b/benchmarks/fio/Makefile
index cd8f2806af17..8b778cad7b88 100644
--- a/benchmarks/fio/Makefile
+++ b/benchmarks/fio/Makefile
@@ -12,8 +12,8 @@ COMMENT= FIO - flexible IO tester
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
OPTIONS_DEFINE= GNUPLOT
GNUPLOT_DESC= Support for plotting graphs
diff --git a/benchmarks/gtkperf/Makefile b/benchmarks/gtkperf/Makefile
index 5f79a44265c9..c2963022a069 100644
--- a/benchmarks/gtkperf/Makefile
+++ b/benchmarks/gtkperf/Makefile
@@ -1,20 +1,20 @@
# Created by: Andreas Kohn <andreas@syndrom23.de>
# $FreeBSD$
-PORTNAME= gtkperf
-PORTVERSION= 0.40
+PORTNAME= gtkperf
+PORTVERSION= 0.40
PORTREVISION= 9
-CATEGORIES= benchmarks
-MASTER_SITES= SF
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+CATEGORIES= benchmarks
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Measure your system's GTK+ performance
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Measure your system's GTK+ performance
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_GNOME= gtk20 gnomeprefix
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= gmake
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20 gnomeprefix
.include <bsd.port.options.mk>
diff --git a/benchmarks/httperf/Makefile b/benchmarks/httperf/Makefile
index dfb25e8d4423..ea06b7d48dcb 100644
--- a/benchmarks/httperf/Makefile
+++ b/benchmarks/httperf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: httperf
-# Date created: 28 Jul 1999
-# Whom: Will Andrews <andrews@technologist.com>
-#
+# Created by: Will Andrews <andrews@technologist.com>
# $FreeBSD$
-#
PORTNAME= httperf
PORTVERSION= 0.9.0
@@ -17,7 +13,7 @@ LICENSE= GPLv2
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
MAKE_ARGS= LIBUTIL_OBJS=ssl_writev.o \
exec_prefix=${PREFIX}
diff --git a/benchmarks/imb/Makefile b/benchmarks/imb/Makefile
index 4d8dee692f99..00cd74c814d0 100644
--- a/benchmarks/imb/Makefile
+++ b/benchmarks/imb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: imb
-# Date created: 2006-11-19
-# Whom: trasz <trasz@pin.if.uz.zgora.pl>
-#
+# Created by: trasz <trasz@pin.if.uz.zgora.pl>
# $FreeBSD$
-#
PORTNAME= imb
PORTVERSION= 3.0
@@ -19,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Intel MPI Benchmark
WRKSRC= ${WRKDIR}/IMB_3.0/src/
-USE_GMAKE= yes
+USES= gmake
USE_DOS2UNIX= yes
MAKEFILE= make_mpich
ALL_TARGET= all
diff --git a/benchmarks/libmicro/Makefile b/benchmarks/libmicro/Makefile
index ddeaa23f69d8..80e56496ea9c 100644
--- a/benchmarks/libmicro/Makefile
+++ b/benchmarks/libmicro/Makefile
@@ -14,7 +14,7 @@ LICENSE= CDDL
WRKSRC= ${WRKDIR}/libMicro-${PORTVERSION}
-USE_GMAKE= yes
+USES= gmake
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
CFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/benchmarks/lmbench/Makefile b/benchmarks/lmbench/Makefile
index bf3a3fc11999..8fc66a2d369a 100644
--- a/benchmarks/lmbench/Makefile
+++ b/benchmarks/lmbench/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lmbench
-# Date created: 6 May 1995
-# Whom: asami
-#
+# Created by: asami
# $FreeBSD$
-#
PORTNAME= lmbench
PORTVERSION= 3.0.a9
@@ -31,7 +27,7 @@ MAN8= bw_file_rd.8 bw_mem.8 bw_mem_rd.8 bw_mmap_rd.8 \
lat_unix_connect.8 line.8 lmbench.8 lmdd.8 mhz.8 \
par_mem.8 par_ops.8 stream.8 tlb.8
-USE_GMAKE= yes
+USES= gmake
# the bindir for the PLIST is:
# (note that ./os needs to be run inside the work dir, running it
diff --git a/benchmarks/netio/Makefile b/benchmarks/netio/Makefile
index bb4def0b95ad..cc2cdcf39ea4 100644
--- a/benchmarks/netio/Makefile
+++ b/benchmarks/netio/Makefile
@@ -1,7 +1,4 @@
-# New ports collection Makefile for: netio
-# Date created: 2005-01-09
-# Whom: arved
-#
+# Created by: arved
# $FreeBSD$
PORTNAME= netio
@@ -16,7 +13,7 @@ COMMENT= Network benchmark
WRKSRC= ${WRKDIR}
USE_ZIP= yes
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/netio
CFLAGS+= -DUNIX ${PTHREAD_CFLAGS}
diff --git a/benchmarks/netperfmeter/Makefile b/benchmarks/netperfmeter/Makefile
index e2c759942b34..c647adaa7459 100644
--- a/benchmarks/netperfmeter/Makefile
+++ b/benchmarks/netperfmeter/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= dreibh@iem.uni-due.de
COMMENT= Network Performance Meter
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/netperfmeter
MAN1= netperfmeter.1
diff --git a/benchmarks/nttcp/Makefile b/benchmarks/nttcp/Makefile
index 6ffb5eb7594c..6aad71c64d84 100644
--- a/benchmarks/nttcp/Makefile
+++ b/benchmarks/nttcp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nttcp
-# Date created: 11 Nov 1998
-# Whom: Bill Fumerola <billf@chc-chimes.com>
-#
+# Created by: Bill Fumerola <billf@chc-chimes.com>
# $FreeBSD$
-#
PORTNAME= nttcp
PORTVERSION= 1.47
@@ -20,7 +16,7 @@ RESTRICTED= No commercial use
ALL_TARGET= nttcp
MAN1= nttcp.1
PLIST_FILES= bin/nttcp
-USE_GMAKE= yes
+USES= gmake
MAKE_ENV+= OPT="${CFLAGS}"
NOPRECIOUSMAKEVARS=yes
diff --git a/benchmarks/pathload/Makefile b/benchmarks/pathload/Makefile
index dbff01bf2207..8c39aac57700 100644
--- a/benchmarks/pathload/Makefile
+++ b/benchmarks/pathload/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pathload
-# Date created: 19 May 2005
-# Whom: dikshie <dikshie@lapi.itb.ac.id>
-#
+# Created by: dikshie <dikshie@lapi.itb.ac.id>
# $FreeBSD$
-#
PORTNAME= pathload
PORTVERSION= 1.3.2
@@ -15,7 +11,7 @@ MAINTAINER= dikshie@lapi.itb.ac.id
COMMENT= A measurement tool for network path available bandwidth estimation
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
MAKEFILE= makefile
diff --git a/benchmarks/pathrate/Makefile b/benchmarks/pathrate/Makefile
index ee5cc9ec2229..f2e03ab8b7a3 100644
--- a/benchmarks/pathrate/Makefile
+++ b/benchmarks/pathrate/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pathrate
-# Date created: 19 May 2005
-# Whom: dikshie <dikshie@lapi.itb.ac.id>
-#
+# Created by: dikshie <dikshie@lapi.itb.ac.id>
# $FreeBSD$
-#
PORTNAME= pathrate
PORTVERSION= 2.4.1
@@ -15,7 +11,7 @@ MAINTAINER= dikshie@lapi.itb.ac.id
COMMENT= A measurement tool for capacity estimation of network paths
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
MAKEFILE= makefile
diff --git a/benchmarks/pnetmark/Makefile b/benchmarks/pnetmark/Makefile
index 1a0a9dd62186..3349d25aad72 100644
--- a/benchmarks/pnetmark/Makefile
+++ b/benchmarks/pnetmark/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pnetmark
-# Date created: 2004-03-19
-# Whom: michael johnson <ahze@ahze.net>
-#
+# Created by: michael johnson <ahze@ahze.net>
# $FreeBSD$
-#
PORTNAME= pnetmark
PORTVERSION= 0.0.6
@@ -21,7 +17,7 @@ RUN_DEPENDS= cscc:${PORTSDIR}/lang/pnet-base \
csunit:${PORTSDIR}/lang/pnetlib
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
STRIP= # Nothing to Strip
PORTDOCS= pm_faq.html
PNET_STRAP_BIN= pnetmark \
diff --git a/benchmarks/postal/Makefile b/benchmarks/postal/Makefile
index eee05013edf7..b54b79289dc2 100644
--- a/benchmarks/postal/Makefile
+++ b/benchmarks/postal/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: postal
-# Date created: Apr 2, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= postal
PORTVERSION= 0.72
@@ -22,7 +17,7 @@ OPTIONS_DEFAULT= SSL
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= sbin/bhm sbin/postal bin/postal-list sbin/rabid
diff --git a/benchmarks/randomio/Makefile b/benchmarks/randomio/Makefile
index ae763adaccc8..18bcb6e09f50 100644
--- a/benchmarks/randomio/Makefile
+++ b/benchmarks/randomio/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: randomio
-# Date created: 20 Aug 2010
-# Whom: Sergey Kandaurov <pluknet@gmail.com>
-#
+# Created by: Sergey Kandaurov <pluknet@gmail.com>
# $FreeBSD$
-#
PORTNAME= randomio
PORTVERSION= 1.4
@@ -14,7 +10,7 @@ MAINTAINER= pluknet@gmail.com
COMMENT= A multithreaded disk i/o microbenchmark
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/${PORTNAME}
do-install:
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index 6e6569fcf417..2a333d271312 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
PLIST_FILES= bin/sipp
MAN1= sipp.1
-USE_GMAKE= yes
+USES= gmake
CPP= ${CXX}
MAKE_ENV+= CCLINK="${CXX}"
CPPFLAGS+= ${CXXFLAGS}
diff --git a/benchmarks/thrulay/Makefile b/benchmarks/thrulay/Makefile
index 4d5da2112842..a2f5675d5100 100644
--- a/benchmarks/thrulay/Makefile
+++ b/benchmarks/thrulay/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: thrulay
-# Date created: 2005-10-19
-# Whom: shalunov
-#
+# Created by: shalunov
# $FreeBSD$
PORTNAME= thrulay
@@ -17,7 +14,7 @@ MAN1= thrulay.1
MAN8= thrulayd.8
MANCOMPRESSED= no
HAS_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
USE_RC_SUBR= thrulayd
SUB_FILES= thrulayd
diff --git a/benchmarks/tsung/Makefile b/benchmarks/tsung/Makefile
index ac11ae09c926..a0c47aabfe63 100644
--- a/benchmarks/tsung/Makefile
+++ b/benchmarks/tsung/Makefile
@@ -14,11 +14,11 @@ LICENSE= GPLv2
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_PYTHON_RUN= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake perl5
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/benchmarks/wrk/Makefile b/benchmarks/wrk/Makefile
index c4f74775b1e3..4274ba9769f5 100644
--- a/benchmarks/wrk/Makefile
+++ b/benchmarks/wrk/Makefile
@@ -15,7 +15,7 @@ LICENSE= AL2
FETCH_ARGS= -pRr
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_GMAKE= yes
+USES= gmake
CFLAGS+= -std=c99 -D_DECLARE_C99_LDBL_MATH
PLIST_FILES= bin/wrk