aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-04-10 16:19:04 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-04-10 16:19:04 +0000
commit08bab04de54b82cfcfe31d4cab62f32ef9ead403 (patch)
treecb09d4e84adf5793ef52cfbdd595fa2700fb98a4
parent6e7d58c3969e824c5160f584d96d242ac8afecf3 (diff)
downloadports-08bab04de54b82cfcfe31d4cab62f32ef9ead403.tar.gz
ports-08bab04de54b82cfcfe31d4cab62f32ef9ead403.zip
Notes
-rw-r--r--devel/devhelp/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index 72632dacec14..0ee0fe9c3152 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -19,10 +19,15 @@ COMMENT= Developer help browser for GNOME 2
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_GNOME= gnomehack gnomeprefix libgtkhtml libgnomeui
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|-DG[TD]K_DISABLE_DEPRECATED||g'
+
.include <bsd.port.mk>