aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Chadd <adrian@FreeBSD.org>2001-10-03 10:48:07 +0000
committerAdrian Chadd <adrian@FreeBSD.org>2001-10-03 10:48:07 +0000
commit446f26debe1603738d44b178ab62b6890caefb18 (patch)
tree124ba72c9fcac6f0a5991b9fbdce7e42380f5132
parentfb7f361e2fac12b0c494166f35f51369739bb7b2 (diff)
downloadports-446f26debe1603738d44b178ab62b6890caefb18.tar.gz
ports-446f26debe1603738d44b178ab62b6890caefb18.zip
Notes
-rw-r--r--www/squid23/Makefile116
-rw-r--r--www/squid23/distinfo1
-rw-r--r--www/squid23/files/squid.sh21
-rw-r--r--www/squid23/pkg-comment1
-rw-r--r--www/squid23/pkg-descr17
-rw-r--r--www/squid23/pkg-install41
-rw-r--r--www/squid23/pkg-plist73
7 files changed, 0 insertions, 270 deletions
diff --git a/www/squid23/Makefile b/www/squid23/Makefile
deleted file mode 100644
index c3e475bebbd4..000000000000
--- a/www/squid23/Makefile
+++ /dev/null
@@ -1,116 +0,0 @@
-# New ports collection makefile for: squid
-# Date created: Thu Nov 7 00:53:18 WST 1996
-# Whom: Peter Wemm <peter@freebsd.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= squid
-PORTVERSION= 2.3
-PORTREVISION= 1
-CATEGORIES= www
-MASTER_SITES= \
- ftp://ftp.squid-cache.org/pub/squid-2/STABLE/ \
- ftp://www.unimelb.edu.au/pub/cwis/servers/unix/squid/squid-2/STABLE/ \
- ftp://sunsite.auc.dk/pub/infosystems/squid/squid-2/STABLE/ \
- ftp://ftp.net.lut.ac.uk/squid/squid-2/STABLE/
-DISTNAME= squid-2.3.STABLE5
-EXTRACT_SUFX= -src.tar.gz
-
-PATCH_SITES= http://www.squid-cache.org/Versions/v2/2.3/bugs/
-PATCHFILES=
-MAINTAINER= adrian@freebsd.org
-
-DIST_SUBDIR= squid2.3
-PATCH_DIST_STRIP= -p0
-GNU_CONFIGURE= yes
-# Follow the apache port's lead...
-CONFIGURE_ARGS= --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc/squid \
- --localstatedir=${PREFIX}/squid
-STRIP= # won't install scripts correctly otherwise.
-MAKEFILE= makefile
-
-# Some other configure options..
-# - Compile and use the malloc package from Doug Lea
-#CONFIGURE_ARGS+= --enable-dlmalloc
-# - Compile and use the supplied GNUregex routines instead of BSD regex.
-#CONFIGURE_ARGS+= --enable-gnuregex
-# - Enable simple malloc debugging
-#CONFIGURE_ARGS+= --enable-xmalloc-debug
-# - Detailed trace of memory allocations
-#CONFIGURE_ARGS+= --enable-xmalloc-debug-count
-# - Show malloc statistics in cachemgr status pages
-#CONFIGURE_ARGS+= --enable-xmalloc-statistics
-# - Enable CARP support
-#CONFIGURE_ARGS+= --enable-carp
-# - Use ASYNC disk I/O (Requires real threads, apparently runs on 3.0 libc_r)
-#CONFIGURE_ARGS+= --enable-async-io
-# - Enable ICMP pinging for heirarchy stats and selection
-#CONFIGURE_ARGS+= --enable-icmp
-# - Enable delay pools to limit bandwidth usage
-#CONFIGURE_ARGS+= --enable-delay-pools
-# - Enable generic memory use tracing
-#CONFIGURE+ARGS+= --enable-mem-gen-trace
-# - Enable logging of the User-Agent header
-#CONFIGURE_ARGS+= --enable-useragent-log
-# - Disable Web Cache Coordination Protocol
-#CONFIGURE_ARGS+= --disable-wccp
-# - Kill parent (eg: RunCache) on shutdown (use with great care!!)
-#CONFIGURE_ARGS+= --enable-kill-parent-hack
-# - Turn on SNMP server support
-#CONFIGURE_ARGS+= --enable-snmp
-# - Optimize time updates to one per second rather than calling gettimeofday()
-#CONFIGURE_ARGS+= --enable-time-hack
-# - Set an explicit hostname in cachemgr.cgi
-#CONFIGURE_ARGS+= --enable-cachemgr-hostname=some.hostname
-# - Enable ACL based on ethernet address (eg: for machines with dynamic DHCP
-# assigned IP addresses)
-#CONFIGURE_ARGS+= --enable-arp-acl
-# - Enable HTCP protocol
-#CONFIGURE_ARGS+= --enable-htcp
-# - Enable Forw/Via database
-#CONFIGURE_ARGS+= --enable-forw-via-db
-# - Use Cache Digests - see http://squid.nlanr.net/Squid/FAQ/FAQ-16.html
-#CONFIGURE_ARGS+= --enable-cache-digests
-# - Select language for Error pages (see errors dir)
-#CONFIGURE_ARGS+= --enable-err-language=lang
-# (--enable-poll is not needed, it's detected correctly on 3.0)
-# - Strict HTTP compliance
-#CONFIGURE_ARGS+= --disable-http-violations
-# - Enable Transparent Proxy support for IP-Filter systems (incl 3.0)
-#CONFIGURE_ARGS+= --enable-ipf-transparent
-# (--enable-leakfinder is a developer support tool only)
-# - Compile out code that does optional Ident (RFC931) lookups
-#CONFIGURE_ARGS+= --disable-ident-lookups
-# - Disable squid's internal async DNS lookup code.
-#CONFIGURE_ARGS+= --disable-internal-dns
-# - Use truncate() rather than unlink()
-#CONFIGURE_ARGS+= --enable-truncate
-# - accept the illegal '_' character in hostnames.
-#CONFIGURE_ARGS+= --enable-underscores
-# - Enable control of different heap replacement algorithms at runtime.
-#CONFIGURE_ARGS+= --enable-heap-replacement
-
-post-extract:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-
-post-install:
- cd ${WRKSRC}/src; make install-pinger
-.for file in client squid
- if [ -f ${PREFIX}/sbin/${file} ] ; then \
- strip ${PREFIX}/sbin/${file} ; \
- fi
-.endfor
-.for file in cachemgr.cgi dnsserver pinger unlinkd
- if [ -f ${PREFIX}/libexec/${file} ] ; then \
- strip ${PREFIX}/libexec/${file} ; \
- fi
-.endfor
- ${MKDIR} ${PREFIX}/squid/logs
- ${MKDIR} ${PREFIX}/squid/cache
- @if [ ! -f ${PREFIX}/etc/rc.d/squid.sh ]; then \
- ${ECHO} "Installing ${PREFIX}/etc/rc.d/squid.sh startup file."; \
- ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/squid.sh ${PREFIX}/etc/rc.d/squid.sh; \
- fi
-
-.include <bsd.port.mk>
diff --git a/www/squid23/distinfo b/www/squid23/distinfo
deleted file mode 100644
index 13db60ac92e5..000000000000
--- a/www/squid23/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (squid2.3/squid-2.3.STABLE5-src.tar.gz) = 1a1ae6f496600f3af697692a5ad031f0
diff --git a/www/squid23/files/squid.sh b/www/squid23/files/squid.sh
deleted file mode 100644
index e9a3144e8c93..000000000000
--- a/www/squid23/files/squid.sh
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 1
-fi
-
-case "$1" in
-start)
- if [ -x ${PREFIX}/sbin/RunCache -a -f ${PREFIX}/etc/squid/squid.conf ]; then
- (cd /tmp; ${PREFIX}/sbin/RunCache >/dev/null 2>&1 &) ; echo -n ' squid'
- fi
- ;;
-stop)
- ;;
-*)
- echo "Usage: `basename $0` {start|stop}" >&2
- ;;
-esac
-
-exit 0
diff --git a/www/squid23/pkg-comment b/www/squid23/pkg-comment
deleted file mode 100644
index eec4966b0f07..000000000000
--- a/www/squid23/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-The successful WWW proxy cache and accelerator
diff --git a/www/squid23/pkg-descr b/www/squid23/pkg-descr
deleted file mode 100644
index a030d6c271b8..000000000000
--- a/www/squid23/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-This is the Squid Internet Object Cache developed by the National
-Laboratory for Applied Networking Research (NLANR) and Internet
-volunteers. This software is freely available for anyone to use.
-
-This software is based on the Harvest Object Cache developed by
-the University of Colorado and the University of Southern California.
-The Harvest home page is http://harvest.cs.colorado.edu/.
-
-ARPA funding for the Harvest project has ended, the squid project has
-continued development of the cache where Harvest finished.
-
-FreeBSD PORTER'S NOTES. To this moment, Squid is not well documented.
-But you aren't lost in space: there is a mailing list,
-<squid-users@squid-cache.org>, where you will find some support and help.
-We also _strongly_ suggest you to examine Web pages noted above.
-
-WWW: http://www.squid-cache.org/
diff --git a/www/squid23/pkg-install b/www/squid23/pkg-install
deleted file mode 100644
index 2b6052e5aa11..000000000000
--- a/www/squid23/pkg-install
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/sh
-
-PKGNAME=$1
-
-case $2 in
- PRE-INSTALL)
- ;;
- POST-INSTALL)
- echo "==> Post-installation configuration of ${PKGNAME}"
- echo ""
- echo " o you DO need running nameservice to start and run ${PKGNAME}"
- echo ""
- echo " o use the ${PKGNAME} proxy and caching WWW Server by"
- echo " configuring your WWW Navigator (Netscape, Mosaic,...)"
- echo " to use it as a proxy server."
- echo ""
- echo "==> Press Enter to edit the ${PKGNAME} config file."
- echo " (The defaults are reasonable; and the file is well commented)"
- tput md
- echo " You'd certainly like to pay attention to the"
- echo " ACTUAL locations of cache \"spool\", logfiles, pidfile!"
- tput me
- if [ -z "${PACKAGE_BUILDING}" ]; then read skip; fi
- chown root:wheel ${PREFIX:-/usr/local}/etc/squid/squid.conf*
- chmod 644 ${PREFIX:-/usr/local}/etc/squid/squid.conf*
- [ -f ${PREFIX:-/usr/local}/etc/squid/squid.conf ] || \
- cp -fp ${PREFIX:-/usr/local}/etc/squid/squid.conf.default \
- ${PREFIX:-/usr/local}/etc/squid/squid.conf
- [ -f ${PREFIX:-/usr/local}/etc/squid/mime.conf ] || \
- cp -fp ${PREFIX:-/usr/local}/etc/squid/mime.conf.default \
- ${PREFIX:-/usr/local}/etc/squid/mime.conf
- ${EDITOR:-vi} ${PREFIX:-/usr/local}/etc/squid/squid.conf \
- ${PREFIX:-/usr/local}/etc/squid/mime.conf
- ;;
- *)
- echo "Unexpected Argument $2!!!"
- exit 1
- ;;
-esac
-exit 0
-
diff --git a/www/squid23/pkg-plist b/www/squid23/pkg-plist
deleted file mode 100644
index ba5a312069c2..000000000000
--- a/www/squid23/pkg-plist
+++ /dev/null
@@ -1,73 +0,0 @@
-etc/rc.d/squid.sh
-etc/squid/errors/ERR_ACCESS_DENIED
-etc/squid/errors/ERR_CACHE_ACCESS_DENIED
-etc/squid/errors/ERR_CACHE_MGR_ACCESS_DENIED
-etc/squid/errors/ERR_CANNOT_FORWARD
-etc/squid/errors/ERR_CONNECT_FAIL
-etc/squid/errors/ERR_DNS_FAIL
-etc/squid/errors/ERR_FORWARDING_DENIED
-etc/squid/errors/ERR_FTP_DISABLED
-etc/squid/errors/ERR_FTP_FAILURE
-etc/squid/errors/ERR_FTP_FORBIDDEN
-etc/squid/errors/ERR_FTP_NOT_FOUND
-etc/squid/errors/ERR_FTP_PUT_CREATED
-etc/squid/errors/ERR_FTP_PUT_ERROR
-etc/squid/errors/ERR_FTP_PUT_MODIFIED
-etc/squid/errors/ERR_FTP_UNAVAILABLE
-etc/squid/errors/ERR_INVALID_REQ
-etc/squid/errors/ERR_INVALID_URL
-etc/squid/errors/ERR_LIFETIME_EXP
-etc/squid/errors/ERR_NO_RELAY
-etc/squid/errors/ERR_ONLY_IF_CACHED_MISS
-etc/squid/errors/ERR_READ_ERROR
-etc/squid/errors/ERR_READ_TIMEOUT
-etc/squid/errors/ERR_SHUTTING_DOWN
-etc/squid/errors/ERR_SOCKET_FAILURE
-etc/squid/errors/ERR_TOO_BIG
-etc/squid/errors/ERR_UNSUP_REQ
-etc/squid/errors/ERR_URN_RESOLVE
-etc/squid/errors/ERR_WRITE_ERROR
-etc/squid/errors/ERR_ZERO_SIZE_OBJECT
-etc/squid/icons/anthony-binhex.gif
-etc/squid/icons/anthony-bomb.gif
-etc/squid/icons/anthony-box.gif
-etc/squid/icons/anthony-box2.gif
-etc/squid/icons/anthony-c.gif
-etc/squid/icons/anthony-compressed.gif
-etc/squid/icons/anthony-dir.gif
-etc/squid/icons/anthony-dirup.gif
-etc/squid/icons/anthony-dvi.gif
-etc/squid/icons/anthony-f.gif
-etc/squid/icons/anthony-image.gif
-etc/squid/icons/anthony-image2.gif
-etc/squid/icons/anthony-layout.gif
-etc/squid/icons/anthony-link.gif
-etc/squid/icons/anthony-movie.gif
-etc/squid/icons/anthony-pdf.gif
-etc/squid/icons/anthony-portal.gif
-etc/squid/icons/anthony-ps.gif
-etc/squid/icons/anthony-quill.gif
-etc/squid/icons/anthony-script.gif
-etc/squid/icons/anthony-sound.gif
-etc/squid/icons/anthony-tar.gif
-etc/squid/icons/anthony-tex.gif
-etc/squid/icons/anthony-text.gif
-etc/squid/icons/anthony-unknown.gif
-etc/squid/icons/anthony-xbm.gif
-etc/squid/icons/anthony-xpm.gif
-etc/squid/mib.txt
-etc/squid/mime.conf.default
-etc/squid/squid.conf.default
-libexec/cachemgr.cgi
-libexec/dnsserver
-libexec/pinger
-libexec/unlinkd
-sbin/RunAccel
-sbin/RunCache
-sbin/client
-sbin/squid
-@exec mkdir -p %D/squid/cache
-@exec mkdir -p %D/squid/logs
-@unexec rmdir %D/squid/cache 2>/dev/null || true
-@unexec rmdir %D/squid/logs 2>/dev/null || true
-@unexec rmdir %D/squid 2>/dev/null || true