aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-12 11:45:12 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-12 11:45:12 +0000
commit4cfbd6facf075f02a992dd1012a77ac1e1eab145 (patch)
tree951b18cfc0fc38b51112f71aad462c45ce92e373
parentd69aa36e2c12417af140be228910b9c136d9cc0b (diff)
downloadports-4cfbd6facf075f02a992dd1012a77ac1e1eab145.tar.gz
ports-4cfbd6facf075f02a992dd1012a77ac1e1eab145.zip
MFH: r455800
Fix CVE-2017-16844 - Bump PORTREVISION for package change PR: 223777 Submitted by: Jeremy Chadwick <jdc@koitsu.org>, romain Security: 288f7cee-ced6-11e7-8ae9-0050569f0b83 Approved by: ports-secteam (swills)
Notes
Notes: svn path=/branches/2017Q4/; revision=456121
-rw-r--r--mail/procmail/Makefile2
-rw-r--r--mail/procmail/files/patch-src-formisc.c9
2 files changed, 10 insertions, 1 deletions
diff --git a/mail/procmail/Makefile b/mail/procmail/Makefile
index 6eaf051c3f17..4c11d7c793c3 100644
--- a/mail/procmail/Makefile
+++ b/mail/procmail/Makefile
@@ -3,7 +3,7 @@
PORTNAME= procmail
PORTVERSION= 3.22
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= mail
MASTER_SITES= ftp://ftp.ucsb.edu/pub/mirrors/procmail/ \
ftp://ftp.informatik.rwth-aachen.de/pub/packages/procmail/ \
diff --git a/mail/procmail/files/patch-src-formisc.c b/mail/procmail/files/patch-src-formisc.c
index 2743d6c5f94a..1e9736c14397 100644
--- a/mail/procmail/files/patch-src-formisc.c
+++ b/mail/procmail/files/patch-src-formisc.c
@@ -14,3 +14,12 @@
}
hitspc=2;
}
+@@ -104,7 +103,7 @@
+ }
+ /* append to buf */
+ void loadbuf(text,len)const char*const text;const size_t len;
+-{ if(buffilled+len>buflen) /* buf can't hold the text */
++{ while(buffilled+len>buflen) /* buf can't hold the text */
+ buf=realloc(buf,buflen+=Bsize);
+ tmemmove(buf+buffilled,text,len);buffilled+=len;
+ }